[PATCH] gnu: Add gputils.

  • Done
  • quality assurance status badge
Details
4 participants
  • Ekaitz Zarraga
  • Ludovic Courtès
  • Maxim Cournoyer
  • Simon South
Owner
unassigned
Submitted by
Ekaitz Zarraga
Severity
normal
E
E
Ekaitz Zarraga wrote on 10 Nov 2020 21:23
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
bxJ4DPtJrTnD8NTQWweobLco6VaTctkVeogiP1O-yfOXEwEGTnOwfVvyD0WMcDDxWUWaY_Z45_-HjX40CGXgx_bTHFXfg7n3knC-0Y1KrTk=@elenq.tech
Hi all,

I packaged GPUtils (patch below) but I'm not sure about how to separate the
documentation (a large folder full of htmls) to a "doc" output, like other
packages have. I tried setting --htmldir configure-flag but it didn't change
anything, I also considered moving the docs to the "doc" output by hand in
an extra phase but I don't know if it's the best thing to do.
Ideas?

Thanks!

From 6baa681504c18d9768142937a1d014e59366bee3 Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Tue, 10 Nov 2020 20:30:14 +0100
Subject: [PATCH] gnu: Add gputils.

* gnu/packages/electronics.scm (gputils): New variable.
---
gnu/packages/electronics.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index d21ec61039..2b5fd25a15 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -276,3 +276,23 @@ format support.")
(description "PulseView is a Qt based logic analyzer, oscilloscope and MSO GUI
for sigrok.")
(license license:gpl3+)))
+
+
+(define-public gputils
+ (package
+ (name "gputils")
+ (version "1.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/gputils/gputils/"
+ version "/gputils-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1xfvmvb6zyzs5bqycbvmc6hyl2vp2pv22aaq5974vip4rriklhf7"))))
+ (build-system gnu-build-system)
+ (home-page "https://gputils.sourceforge.io/")
+ (synopsis "GNU PIC Utilities")
+ (description "GPUTILS is a collection of tools for the Microchip (TM) PIC
+microcontrollers. It includes gpasm, gplink, and gplib.")
+ (license license:gpl2+)))
--
2.28.0
S
S
Simon South wrote on 11 Nov 2020 00:04
(address . 44557@debbugs.gnu.org)(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)
87eel0hl09.fsf@simonsouth.net
Ekaitz Zarraga <ekaitz@elenq.tech> writes:
Toggle quote (2 lines)
> I packaged GPUtils...

I hate to jump in here with bad news, but I didn't expect anyone would
package gputils before I got around to sharing this:

While gputils itself is free software, I suspect some of the header
files contained in its distribution may not be, which makes the
licensing status of the project as a whole somewhat dubious. (This is
similar to the problem that affects SDCC[0].) I think gputils should be
reviewed carefully before the decision is made to include it in Guix.

As evidence, I submit the following:

- The "*.inc" files in gputils' "header" subfolder that are intended for
use with PIC devices carry a copyright notice from Microchip[1], the
current owner of the PIC design, but I have found no mention of any
special terms for the files' distribution, nor any notice that they
too have been released under the terms of the GPL.

- SDCC, a free C compiler for microcontrollers, distributes header files
of its own that are also derived from files originally provided by
Microchip. When they approached the company[2] in 2010 to verify they
had permission to distribute their derivative versions under the GPL,
Microchip responded[3] to say the files could be distributed but with
the requirement they be used only with "authentic" PIC-compatible
controllers produced by Microchip themselves. This violates freedom
0[4], making the files non-free and (worse) any software compiled with
SDCC that relies on these files non-free as well.

Consequently, the SDCC project moved these files to a "non-free"
section of their source tree and added build and run-time options to
control their use.

Now here's where things get a little murky:

- The Microchip-copyrighted files from which the SDCC project derives
their non-free header files are... the same Microchip-copyrighted
files gputils provides in its "header" folder. This is clear from the
SDCC manual[5] in section 4.7.10, "Adding New Devices to the Port",
which gives instructions on converting gputils' supposedly free
"*.inc" files into "non-free" header files for use with SDCC.

How is it, then, that these files can be distributed freely under the
GPL with gputils, while files produced from them cannot be freely
distributed with SDCC? I suspect the answer is that _neither_ project
has permission to distribute these files under a free license, and in
the case of gputils, no one has raised the question yet.

Obviously I feel we _should_ raise the question before deciding to
include gputils as a package in Guix. Unfortunately, it is looking to me
as though there may not be a place for PIC-compatible controllers,
Microchip-branded or otherwise, in the free-software world.

[1] See e.g.

--
Simon South
simon@simonsouth.net
E
E
Ekaitz Zarraga wrote on 11 Nov 2020 12:28
(name . Simon South)(address . simon@simonsouth.net)(name . 44557@debbugs.gnu.org)(address . 44557@debbugs.gnu.org)
BtS5wuTVQC9CpLn0jOvaYdDKhyLTz9qZyaAJd9hc9L7B0sjmE6xJyJOxJZ0-shbG5XVtteU-PHeuUuswXJ4Jz_fAuaiFMLk_OHY5d__kwGY=@elenq.tech
??????? Original Message ???????
On Wednesday, November 11, 2020 12:04 AM, Simon South <simon@simonsouth.net> wrote:

Toggle quote (14 lines)
> Ekaitz Zarraga ekaitz@elenq.tech writes:
>
> > I packaged GPUtils...
>
> I hate to jump in here with bad news, but I didn't expect anyone would
> package gputils before I got around to sharing this:
>
> While gputils itself is free software, I suspect some of the header
> files contained in its distribution may not be, which makes the
> licensing status of the project as a whole somewhat dubious. (This is
> similar to the problem that affects SDCC[0].) I think gputils should be
> reviewed carefully before the decision is made to include it in Guix.


Hi,

Thanks for the email.
I'll forward this discussion to the GPUtils team and ask them about
the header files. There might be a way to separate them from the project.

Thanks for the detailed answer.

Best,
Ekaitz
L
L
Ludovic Courtès wrote on 29 Nov 2020 23:36
(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)
878sajpz8s.fsf@gnu.org
Egun on,

Ekaitz Zarraga <ekaitz@elenq.tech> skribis:

Toggle quote (3 lines)
> I'll forward this discussion to the GPUtils team and ask them about
> the header files. There might be a way to separate them from the project.

Did you get feedback from them?

What Simon describes looks like a showstopper. :-/

Thanks,
Ludo’.
M
M
Maxim Cournoyer wrote on 14 Jun 2021 04:44
Re: bug#44557: [PATCH] gnu: Add gputils.
(name . Ludovic Courtès)(address . ludo@gnu.org)
87a6nttbbc.fsf_-_@gmail.com
Hello,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (14 lines)
> Egun on,
>
> Ekaitz Zarraga <ekaitz@elenq.tech> skribis:
>
>> I'll forward this discussion to the GPUtils team and ask them about
>> the header files. There might be a way to separate them from the project.
>
> Did you get feedback from them?
>
> What Simon describes looks like a showstopper. :-/
>
> Thanks,
> Ludo’.

Looking at the project trackers [0] and mailing list [1], I don't see
traces of such discussion. Could you please provide a link so that we
can follow any resolution?

Thank you!

Maxim

E
E
Ekaitz Zarraga wrote on 14 Jun 2021 10:08
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
thP-qLpyOv49G4SNqf0KMYLyhBFw5T8Rq1lvGDxOlXthWoXROwtOydE67mzSMeCX1rms-E29dvujFRrmXVEob18SRo3pXPe0ljf_zqtDNAM=@elenq.tech
On Monday, June 14th, 2021 at 4:44 AM, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:

Toggle quote (34 lines)
> Hello,
>
> Ludovic Courtès ludo@gnu.org writes:
>
> > Egun on,
> >
> > Ekaitz Zarraga ekaitz@elenq.tech skribis:
> >
> > > I'll forward this discussion to the GPUtils team and ask them about
> > >
> > > the header files. There might be a way to separate them from the project.
> >
> > Did you get feedback from them?
> >
> > What Simon describes looks like a showstopper. :-/
> >
> > Thanks,
> >
> > Ludo’.
>
> Looking at the project trackers [0] and mailing list [1], I don't see
>
> traces of such discussion. Could you please provide a link so that we
>
> can follow any resolution?
>
> Thank you!
>
> Maxim
>
> [0] https://sourceforge.net/p/gputils/_list/tickets
>
> [1] https://sourceforge.net/p/gputils/mailman/gputils-devel/

IIRC I sent them an email but never got answers.

You can close the issue and discard the patch.

Best,
Ekaitz
L
L
Ludovic Courtès wrote on 14 Jun 2021 22:51
control message for bug #44557
(address . control@debbugs.gnu.org)
87zgvsuq3m.fsf@gnu.org
tags 44557 wontfix
close 44557
quit
M
M
Maxim Cournoyer wrote on 25 Jun 2021 06:04
Re: bug#44557: [PATCH] gnu: Add gputils.
(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)
87tulmy4gm.fsf_-_@gmail.com
Hello,

Ekaitz Zarraga <ekaitz@elenq.tech> writes:

[...]

Toggle quote (18 lines)
>> Looking at the project trackers [0] and mailing list [1], I don't see
>>
>> traces of such discussion. Could you please provide a link so that we
>>
>> can follow any resolution?
>>
>> Thank you!
>>
>> Maxim
>>
>> [0] https://sourceforge.net/p/gputils/_list/tickets
>>
>> [1] https://sourceforge.net/p/gputils/mailman/gputils-devel/
>
> IIRC I sent them an email but never got answers.
>
> You can close the issue and discard the patch.

I've opened a ticket with the gputils project so that this hopefully
gets some attention [0]. When it gets resolved, we can revisit this
submission again.


Thank you,

Maxim
?