gnu: Add matterhorn.

  • Open
  • quality assurance status badge
Details
4 participants
  • elaexuotee
  • Mathieu
  • Maxime Devos
  • (
Owner
unassigned
Submitted by
elaexuotee
Severity
normal
E
E
elaexuotee wrote on 8 Nov 2020 13:53
(address . guix-patches@gnu.org)
2674A0N1F01CQ.3GO4FVW1X3O76@wilsonb.com
Hey Guix,

This packages up a nice CLI client for Mattermost chat servers (a self-hosted,
libre Slack alternative).

Anyway, it's a Haskell package and ended up requiring quite a few
dependendencies along with a few version-updated alternatives to existing
packages.

The attached patch bundles all these up together, but what is the appropriate
convention in this case?

The bulk of the work is completely thanks to the hackage importer, but I did
spend quite a bit of time cleaning these up and sanity checking things.
Everything should pass the lint checks as well as indentation.

Also, for two packages, I had to disable tests. There are comments explaining
why in each case.

Let me know what you think!
(
CMSPINIXM5VA.GR7957O7UF4M@guix-aspire
Hi,

This patch must have slipped through the cracks, but it was mentioned
on IRC today, so I decided to do a little review :)

First of all,

(1) You should have one commit per package.
(2) It's better, though not required, to use the procedure described here[1]
to send patches, instead of using attachments. This makes it much easier
to annotate the patch with review comments, at least here in aerc :)


Toggle quote (5 lines)
> + (inputs
> + `(("ghc-random" ,ghc-random)
> + ("ghc-quickcheck" ,ghc-quickcheck)
> + ("ghc-semigroupoids" ,ghc-semigroupoids)))

You should use the "new style" of inputs:

Toggle quote (5 lines)
> + (inputs
> + (list ghc-random
> + ghc-quickcheck
> + ghc-semigroupoids))

Same for any native- and propagated- inputs.

Toggle quote (4 lines)
> + (arguments
> + `(#:cabal-revision
> + ("3" "1ndz5x6njl35h73il5c6qpaqd4ynvg21n6k7sb8aq09gfbg544d8")))

There's also a new arguments style:

Toggle quote (12 lines)
> + (arguments
> + (list #:cabal-revision
> + (list "3" "1ndz5x6njl35h73il5c6qpaqd4ynvg21n6k7sb8aq09gfbg544d8")))

> + (description
> + "This library is intended to be a comprehensive solution to parsing and
> +selecting quality-indexed values in HTTP headers. It is capable of parsing
> +both media types and language parameters from the Accept and Content header
> +families, and can be extended to match against other accept headers as well.
> +Selecting the appropriate header value is achieved by comparing a list of
> +server options against the quality-indexed values supplied by the client.")

This is a wee bit too long IMO.

-- (
M
M
Maxime Devos wrote on 12 Sep 2022 18:47
Re: [bug#44518] gnu: Add matterhorn.
4918ad1b-fda2-69ca-619c-abb30753292d@telenet.be
On 10-09-2022 14:06, ( via Guix-patches via wrote:
Toggle quote (11 lines)
>> ription
>> + "This library is intended to be a comprehensive solution to parsing and
>> +selecting quality-indexed values in HTTP headers. It is capable of parsing
>> +both media types and language parameters from the Accept and Content header
>> +families, and can be extended to match against other accept headers as well.
>> +Selecting the appropriate header value is achieved by comparing a list of
>> +server options against the quality-indexed values supplied by the client.")
> This is a wee bit too long IMO.
>
> -- (
>
Myself, I consider the length to be about perfect -- it isn't verbosely
worded, it is only a single paragraph and it clearly explains what it
can do.
Greetings,
Maxime.
Attachment: OpenPGP_signature
M
M
Mathieu wrote on 4 Nov 2022 16:11
Re: gnu: Add matterhorn.
(address . 44518@debbugs.gnu.org)
af59e078-0850-4080-b955-09699c4cb9de@disroot.org
Do you receive email notifications from here, elaexuotee, and are you by any chance still an active Guix user? Matterhorn would be a great addition to Guix packages.
?