Skeleton files in sub-directories are not writable

  • Open
  • quality assurance status badge
Details
One participant
  • Reza Alizadeh Majd
Owner
unassigned
Submitted by
Reza Alizadeh Majd
Severity
normal
R
R
Reza Alizadeh Majd wrote on 5 Nov 2020 11:44
(address . bug-guix@gnu.org)
20201105141437.486402c9@pantherx.org
Hi Guix,

trying to add a new skeleton file in a sub-directory in newly created
users home, skeleton files add in read-only mode.

since there shouldn't be any difference between adding a skeleton file
in user home directory, or in a sub-directory under user's home, I
assume this might be a bug related to skeleton file creation.

following configuration could be used to reproduce this issue:

Toggle snippet (32 lines)
(use-modules (gnu))

(define (test-skeletons)
(append
`(("test" ,(computed-file
"test"
(with-imported-modules '((guix build utils))
#~(begin
(use-modules (guix build utils))
(mkdir-p #$output)))))
("foo" ,(plain-file "foo" "foo is writable"))
("test/bar" ,(plain-file "bar" "bar is read-only")))
(default-skeletons)))

(operating-system
(host-name "guix.test")
(timezone "Asia/Tehran")
(locale "en_US.utf8")

(bootloader (bootloader-configuration
(bootloader grub-bootloader)
(target "/dev/sda")))
(file-systems (cons (file-system
(device (file-system-label "my-root"))
(mount-point "/")
(type "ext4"))
%base-file-systems))

(skeletons (test-skeletons)))


generated skeleton files status:

Toggle snippet (9 lines)
root@guix ~# ll
total 4
-rw-r--r-- 1 root root 15 Nov 5 14:05 foo
-rw-r--r-- 2 root root 15 Nov 5 14:05 test/

root@guix ~# ll
-r--r--r-- 1 root root 15 Nov 5 14:05 bar

Regards,
Reza

--
Reza Alizadeh Majd
PantherX Team
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 44463@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44463
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch