Michael Rohleder wrote 4 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
* gnu/packages/databases.scm (python-peewee): Update to 3.13.3.
[inputs]: Add sqlite.
---
Added (optional) sqlite support, because I think
this pkg is much more useful then.
gnu/packages/databases.scm | 18 ++++++++++--------
1 file changed, 10 insertions(+), 8 deletions(-)
Toggle diff (34 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 0d8342b04a..e4e2675e08 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2256,17 +2256,19 @@ on another machine, accessed via TCP/IP.")
(define-public python-peewee
(package
(name "python-peewee")
- (version "3.9.6")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "peewee" version))
- (sha256
- (base32
- "1j4sh946k0736m7pd54z0y6i2hjhgg3kdllx1pwq8xkzzcgrx1xw"))))
+ (version "3.13.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "peewee" version))
+ (sha256
+ (base32
+ "0sc376v6rxga4b7ic9kxw2pmf28rmcx016320pa2nlb5d1rsjs8j"))))
(build-system python-build-system)
(arguments
`(#:tests? #f)) ; Fails to import test data
+ (inputs
+ `(("sqlite" ,sqlite)))
(native-inputs
`(("python-cython" ,python-cython)))
(home-page "https://github.com/coleifer/peewee/")
--
2.29.2