[PATCH] gnu: python-peewee: Update to 3.13.3.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 4 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20201105015549.7804-1-mike@rohleder.de
* gnu/packages/databases.scm (python-peewee): Update to 3.13.3.
[inputs]: Add sqlite.
---
Added (optional) sqlite support, because I think
this pkg is much more useful then.

gnu/packages/databases.scm | 18 ++++++++++--------
1 file changed, 10 insertions(+), 8 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 0d8342b04a..e4e2675e08 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2256,17 +2256,19 @@ on another machine, accessed via TCP/IP.")
(define-public python-peewee
(package
(name "python-peewee")
- (version "3.9.6")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "peewee" version))
- (sha256
- (base32
- "1j4sh946k0736m7pd54z0y6i2hjhgg3kdllx1pwq8xkzzcgrx1xw"))))
+ (version "3.13.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "peewee" version))
+ (sha256
+ (base32
+ "0sc376v6rxga4b7ic9kxw2pmf28rmcx016320pa2nlb5d1rsjs8j"))))
(build-system python-build-system)
(arguments
`(#:tests? #f)) ; Fails to import test data
+ (inputs
+ `(("sqlite" ,sqlite)))
(native-inputs
`(("python-cython" ,python-cython)))
(home-page "https://github.com/coleifer/peewee/")
--
2.29.2
Efraim Flashner wrote 4 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 44459-done@debbugs.gnu.org)
20201108200938.GB1287@E5400
Looks good. Patch pushed!

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl+oUIIACgkQQarn3Mo9
g1GAYw/+L4ZKpdBhbqT52CY+EUvYa61Zfkco5wWO4unl6n82Kt6p8Tya/+ZL47Wn
K1F5OBoe5K+/5vYGSBAyrsWGfPIlUr0I/c2OsJzmeznssnBLUzqSwLShT0YlW2KI
nI8tV4zFOwtXVPVhtTxEoHvRnZrCiHq+nFt69Plxgx2qqMHO6p90dukuR47iC8gb
b7ZwXXdIAWAP92aOoMmbaY4XykXE4IkOVVJJyVfis0CO8I2T7n02hm1ox9G5QcxX
Ube+0tNbOiCNL3iB6f8VT9pWZSs0yYopJrDki1/5VFvKOn2DSS+0KeVIs3AZjCL/
/Rbihd6g4A6Ig0c2Dj5QsX9DVvttAYI+ad17TJgcGcyHLEs6na9doqRB+F4/i9Im
E2cp5zxWHnJQfn/V3TkyHAQ2x0hhGdmYJsxwMCJoW1xneTIoD3LQ/AXgLZdIg0Eu
n1oUhL1NnWYoNIfoVyIYQB+Lrd6CycQAEvDEycOMhJNDyZVn07D10YGjROM/JoLq
qQag/1+gTjGoawE8quR4ruNhIoIhMeCwf4JOw97T3hxs7eMEj1aymOtrqk4MgGcU
aACEUpoo+b82MHNIt+q7r1FbDbbo+5uAxt4uMaK+jd0EwpwaSb0AMxd5mOEdG9OI
AXrfIY0lXhCjtvv9DTBtDLkOcyAwSPnFUfiSbcUJGHr5kStFi9w=
=JeW4
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44459@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44459
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help