Issues installing Avogadro

  • Done
  • quality assurance status badge
Details
3 participants
  • Godefroy Vannoye
  • Maxim Cournoyer
  • zimoun
Owner
unassigned
Submitted by
Godefroy Vannoye
Severity
normal
G
G
Godefroy Vannoye wrote on 4 Nov 2020 19:17
(address . bug-guix@gnu.org)
2f4832e0-c173-bd24-fd77-9d6b587f6095@gmail.com
Hi,

First let me apologize if I have missed something, I'm a new user of
guix and know only the basics about compilation processes.

I am using guix on the Arch distribution, and installed it using the
shell installer script. My first tests seem to indicate that guix is
installed properly.

I then tried to install Avogadro, but met the following error when
building it:

make[1]: Leaving directory '/tmp/guix-build-avogadro-1.2.0.drv-0/build'
make: *** [Makefile:155: all] Error 2
command "make" "-j" "4" failed with status 2
note: keeping build directory `/tmp/guix-build-avogadro-1.2.0.drv-0'
builder for
`/gnu/store/pc3pdcpm0mwbfvymwizfs14mdfb6qa5x-avogadro-1.2.0.drv' failed
with exit code 1
build of /gnu/store/pc3pdcpm0mwbfvymwizfs14mdfb6qa5x-avogadro-1.2.0.drv
failed

I retried to build it by running guix build avogadro -K to look at the
makefile and found at line 155

cd /tmp/guix-build-avogadro-1.2.0.drv-0/build && $(MAKE) -f
CMakeFiles/Makefile2 libavogadro/all

This is the first line of the makefile where $(MAKE) appears, but I
could not find where it was defined (I suppose it is defined as make
-j4, but it is not explicit in the makefile or in
environment-variables). This makes me assume that the error comes from
the $(MAKE), but I'm not knowledgeable enough to verify it.

Feel free to ask me anything or to explain me what I could have done wrong.

Thank you for your work and for your time,

Godefroy Vannoye
Z
Z
zimoun wrote on 10 Nov 2020 00:27
86mtzq9kmt.fsf@gmail.com
Dear,

Thank you for the report.

On Wed, 04 Nov 2020 at 19:17, Godefroy Vannoye <godefroy.vannoye@gmail.com> wrote:

Toggle quote (3 lines)
> First let me apologize if I have missed something, I'm a new user of
> guix and know only the basics about compilation processes.

Welcome! :-)


Toggle quote (4 lines)
> I am using guix on the Arch distribution, and installed it using the
> shell installer script. My first tests seem to indicate that guix is
> installed properly.

The Guix Data Service indicates that the package avogrado is broken.




Toggle quote (13 lines)
> I then tried to install Avogadro, but met the following error when
> building it:
>
> make[1]: Leaving directory '/tmp/guix-build-avogadro-1.2.0.drv-0/build'
> make: *** [Makefile:155: all] Error 2
> command "make" "-j" "4" failed with status 2
> note: keeping build directory `/tmp/guix-build-avogadro-1.2.0.drv-0'
> builder for
> `/gnu/store/pc3pdcpm0mwbfvymwizfs14mdfb6qa5x-avogadro-1.2.0.drv' failed
> with exit code 1
> build of /gnu/store/pc3pdcpm0mwbfvymwizfs14mdfb6qa5x-avogadro-1.2.0.drv
> failed

Before that, I get:

Toggle snippet (13 lines)
[..]
-- Setting new boost python libraries
CMake Error: failed to create symbolic link '/tmp/guix-build-avogadro-1.2.0.drv-0/build/libavogadro/include/avogadro//tmp/guix-build-avogadro-1.2.0.drv-0/build/libavogadro/src/config.h': no such file or directory
-- Enabled python terminal
CMake Warning at libavogadro/src/extensions/symmetry/libmsym/CMakeLists.txt:44 (export):
Cannot create package registry file:

/homeless-shelter/.cmake/packages/libmsym/0734694d5c49e2816b4ae48943d7700a

No such file or directory
[..]

then:

Toggle snippet (20 lines)
[..]
/tmp/guix-build-avogadro-1.2.0.drv-0/avogadro-1.2.0-checkout/libavogadro/src/extensions/symmetry/libmsym/src/orbital.c: In function ‘orbitalFromQuantumNumbers’:
/tmp/guix-build-avogadro-1.2.0.drv-0/avogadro-1.2.0-checkout/libavogadro/src/extensions/symmetry/libmsym/src/orbital.c:70:24: error: non-floating-point argument in call to function ‘__builtin_signbit’
char *d = (signbit(m) == 1 ? "-" : "+");
^~~~~~~
/tmp/guix-build-avogadro-1.2.0.drv-0/avogadro-1.2.0-checkout/libavogadro/src/extensions/symmetry/libmsym/src/orbital.c:76:24: error: non-floating-point argument in call to function ‘__builtin_signbit’
char *d = (signbit(m) == 1 ? "-" : "+");
^~~~~~~
make[2]: *** [libavogadro/src/extensions/symmetry/libmsym/CMakeFiles/msym.dir/build.make:170: libavogadro/src/extensions/symmetry/libmsym/CMakeFiles/msym.dir/src/orbital.c.o] Error 1
make[2]: Leaving directory '/tmp/guix-build-avogadro-1.2.0.drv-0/build'
make[1]: *** [CMakeFiles/Makefile2:2069: libavogadro/src/extensions/symmetry/libmsym/CMakeFiles/msym.dir/all] Error 2
make[2]: Leaving directory '/tmp/guix-build-avogadro-1.2.0.drv-0/build'
make[1]: *** [CMakeFiles/Makefile2:2069: libavogadro/src/extensions/symmetry/libmsym/CMakeFiles/msym.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 1%] Building CXX object libavogadro/src/tools/CMakeFiles/navigatetool.dir/eyecandy.cpp.o
[..]



Toggle quote (3 lines)
> I retried to build it by running guix build avogadro -K to look at the
> makefile and found at line 155

I get the same thing. But I think the error comes from an early step.


Well, then I am running:

cd /tmp/guix-build-avogadro-1.2.0.drv-0
mkdir mine && cd mine
guix environmment avogadro
cmake ../avogadro-1.2.0-checkout/

Toggle snippet (5 lines)
[..]
CMake Error: failed to create symbolic link '/tmp/guix-build-avogadro-1.2.0.drv-0/my/libavogadro/include/avogadro//tmp/guix-build-avogadro-1.2.0.drv-0/my/libavogadro/src/config.h': no such file or directory
[..]

So I would try to address this first error by examining the folder avogadro-1.2.0-checkout/.


All the best,
simon
M
M
Maxim Cournoyer wrote on 6 Sep 2023 06:05
(name . zimoun)(address . zimon.toutoune@gmail.com)
87a5u09cay.fsf@gmail.com
Hi,

zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (20 lines)
> Dear,
>
> Thank you for the report.
>
> On Wed, 04 Nov 2020 at 19:17, Godefroy Vannoye <godefroy.vannoye@gmail.com> wrote:
>
>> First let me apologize if I have missed something, I'm a new user of
>> guix and know only the basics about compilation processes.
>
> Welcome! :-)
>
>
>> I am using guix on the Arch distribution, and installed it using the
>> shell installer script. My first tests seem to indicate that guix is
>> installed properly.
>
> The Guix Data Service indicates that the package avogrado is broken.
>
> https://data.guix.gnu.org/repository/1/branch/master/package/avogadro/output-history

We now have avogradro2, which builds correctly.

--
Thanks,
Maxim
Closed
?