Christopher Lemmer Webber wrote 4 years ago
(address . guix-patches@gnu.org)
Attached is a highly WIP patch for the git-annex assistant (sloppily
includes the two dependencies that also need to be added, will separate
once I get it all working). However, it doesn't work... here's the
point at which it stopped working:
[601 of 607] Compiling Assistant ( Assistant.hs, dist/build/git-annex/git-annex-tmp/Assistant.dyn_o )
Assistant.hs:73:55: warning: [-Wunused-matches]
Defined but not used: ‘listenhost’
|
73 | startDaemon assistant foreground startdelay cannotrun listenhost startbrowser = do
| ^^^^^^^^^^
[602 of 607] Compiling Command.Watch ( Command/Watch.hs, dist/build/git-annex/git-annex-tmp/Command/Watch.dyn_o )
[603 of 607] Compiling Command.Assistant ( Command/Assistant.hs, dist/build/git-annex/git-annex-tmp/Command/Assistant.dyn_o )
[604 of 607] Compiling CmdLine.GitAnnex ( CmdLine/GitAnnex.hs, dist/build/git-annex/git-annex-tmp/CmdLine/GitAnnex.dyn_o )
[605 of 607] Compiling Main ( git-annex.hs, dist/build/git-annex/git-annex-tmp/Main.dyn_o )
[606 of 607] Compiling Assistant.Pairing.Network ( Assistant/Pairing/Network.hs, dist/build/git-annex/git-annex-tmp/Assistant/Pairing/Network.dyn_o )
Assistant/Pairing/Network.hs:20:1: error:
Could not find module ‘Network.Multicast’
Use -v to see a list of the files searched for.
|
20 | import Network.Multicast
| ^^^^^^^^^^^^^^^^^^^^^^^^
Assistant/Pairing/Network.hs:21:1: error:
Could not load module ‘Network.Info’
It is a member of the hidden package ‘network-info-0.2.0.10’.
Perhaps you need to add ‘network-info’ to the build-depends in your .cabal file.
Use -v to see a list of the files searched for.
|
21 | import Network.Info
| ^^^^^^^^^^^^^^^^^^^
command "runhaskell" "Setup.hs" "build" "--ghc-option=-j8" failed with status 1
I'm unsure why it would be failing since I did add network-info to the
inputs. Any ideas?
From 092183597b503ef349401a99ce1e981f4b3d29ba Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Tue, 3 Nov 2020 14:21:51 -0500
Subject: [PATCH] Git annex assistant wip
---
gnu/packages/haskell-apps.scm | 6 +++++-
gnu/packages/haskell-xyz.scm | 21 +++++++++++++++++++++
2 files changed, 26 insertions(+), 1 deletion(-)
Toggle diff (70 lines)
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 1de8b040f1..e3f0ed01f5 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -350,7 +350,7 @@ to @code{cabal repl}).")
(build-system haskell-build-system)
(arguments
`(#:configure-flags
- '("--flags=-Android -Assistant -Pairing -Webapp")
+ '("--flags=-Android -Pairing -Webapp")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-shell-for-tests
@@ -449,6 +449,7 @@ to @code{cabal repl}).")
("ghc-cryptonite" ,ghc-cryptonite)
("ghc-data-default" ,ghc-data-default)
("ghc-dav" ,ghc-dav)
+ ("ghc-dbus" ,ghc-dbus)
("ghc-disk-free-space" ,ghc-disk-free-space)
("ghc-dlist" ,ghc-dlist)
("ghc-edit-distance" ,ghc-edit-distance)
@@ -457,6 +458,7 @@ to @code{cabal repl}).")
("ghc-feed" ,ghc-feed)
("ghc-filepath-bytestring" ,ghc-filepath-bytestring)
("ghc-free" ,ghc-free)
+ ("ghc-hinotify" ,ghc-hinotify)
("ghc-hslogger" ,ghc-hslogger)
("ghc-http-client" ,ghc-http-client)
("ghc-http-conduit" ,ghc-http-conduit)
@@ -466,7 +468,9 @@ to @code{cabal repl}).")
("ghc-memory" ,ghc-memory)
("ghc-monad-control" ,ghc-monad-control)
("ghc-monad-logger" ,ghc-monad-logger)
+ ("ghc-mountpoints" ,ghc-mountpoints)
("ghc-network" ,ghc-network)
+ ("ghc-network-info" ,ghc-network-info)
("ghc-old-locale" ,ghc-old-locale)
("ghc-optparse-applicative" ,ghc-optparse-applicative)
("ghc-persistent" ,ghc-persistent)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 43dc7d5bbf..24be3ce5bc 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -15416,3 +15416,24 @@ Zstandard compression algorithm, a fast lossless compression algorithm
targeting real-time compression scenarios at zlib-level and better
compression ratios.")
(license license:bsd-3)))
+
+(define-public ghc-mountpoints
+ (package
+ (name "ghc-mountpoints")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/mountpoints/mountpoints-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1hnm31pqcffphyc463wf0vbik9fzm5lb2r4wjdc1y4dqzmjdzz37"))))
+ (build-system haskell-build-system)
+ (home-page
+ "http://hackage.haskell.org/package/mountpoints")
+ (synopsis "list mount points")
+ (description "Lists currently mounted filesystems. . Works on: Linux, BSD, Mac OS X, Android")
+ (license license:lgpl2.1+)))
--
2.29.1