[PATCH 0/3] Update gmnisrv.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandru-Sergiu Marton
  • Christopher Baines
Owner
unassigned
Submitted by
Alexandru-Sergiu Marton
Severity
normal

Debbugs page

Alexandru-Sergiu Marton wrote 4 years ago
(address . guix-patches@gnu.org)(name . Alexandru-Sergiu Marton)(address . brown121407@posteo.ro)
20201103191737.7836-1-brown121407@posteo.ro
These patches add the mailcap package and update the gmnisrv Gemini
server. They also export the types needed to actually use the server,
something which I forgot to do when I wrote the service for gmnisrv.

Alexandru-Sergiu Marton (3):
gnu: Add mailcap.
services: gmnisrv: Export types.
gnu: Update gmnisrv.

gnu/packages/mail.scm | 37 +++++++++++++++++++++++++++++++++++++
gnu/packages/web.scm | 19 ++++++++-----------
gnu/services/web.scm | 9 ++++++++-
3 files changed, 53 insertions(+), 12 deletions(-)

--
2.29.1
Alexandru-Sergiu Marton wrote 4 years ago
[PATCH 1/3] gnu: Add mailcap.
(address . 44423@debbugs.gnu.org)(name . Alexandru-Sergiu Marton)(address . brown121407@posteo.ro)
20201103191918.7944-1-brown121407@posteo.ro
* gnu/packages/mail.scm (mailcap): New variable.
---
gnu/packages/mail.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 44a156fd99..2f4173dc92 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -747,6 +747,43 @@ MIME-encoded email package.")
(home-page "https://github.com/inflex/ripMIME")
(license license:bsd-3))))
+(define-public mailcap
+ (let* ((version "2.1.49")
+ (tag ;; mailcap tags their releases like this: rMajor-minor-patch
+ (string-append "r" (string-join (string-split version #\.) "-"))))
+ (package
+ (name "mailcap")
+ (version version)
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://pagure.io/mailcap.git")
+ (commit tag)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ck1fw6gqn51phcfakhfpfq1yziv3gnmgjvswzhj9x0p162n6alj"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'install 'set-dest-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (setenv "DESTDIR" out)
+ (substitute* "Makefile"
+ (("/usr") "")) ;; This allows the man page to install.
+ #t))))))
+ (native-inputs `(("python" ,python-3.8))) ;; for tests
+ (synopsis "MIME type associations for file types")
+ (description "This package provides MIME type associations for file
+types.")
+ (home-page "https://pagure.io/mailcap")
+ (license (list license:expat ;; mailcap.5
+ license:public-domain))))) ;; mailcap and mime.types
+
(define-public bogofilter
(package
(name "bogofilter")
--
2.29.1
Alexandru-Sergiu Marton wrote 4 years ago
[PATCH 2/3] services: gmnisrv: Export types.
(address . 44423@debbugs.gnu.org)(name . Alexandru-Sergiu Marton)(address . brown121407@posteo.ro)
20201103191918.7944-2-brown121407@posteo.ro
* gnu/services/web.scm: Export gmnisrv-configuration, gmnisrv-configuration?,
gmnisrv-configuration-package, gmnisrv-configuration-config-file,
gmnisrv-service-type.
---
gnu/services/web.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)

Toggle diff (22 lines)
diff --git a/gnu/services/web.scm b/gnu/services/web.scm
index 7e17dac6e2..0f8f09d919 100644
--- a/gnu/services/web.scm
+++ b/gnu/services/web.scm
@@ -256,7 +256,14 @@
mumi-configuration-sender
mumi-configuration-smtp
- mumi-service-type))
+ mumi-service-type
+
+ gmnisrv-configuration
+ gmnisrv-configuration?
+ gmnisrv-configuration-package
+ gmnisrv-configuration-config-file
+
+ gmnisrv-service-type))
;;; Commentary:
;;;
--
2.29.1
Alexandru-Sergiu Marton wrote 4 years ago
[PATCH 3/3] gnu: Update gmnisrv.
(address . 44423@debbugs.gnu.org)(name . Alexandru-Sergiu Marton)(address . brown121407@posteo.ro)
20201103191918.7944-3-brown121407@posteo.ro
* gnu/packages/web.scm (gmnisrv): Update to commit
d484ba0ab0020866535a44be5948c9482b8f2b8d.
---
gnu/packages/web.scm | 19 ++++++++-----------
1 file changed, 8 insertions(+), 11 deletions(-)

Toggle diff (60 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 93399b3459..0f7c5fe2e9 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -129,6 +129,7 @@
#:use-module (gnu packages lisp-xyz)
#:use-module (gnu packages lsof)
#:use-module (gnu packages lua)
+ #:use-module (gnu packages mail)
#:use-module (gnu packages man)
#:use-module (gnu packages markup)
#:use-module (gnu packages ncurses)
@@ -7706,10 +7707,11 @@ solution for any project's interface needs:
(license license:expat)))
(define-public gmnisrv
- (let ((commit "a22bec51494a50c044416d469cc33e043480e7fd"))
+ (let ((commit "d484ba0ab0020866535a44be5948c9482b8f2b8d")
+ (revision "1"))
(package
(name "gmnisrv")
- (version (git-version "0" "0" commit))
+ (version (git-version "0" revision commit))
(home-page "https://git.sr.ht/~sircmpwn/gmnisrv")
(source (origin
(method git-fetch)
@@ -7718,7 +7720,7 @@ solution for any project's interface needs:
(commit commit)))
(sha256
(base32
- "1k1n7cqd37jgbhxyh231bagdxdxqwpr6n5pk3gax2516w6xbzlb9"))
+ "11phipixsxx1jgm42agp76p5s68l0zj65kgb41vzaymgwcq79ivn"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -7728,19 +7730,14 @@ solution for any project's interface needs:
(lambda _
(setenv "CC" "gcc")
#t))
- (delete 'check)
- (add-after 'install 'install-config
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((etc (string-append (assoc-ref outputs "out")
- "/etc")))
- (mkdir-p etc)
- (copy-file "config.ini" (string-append etc "/gmnisrv.ini"))
- #t))))))
+ (delete 'check))))
(inputs
`(("openssl" ,openssl)))
(native-inputs
`(("pkg-config" ,pkg-config)
("scdoc" ,scdoc)))
+ (propagated-inputs
+ `(("mailcap" ,mailcap)))
(synopsis "Simple Gemini protocol server")
(description "gmnisrv is a simple Gemini protocol server written in C.")
(license (list license:gpl3+
--
2.29.1
Christopher Baines wrote 4 years ago
Re: [bug#44423] [PATCH 0/3] Update gmnisrv.
(name . Alexandru-Sergiu Marton)(address . brown121407@posteo.ro)(address . 44423-done@debbugs.gnu.org)
87ima8cgjx.fsf@cbaines.net
Alexandru-Sergiu Marton <brown121407@posteo.ro> writes:

Toggle quote (14 lines)
> These patches add the mailcap package and update the gmnisrv Gemini
> server. They also export the types needed to actually use the server,
> something which I forgot to do when I wrote the service for gmnisrv.
>
> Alexandru-Sergiu Marton (3):
> gnu: Add mailcap.
> services: gmnisrv: Export types.
> gnu: Update gmnisrv.
>
> gnu/packages/mail.scm | 37 +++++++++++++++++++++++++++++++++++++
> gnu/packages/web.scm | 19 ++++++++-----------
> gnu/services/web.scm | 9 ++++++++-
> 3 files changed, 53 insertions(+), 12 deletions(-)

Thanks, I've pushed this as 870d74ab6883196b269382b86b6e48a1cc7ac8ae
with a few tweaks.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl+vwjNfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcGDA/9Exf6kkFL5YvV0Ra0HIMqTuJBxxOXZZDB
NCgHEt/oIwmLJ8d1ScusCS3lxGf3fTQYat3b7koW4sFaON5SiEAj+pAsvw+VXroV
MoJRlmWyUlGI4COx+uuOzjAmk8XpuCmjwqfdY116VWJIZyNOlmZSzYOfv/wpwPkx
6ikhUGiFTHXNDiwV5jJzH+Im7P4ep1gXcQm6EQF9k7T5JorESH3qok639BoI4J1K
/uUFBCMke0lljZWJ77Iva+ifVWi6ZIQa9ouHWuBgtZK66qa2BekXb4nUbjh6JHed
vRQtdyfTWVwfUcdR/FOlatLpGEx0t2NnqrnhDWFk0eEGJ0y+SIfFqUpeVnVHg3dI
bl9jh4VE4yz5Tn4bzHp8pI06IGm+/WW21FQQfNeAOvfpAX9NckZIDxI6gDg0CQlN
LSNCSdkhMZyDuoUnbCABmYaa+OqKHqpjI9IlhDvQ3hKrTs2WKkBq7l+pLjfztBLf
AO2ezXMpl+ueJ/tjfg2GoqJ59sDt76UTseCk+aHi8o+SoTNMroL0Fs78AzzBI1eZ
12s0PRk6IDvnz05wNFDcxxreQhwEuuMT9z/qffTvDGFYv2J/ww+r3bn3enk+/LP5
1saME/ZAmYZKsxGN+wsqa2445fwt+8xorObvyr/JWx+hK7DE5Bp4KblPwVi8LsMA
Fg7U1pn50Io=
=DOW9
-----END PGP SIGNATURE-----

Closed
Christopher Baines wrote 4 years ago
Re: [bug#44423] [PATCH 1/3] gnu: Add mailcap.
(name . Alexandru-Sergiu Marton)(address . brown121407@posteo.ro)(address . 44423@debbugs.gnu.org)
87ft5ccgh3.fsf@cbaines.net
Alexandru-Sergiu Marton <brown121407@posteo.ro> writes:

Toggle quote (50 lines)
> * gnu/packages/mail.scm (mailcap): New variable.
> ---
> gnu/packages/mail.scm | 37 +++++++++++++++++++++++++++++++++++++
> 1 file changed, 37 insertions(+)
>
> diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
> index 44a156fd99..2f4173dc92 100644
> --- a/gnu/packages/mail.scm
> +++ b/gnu/packages/mail.scm
> @@ -747,6 +747,43 @@ MIME-encoded email package.")
> (home-page "https://github.com/inflex/ripMIME")
> (license license:bsd-3))))
>
> +(define-public mailcap
> + (let* ((version "2.1.49")
> + (tag ;; mailcap tags their releases like this: rMajor-minor-patch
> + (string-append "r" (string-join (string-split version #\.) "-"))))
> + (package
> + (name "mailcap")
> + (version version)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://pagure.io/mailcap.git")
> + (commit tag)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0ck1fw6gqn51phcfakhfpfq1yziv3gnmgjvswzhj9x0p162n6alj"))))
> + (build-system gnu-build-system)
> + (arguments
> + '(#:phases
> + (modify-phases %standard-phases
> + (delete 'configure)
> + (add-before 'install 'set-dest-dir
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let ((out (assoc-ref outputs "out")))
> + (setenv "DESTDIR" out)
> + (substitute* "Makefile"
> + (("/usr") "")) ;; This allows the man page to install.
> + #t))))))
> + (native-inputs `(("python" ,python-3.8))) ;; for tests
> + (synopsis "MIME type associations for file types")
> + (description "This package provides MIME type associations for file
> +types.")
> + (home-page "https://pagure.io/mailcap")
> + (license (list license:expat ;; mailcap.5
> + license:public-domain))))) ;; mailcap and mime.types

This looks fine to me, although looking again at the description now,
it's a bit lacking in context.

I tweaked the indentation in places, and switched the end of line
comments to just use a single ;

Toggle quote (4 lines)
> +
> (define-public bogofilter
> (package
> (name "bogofilter")
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl+vwphfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xd+ARAAj5Wk+FfCGWijhXRPDrCj9hCeXv0jeAl6
I2nN1IKSmmVvS2eCsLvLJqoHD9KvCH2/CzXfNxUbWWGmMQaJxnfRB9SSdiaNMOVL
pxkJIJFIclE24cGA+JyfOagZZlP5AOzldobGGaGRHTFfFDbKTUUzAfxqwqVj5Udf
9ChX5vfmI8ageSpPsXgzr22JcPE3WmXSDSsyuB3f5cXyy2YJqU/OpXc/+BYfWeel
89Vi6l5RYFK3qYg3YQGLcKJNcp9qT2X9v7843/Fz2TmxqkLgriJcYrI0PQ5Zo0M4
orbz8sLeS64Pb6swpstoPS6/aDsp6iSaMBP2bw/33sk1dPkwcNeAGtcgsX34kiBm
7AJLxged6xNqWkdgAki/3rDKs+M03GmChCwJf/ZE13H9ieaWXAI4eO8+vdyL+y0m
Y8GOuyh2pzWjVpvZcDY+KuqQmA+Sz6f8ZXEaWQh2PwRliDD2lW3fzZd5rskLI9Tq
EQDvTtyX++NgZ0jky4ZG+89nlnOZ4qSOhDoyPAN90wVUJXiTMaKErN9fVD0UKusO
+omA0uEa+SIB5DRxqDD9LT0GIcgFDbEb6gCfj0NAReqz12y4GgJ+jxUeWQw61hkZ
z1wdvcmJTyRzjnVWKatXgIjR5Cu6KPXRGzDFOhbz0nDyYLWpqLmgHVX6cs0Bagvs
W2ZQC4rNecw=
=Sq5t
-----END PGP SIGNATURE-----

Christopher Baines wrote 4 years ago
Re: [bug#44423] [PATCH 3/3] gnu: Update gmnisrv.
(name . Alexandru-Sergiu Marton)(address . brown121407@posteo.ro)(address . 44423@debbugs.gnu.org)
87d00gcgfr.fsf@cbaines.net
Alexandru-Sergiu Marton <brown121407@posteo.ro> writes:

Toggle quote (3 lines)
> * gnu/packages/web.scm (gmnisrv): Update to commit
> d484ba0ab0020866535a44be5948c9482b8f2b8d.

I changed the commit message to:

gnu: gmnisrv: Update to 0-1.d484ba0.

* gnu/packages/web.scm (gmnisrv): Update to 0-1.d484ba0.
[arguments]: Remove the install-config phase.
[propagated-inputs]: Add mailcap.


Toggle quote (62 lines)
> ---
> gnu/packages/web.scm | 19 ++++++++-----------
> 1 file changed, 8 insertions(+), 11 deletions(-)
>
> diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
> index 93399b3459..0f7c5fe2e9 100644
> --- a/gnu/packages/web.scm
> +++ b/gnu/packages/web.scm
> @@ -129,6 +129,7 @@
> #:use-module (gnu packages lisp-xyz)
> #:use-module (gnu packages lsof)
> #:use-module (gnu packages lua)
> + #:use-module (gnu packages mail)
> #:use-module (gnu packages man)
> #:use-module (gnu packages markup)
> #:use-module (gnu packages ncurses)
> @@ -7706,10 +7707,11 @@ solution for any project's interface needs:
> (license license:expat)))
>
> (define-public gmnisrv
> - (let ((commit "a22bec51494a50c044416d469cc33e043480e7fd"))
> + (let ((commit "d484ba0ab0020866535a44be5948c9482b8f2b8d")
> + (revision "1"))
> (package
> (name "gmnisrv")
> - (version (git-version "0" "0" commit))
> + (version (git-version "0" revision commit))
> (home-page "https://git.sr.ht/~sircmpwn/gmnisrv")
> (source (origin
> (method git-fetch)
> @@ -7718,7 +7720,7 @@ solution for any project's interface needs:
> (commit commit)))
> (sha256
> (base32
> - "1k1n7cqd37jgbhxyh231bagdxdxqwpr6n5pk3gax2516w6xbzlb9"))
> + "11phipixsxx1jgm42agp76p5s68l0zj65kgb41vzaymgwcq79ivn"))
> (file-name (git-file-name name version))))
> (build-system gnu-build-system)
> (arguments
> @@ -7728,19 +7730,14 @@ solution for any project's interface needs:
> (lambda _
> (setenv "CC" "gcc")
> #t))
> - (delete 'check)
> - (add-after 'install 'install-config
> - (lambda* (#:key outputs #:allow-other-keys)
> - (let ((etc (string-append (assoc-ref outputs "out")
> - "/etc")))
> - (mkdir-p etc)
> - (copy-file "config.ini" (string-append etc "/gmnisrv.ini"))
> - #t))))))
> + (delete 'check))))
> (inputs
> `(("openssl" ,openssl)))
> (native-inputs
> `(("pkg-config" ,pkg-config)
> ("scdoc" ,scdoc)))
> + (propagated-inputs
> + `(("mailcap" ,mailcap)))
> (synopsis "Simple Gemini protocol server")
> (description "gmnisrv is a simple Gemini protocol server written in C.")
> (license (list license:gpl3+
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl+vwshfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xe03xAApm1mQIhbgA4qjAYcwyCAo0tctpKWEH1j
50ReELyB0OOUgaJfx+7i5Uq2T09Af7dq1p5T3AHw6NBkdBm4QMSpddofdM/argNP
T5YFW2T64aUj3QJnDkJnR/kjTiinWZz1As/fPtFW6T0bmSq64Y2MZwQrxnuODd9x
9JJ925YKyinBQZn+KX3vHQJ+DOczsXu11BLgvwQvgK3v+pInNDPeXRoqOlJ/AX1G
VhkQS2gqODEkno4rIEMgmH07zxRvSSCwjKzC8x/BH5EvGuqY+EOsUQIRSpDuyCGJ
HY+qw55drPlhiZ3p/NAWheME+YSSSrVxJbWnwSxOht2agzkBWlVn4MLg7hWaj3cL
GpE919luzBPlzW9I4YLOEmkvAA2KNw8+fomaSvpYTWkLWXMukhTtzN69LmkzJxcT
ax66DPcBlvqM50x+QnmZ9uPFVt366PTalQ+q9zNJ9aElRjJozj65dWhpXXpx5g+i
cp2iZlW4sMkqYu49ncFH/0meZUx16JBkzP/3K2gmvmUum10m1ecDXOdtzSaQdU2v
mwJNuHfRBS52ECwAsP77E7LDzZbFE9AgQUOdDG11zCS5e4F3k6ECJZfRoJd/aWHi
BpGjv22E13tl2ip08btNLpO+wwR45c+339lMTiqiFSflBejX5IaK/xTAiUfdVCud
HDrn4leYQHM=
=8Pe5
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 44423@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44423
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help