(no subject)

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolò Balzarotti
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Nicolò Balzarotti
Severity
normal
N
N
Nicolò Balzarotti wrote on 3 Nov 2020 08:53
(address . guix-patches@gnu.org)
87pn4uyiyq.fsf@guixSD.i-did-not-set--mail-host-address--so-tickle-me
Hi guix!

This patch adds JuliaMono, a monospaced font.

Thanks!
From dfa2d577a54d3c4d291415ff2f8e23e41e2b2303 Mon Sep 17 00:00:00 2001
From: nixo <nicolo@nixo.xyz>
Date: Sun, 1 Nov 2020 11:04:12 +0100
Subject: [PATCH] gnu: Add font-juliamono.

* gnu/packages/fonts.scm (font-juliamono): New variable.
---
gnu/packages/fonts.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index f39c529beb..806fe0bb8d 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1762,6 +1762,37 @@ Mono’s typeface forms are simple and free from unnecessary details. Rendered
in small sizes, the text looks crisper.")
(license license:asl2.0)))
+(define-public font-juliamono
+ (package
+ (name "font-juliamono")
+ (version "0.025")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cormullion/juliamono")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1w8mpl9zc1y4j1f26ikbz5g9dqsszhikp4r9p1d3ch3b5ayb5c3m"))))
+ (build-system font-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'delete-website-folder
+ ;; This folder contains other unrelated fonts
+ (lambda _
+ (delete-file-recursively "website")
+ #t)))))
+ (home-page "https://github.com/cormullion/juliamono")
+ (synopsis "Monospaced font for programming")
+ (description
+ "JuliaMono is a monospaced font for scientific and technical computing,
+designed to work for programming in the Julia Programming Language and other
+text environments.")
+ (license license:silofl1.1)))
+
(define-public font-vazir
(package
(name "font-vazir")
--
2.29.2
N
N
Nicolò Balzarotti wrote on 3 Nov 2020 09:01
(address . 44410@debbugs.gnu.org)
87mtzyyilv.fsf@guixSD.i-did-not-set--mail-host-address--so-tickle-me
I forgot to put a subject on the email >.<
sorry

Nicolò Balzarotti <anothersms@gmail.com> writes:

Toggle quote (60 lines)
> Hi guix!
>
> This patch adds JuliaMono, a monospaced font.
>
> Thanks!
>
> From dfa2d577a54d3c4d291415ff2f8e23e41e2b2303 Mon Sep 17 00:00:00 2001
> From: nixo <nicolo@nixo.xyz>
> Date: Sun, 1 Nov 2020 11:04:12 +0100
> Subject: [PATCH] gnu: Add font-juliamono.
>
> * gnu/packages/fonts.scm (font-juliamono): New variable.
> ---
> gnu/packages/fonts.scm | 31 +++++++++++++++++++++++++++++++
> 1 file changed, 31 insertions(+)
>
> diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
> index f39c529beb..806fe0bb8d 100644
> --- a/gnu/packages/fonts.scm
> +++ b/gnu/packages/fonts.scm
> @@ -1762,6 +1762,37 @@ Mono’s typeface forms are simple and free from unnecessary details. Rendered
> in small sizes, the text looks crisper.")
> (license license:asl2.0)))
>
> +(define-public font-juliamono
> + (package
> + (name "font-juliamono")
> + (version "0.025")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/cormullion/juliamono")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1w8mpl9zc1y4j1f26ikbz5g9dqsszhikp4r9p1d3ch3b5ayb5c3m"))))
> + (build-system font-build-system)
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'delete-website-folder
> + ;; This folder contains other unrelated fonts
> + (lambda _
> + (delete-file-recursively "website")
> + #t)))))
> + (home-page "https://github.com/cormullion/juliamono")
> + (synopsis "Monospaced font for programming")
> + (description
> + "JuliaMono is a monospaced font for scientific and technical computing,
> +designed to work for programming in the Julia Programming Language and other
> +text environments.")
> + (license license:silofl1.1)))
> +
> (define-public font-vazir
> (package
> (name "font-vazir")
> --
> 2.29.2
N
N
Nicolas Goaziou wrote on 5 Nov 2020 23:16
Re: [bug#44410] (no subject)
(name . Nicolò Balzarotti)(address . anothersms@gmail.com)(address . 44410-done@debbugs.gnu.org)
87eel7la9o.fsf@nicolasgoaziou.fr
Hello,

Nicolò Balzarotti <anothersms@gmail.com> writes:

Toggle quote (2 lines)
> This patch adds JuliaMono, a monospaced font.

Applied. Thank you!

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44410@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44410
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch