Cuirass problem with building from manifest file

  • Done
  • quality assurance status badge
Details
2 participants
  • david larsson
  • Mathieu Othacehe
Owner
unassigned
Submitted by
david larsson
Severity
normal

Debbugs page

david larsson wrote 4 years ago
(address . bug-guix@gnu.org)
2840f15b6b64cd4d98d3ba5f2255708a@selfhosted.xyz
Hi!

I am unable to build a simple manifest containing the hello package, see
below. I tried imitating the manual
perhaps the manifest.scm is not supposed to contain a regular manifest
or maybe that config example is outdated?

============================
The hello.scm file - works fine using guix package -m hello.scm
============================

cat /home/cuirass/my-guixsd-config.sh/manifests/hello.scm
(specifications->manifest
(append (list "hello")
'()))

============================
From /var/log/cuirass.log
============================

2020-11-02T20:06:25 fetching input 'my-guixsd-config' of spec 'my-pkgs'
2020-11-02T20:06:25 fetching input 'my-guix-packages' of spec 'my-pkgs'
2020-11-02T20:06:25 fetching input 'guix' of spec 'my-pkgs'
2020-11-02T20:06:26 fetched input 'my-guixsd-config' of spec 'my-pkgs'
(commit "fb3001bd453583b4638bf6ec7187b5758d7b0715")
2020-11-02T20:06:26 fetched input 'my-guix-packages' of spec 'my-pkgs'
(commit "9f9c644076b088aabee76626598115c0fe6bfbde")
2020-11-02T20:06:26 fetched input 'guix' of spec 'my-pkgs' (commit
"7c02eb6c8d7d050ecb8f3082c4a754ad32211403")
2020-11-02T20:06:26 next evaluation in 36000 seconds
2020-11-02T20:06:26 evaluating spec 'my-pkgs'
Uncaught exception in fiber ##f:
In cuirass/base.scm:
785:13 3 (_)
In ice-9/boot-9.scm:
1736:10 2 (with-exception-handler _ _ #:unwind? _ # _)
1669:16 1 (raise-exception _ #:continuable? _)
1667:16 0 (raise-exception _ #:continuable? _)
ice-9/boot-9.scm:1667:16: In procedure raise-exception:
ERROR:
1. &evaluation-error:
name: "my-pkgs"
id: 1

============================
My cuirass-specs
============================

(define %cuirass-specs
#~(
list
'((#:name . "my-pkgs")
(#:load-path-inputs . ("guix"))
(#:package-path-inputs . ("my-guix-packages"))
(#:proc-input . "guix")
(#:proc-file . "build-aux/cuirass/gnu-system.scm")
(#:proc . cuirass-jobs)
(#:proc-args .
((subset . manifests)
;; This builds fine!
;;(subset . ("hello" "cowsay" "orgmk" "fwknop" "python-on-guile"
"libxml2-xpath0" "guile-bash-parallel" "guile-base64" "perl-data-ical"
"python-pydotplus"))
(systems . ("x86_64-linux"))
;; This fails on 7c02eb6
(manifests . (("my-guixsd-config" . "hello.scm")))
))
(#:inputs . (
((#:name . "guix")
(#:url . "git://git.savannah.gnu.org/guix.git")
(#:load-path . ".")
;;(#:branch . "master")
(#:commit .
"7c02eb6c8d7d050ecb8f3082c4a754ad32211403")

((#:name . "my-guix-packages")
(#:url . "file:///home/cuirass/my-guix-packages")
(#:load-path . "packages")
(#:branch . "master")
(#:no-compile? . #t))

((#:name . "my-guixsd-config")
(#:url . "file:///home/cuirass/my-guixsd-config.sh")
(#:load-path . "manifests")
(#:branch . "master")
(#:no-compile? . #t))

))
(#:build-outputs . ()))
))

============================
And the evaluations file content
============================

gzip --decompress -c /var/log/cuirass/evaluations/1.gz
warning:
building things during evaluation
'build-things' arguments:
(("/gnu/store/qhm7xsikyykvjisi8kbmzp8ny3cmf370-compute-guix-derivation.drv")
0)
Computing Guix derivation for 'x86_64-linux'...
warning:
building things during evaluation
'build-things' arguments:
(("/gnu/store/ps30mn7xq0ymcrdzlwim8pkv1czgv2zf-profile.drv") 0)
ERROR: In procedure read:
In procedure scm_lreadr: #<unknown port>:16:634: Unknown # object: #\<



Best regards,
David Larsson
Mathieu Othacehe wrote 4 years ago
(name . david larsson)(address . david.larsson@selfhosted.xyz)(address . 44399@debbugs.gnu.org)
87tuu7a57u.fsf@gnu.org
Hello David,

Toggle quote (4 lines)
> (("/gnu/store/ps30mn7xq0ymcrdzlwim8pkv1czgv2zf-profile.drv") 0)
> ERROR: In procedure read:
> In procedure scm_lreadr: #<unknown port>:16:634: Unknown # object: #\<

This is probably a consequence of me breaking things today. I restored
the original handling of package licenses with b5f2a035.

This means that you need to uses non "#f" licenses in your custom
packages to avoid the issue you encountered in

Could you please confirm that it works?

Thanks,

Mathieu
david larsson wrote 4 years ago
(name . Mathieu Othacehe)(address . othacehe@gnu.org)
01466894f6c4942d879d833cedafc83e@selfhosted.xyz
On 2020-11-02 20:12, Mathieu Othacehe wrote:
Toggle quote (4 lines)
>
> Could you please confirm that it works?
>

It does not. Building from manifest gives no error at all but goes
stale. The last output line in /var/log/cuirass.log is just:

2020-11-03T07:57:46 evaluating spec 'my-pkgs'

htop shows no cpu usage.



Building packages with #f licenses throws the same error again as in
#44370.



Packages are otherwise built but reported as failed, as in
david larsson wrote 4 years ago
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 44399@debbugs.gnu.org)
56be256fb43eff17ee6ff4ac7ba90141@selfhosted.xyz
On 2020-11-02 20:12, Mathieu Othacehe wrote:

Toggle quote (8 lines)
>
> Could you please confirm that it works?
>
> Thanks,
>
> Mathieu


Things do work now. I had made a mistake in my config.

In case it helps someone; to fix it, I changed my-guixsd-config input
load path to ".":

((#:name . "config")
(#:url . "file:///home/cuirass/my-guixsd-config.sh")
(#:load-path . ".")
(#:branch . "master")
(#:no-compile? . #t))

and in proc-args I changed the manifests path, and made sure "manifests"
has quotes around it, so I changed it to:

(#:proc-args .
((subset . "manifests")
(systems . ("x86_64-linux"))
(manifests . (("config" . "manifests/user1.scm")))
))

which now built over 200 packages successfully, yay!


Thanks for your help Mathieu!

Best regards,
David
Mathieu Othacehe wrote 4 years ago
(name . david larsson)(address . david.larsson@selfhosted.xyz)(address . 44399-done@debbugs.gnu.org)
87eeg34a49.fsf@gnu.org
Hello,

As the specification format is completely new and the evaluation process
has been rewritten, I think we can close this one.

Thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44399@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44399
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help