Reza Alizadeh Majd wrote 4 years ago
(address . guix-patches@gnu.org)(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)
* gnu/packages/python-xyz.scm (python-boto3): New variable.
---
gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
Toggle diff (36 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ee1f9acda0..e087da1e55 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11094,6 +11094,29 @@ manipulation library.")
interface to the Amazon Web Services (AWS) API.")
(license license:asl2.0)))
+(define-public python-boto3
+ (package
+ (name "python-boto3")
+ (version "1.16.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "boto3" version))
+ (sha256
+ (base32
+ "1smrfjpnki71dkdbj3zpfqi39gbcr5yb4q74fzl35hs953sf9zrs"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-botocore" ,python-botocore)
+ ("python-jmespath" ,python-jmespath)
+ ("python-s3transfer" ,python-s3transfer)))
+ (home-page "https://github.com/boto/boto3")
+ (synopsis "The AWS SDK for Python")
+ (description "Boto3 is the Amazon Web Services (AWS) Software Development
+Kit (SDK) for Python, which allows Python developers to write software that
+makes use of services like Amazon S3 and Amazon EC2.")
+ (license license:asl2.0)))
+
(define-public python2-botocore
(package-with-python2 python-botocore))
--
2.28.0