[PATCH] gnu: Add python-boto3.

  • Done
  • quality assurance status badge
Details
One participant
  • Reza Alizadeh Majd
Owner
unassigned
Submitted by
Reza Alizadeh Majd
Severity
normal

Debbugs page

Reza Alizadeh Majd wrote 4 years ago
(address . guix-patches@gnu.org)(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)
20201102190508.17191-1-r.majd@pantherx.org
* gnu/packages/python-xyz.scm (python-boto3): New variable.
---
gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ee1f9acda0..e087da1e55 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11094,6 +11094,29 @@ manipulation library.")
interface to the Amazon Web Services (AWS) API.")
(license license:asl2.0)))
+(define-public python-boto3
+ (package
+ (name "python-boto3")
+ (version "1.16.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "boto3" version))
+ (sha256
+ (base32
+ "1smrfjpnki71dkdbj3zpfqi39gbcr5yb4q74fzl35hs953sf9zrs"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-botocore" ,python-botocore)
+ ("python-jmespath" ,python-jmespath)
+ ("python-s3transfer" ,python-s3transfer)))
+ (home-page "https://github.com/boto/boto3")
+ (synopsis "The AWS SDK for Python")
+ (description "Boto3 is the Amazon Web Services (AWS) Software Development
+Kit (SDK) for Python, which allows Python developers to write software that
+makes use of services like Amazon S3 and Amazon EC2.")
+ (license license:asl2.0)))
+
(define-public python2-botocore
(package-with-python2 python-botocore))
--
2.28.0
Reza Alizadeh Majd wrote 4 years ago
(address . 44398@debbugs.gnu.org)
e07d26e2-2575-457c-8cf8-b7c2dc812474@www.fastmail.com
sorry, it seems that there is an issue during build of this package.
so I close this patch and submit a new one whenever the build issue
has been resolved.

--
Reza Alizadeh Majd
PantherX Team
Reza Alizadeh Majd wrote 4 years ago
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
7489c561-8463-414e-b7a1-799e8d0b7a08@www.fastmail.com
close 44398
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44398@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44398
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help