[PATCH] gnu: stumpish: Fix xprop call.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 4 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20201102053027.9850-1-mike@rohleder.de
* gnu/packages/wm.scm (stumpish): Fix xprop call.
[inputs]: Add xprop.
[arguments]: Add substitution of xprop.
---
starting stumpish yields:
/gnu/store/3dd14k2g5v67jm0hv0cmpvkvdk4631c5-stumpish-0.0.1-2.920f8fc/bin/stumpish: line 83: xprop: command not found
/gnu/store/3dd14k2g5v67jm0hv0cmpvkvdk4631c5-stumpish-0.0.1-2.920f8fc/bin/stumpish: line 55: xprop: command not found

and after typing "commands" in the repl the same error results in no output.

gnu/packages/wm.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 58252e7095..b76542692c 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2020 Boris A. Dekshteyn <harlequin78@gmail.com>
;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
;;; Copyright © 2020 EuAndreh <eu@euandre.org>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1722,7 +1723,8 @@ productive, customizable lisp based systems.")
(name "stumpish")
(inputs
`(("bash" ,bash)
- ("rlwrap" ,rlwrap)))
+ ("rlwrap" ,rlwrap)
+ ("xprop" ,xprop)))
(build-system trivial-build-system)
(arguments
'(#:modules ((guix build utils))
@@ -1734,6 +1736,8 @@ productive, customizable lisp based systems.")
(substitute* "stumpish"
(("rlwrap") (string-append (assoc-ref %build-inputs "rlwrap")
"/bin/rlwrap"))
+ (("xprop") (string-append (assoc-ref %build-inputs "xprop")
+ "/bin/xprop"))
(("/bin/sh") (string-append (assoc-ref %build-inputs "bash")
"/bin/bash")))
(install-file "stumpish" (string-append %output "/bin")))))
--
2.29.2
Guillaume Le Vaillant wrote 4 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 44385-done@debbugs.gnu.org)
878sbkazym.fsf@yamatai
Pushed to master as 48b00a4c7efadbb654bf28e9e4e61bb23f70a964. Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCX5/McQ8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/qHAD/V0Awfyq9gEkl6t2YViP51cEk+fhh9Uy4DLFv
apHyazMA/10AYz4DTNIYM2yewj71v6iEdTzZAziN5jX0KnZqAJ8W
=d/Gm
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44385@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44385
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help