[PATCH] gnu: Add icedove-wayland.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jonathan Brielmaier
  • Marius Bakke
Owner
unassigned
Submitted by
Jonathan Brielmaier
Severity
normal

Debbugs page

Jonathan Brielmaier wrote 4 years ago
(address . guix-patches@gnu.org)(address . jonathan.brielmaier@web.de)
20201101193908.29681-1-jonathan.brielmaier@web.de
* gnu/packages/gnuzilla.scm (icedove/wayland): New variable.
---
gnu/packages/gnuzilla.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index db67d7ad0a..b6e68c8132 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1476,6 +1476,27 @@ standards of the IceCat project.")
Thunderbird. It supports email, news feeds, chat, calendar and contacts.")
(license license:mpl2.0)))

+(define-public icedove/wayland
+ (package/inherit icedove
+ (name "icedove-wayland")
+ (arguments
+ (substitute-keyword-arguments (package-arguments icedove)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (replace 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib"))
+ (gtk (assoc-ref inputs "gtk+"))
+ (gtk-share (string-append gtk "/share"))
+ (pulseaudio (assoc-ref inputs "pulseaudio"))
+ (pulseaudio-lib (string-append pulseaudio "/lib")))
+ (wrap-program (car (find-files lib "^icedove$"))
+ `("MOZ_ENABLE_WAYLAND" = ("1"))
+ `("XDG_DATA_DIRS" prefix (,gtk-share))
+ `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib)))
+ #t)))))))))
+
(define-public firefox-decrypt
(package
(name "firefox-decrypt")
--
2.29.2
Jonathan Brielmaier wrote 4 years ago
Re: bug#44376: Acknowledgement ([PATCH] gnu: Add icedove-wayland.)
(address . 44376@debbugs.gnu.org)
4dc65c4d-db70-6c9c-54ef-0983d36cb602@web.de
I don't know if that is the best way to have icedove running on Wayland.
At least it works and give me a decent HiDPI experience on sway :)
Marius Bakke wrote 4 years ago
Re: [bug#44376] Acknowledgement ([PATCH] gnu: Add icedove-wayland.)
87pn4kdipk.fsf@gnu.org
Jonathan Brielmaier <jonathan.brielmaier@web.de> writes:

Toggle quote (3 lines)
> I don't know if that is the best way to have icedove running on Wayland.
> At least it works and give me a decent HiDPI experience on sway :)

Awesome, applied!
-----BEGIN PGP SIGNATURE-----

iQFDBAEBCgAtFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl+rAQcPHG1hcml1c0Bn
bnUub3JnAAoJEKKgbfKjOlT6OYAIAK+aymmNkravg7F4kd/jJPBSvORFC/fip8yV
VDaRABkvSdaWEwjDk+xtjVth28c7s2va7bU7mUFHud73siBkBbgK+S1T2H7UN6vv
VysPUG/Fbl0Ffn0QcauiCw9Fk82dEjWxAchPrS46t/ZnnIR9htCR+wlRyKoyARDy
/FbpL5pVpuYUX8w+07Sa9gpGc0aoZiBZ71JeLq6xb5BCUnL9GRoj0I9xX99XWQtr
l5j09sIizVB7bLdxEh6NJIG64AfnDVLYxHtJH+DPT1oDp4Ahy6mhf2ItZBcqDUzh
fs08BFJoHGBnEIuYFYYj7VeEbmxvETcKUJF+yXFLZcoMuTC5hBs=
=101A
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44376@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44376
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help