[PATCH 1/2] gnu: Add python-re-assert.

  • Done
  • quality assurance status badge
Details
2 participants
  • Marius Bakke
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 31 Oct 2020 21:03
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20201031200343.6213-1-monego@posteo.net
* gnu/packages/python-check.scm (python-re-assert): New variable.
---
gnu/packages/python-check.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 498f495584..944f226a41 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -436,6 +436,40 @@ in Pytest.")
of the project to ensure it renders properly.")
(license license:expat)))
+(define-public python-re-assert
+ (package
+ (name "python-re-assert")
+ (version "1.1.0")
+ (source
+ (origin
+ ;; There are no tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/asottile/re-assert")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rssq4wpqmx1c17hjfx5l3sn3zmnlz9jffddiqrs4f6h7m6cadai"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-covdefaults" ,python-covdefaults)
+ ("python-coverage" ,python-coverage)
+ ("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-regex" ,python-regex)))
+ (home-page "https://github.com/asottile/re-assert")
+ (synopsis "Show where your regex match assertion failed")
+ (description
+ "@code{re-assert} provides a helper class to make assertions of regexes
+simpler.")
+ (license license:expat)))
+
(define-public python-pytest-trio
(package
(name "python-pytest-trio")
--
2.29.1
V
V
Vinicius Monego wrote on 31 Oct 2020 21:05
[PATCH 2/2] gnu: pre-commit: Update to 2.8.1.
(address . 44359@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20201031200551.6451-1-monego@posteo.net
* gnu/packages/version-control.scm (pre-commit): Update to 2.8.1.
[arguments]: Skip new dotnet and nodejs tests.
[native-inputs]: Add python-re-assert.
[inputs]: Propagate.
---
gnu/packages/version-control.scm | 17 +++++++++++++----
1 file changed, 13 insertions(+), 4 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 036c0fa09b..38fab2996a 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -93,6 +93,7 @@
#:use-module (gnu packages perl-check)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-check)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
@@ -1441,7 +1442,7 @@ control to Git repositories.")
(define-public pre-commit
(package
(name "pre-commit")
- (version "2.7.1")
+ (version "2.8.1")
(source
(origin
;; No tests in the PyPI tarball.
@@ -1451,7 +1452,7 @@ control to Git repositories.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0n7qby5a4yz3s02nqcp5js6jg9wrd0x7msblxwb1883ds4b2b71a"))))
+ (base32 "0b3ks6viccq3n4p8i8zgfd40vp1k5nkhmmlz7p4nxcdizw8zxgn8"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -1492,6 +1493,12 @@ control to Git repositories.")
" and not test_additional_rust_lib_dependencies_installed"
" and not test_local_rust_additional_dependencies"
" and not test_rust_hook"
+ ;; Disable dotnet tests.
+ " and not test_dotnet_hook"
+ ;; Disable nodejs tests.
+ " and not test_unhealthy_if_system_node_goes_missing"
+ " and not test_installs_without_links_outside_env"
+ " and not test_healthy_system_node"
;; Disable python2 test.
" and not test_switch_language_versions_doesnt_clobber"
;; These tests try to open a network socket.
@@ -1534,8 +1541,10 @@ control to Git repositories.")
#t))))))
(native-inputs
`(("git" ,git-minimal)
- ("python-pytest" ,python-pytest)))
- (inputs
+ ("python-pytest" ,python-pytest)
+ ("python-re-assert" ,python-re-assert)))
+ ;; Propagate because pre-commit is also used as a module.
+ (propagated-inputs
`(("python-cfgv" ,python-cfgv)
("python-identify" ,python-identify)
("python-nodeenv" ,python-nodeenv)
--
2.29.1
M
M
Marius Bakke wrote on 10 Nov 2020 21:37
(name . Vinicius Monego)(address . monego@posteo.net)
87361hdk2n.fsf@gnu.org
Applied both patches, thanks!

[...]

Vinicius Monego <monego@posteo.net> writes:

Toggle quote (5 lines)
> * gnu/packages/version-control.scm (pre-commit): Update to 2.8.1.
> [arguments]: Skip new dotnet and nodejs tests.
> [native-inputs]: Add python-re-assert.
> [inputs]: Propagate.

It would be clearer to make the inputs propagated in a separate commit,
but obviously not a strong opinion.
-----BEGIN PGP SIGNATURE-----

iQFDBAEBCgAtFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl+q+iAPHG1hcml1c0Bn
bnUub3JnAAoJEKKgbfKjOlT6+OYIAJt9JdgsvNE+LFqykE62X9xd8El7s8n/2QRz
3t3HrppFps5mgv3ZEMCsWi8TTdxkK5432BedLx4qrqxr10RxpUNVjME6GTRkeRix
yb2QGSjAQ8Slf4KFvxs7e6aK+XCcW3NeMNEGsgxiJEriFGTHPHQtCO4Pnv4JFdct
Ri2ShCK5Dc8TKYpjq/GLdA9vF6YJNxg7bhYN56xjqA7cCbLV/nvKTG+Bq8eS1fDJ
W86FModvnj1zrcRA6f1nC5XZ5ALBlSOOSyhca09HDB8W6NGJAc+WW/CgbWWE6v3Q
/30xlTZ2ibpIBPBVfKLIv9grOYUFJPlLgNpHZb20XLq+3KnguTY=
=PcF+
-----END PGP SIGNATURE-----

Closed
?