[PATCH] gnu: emacs-dockerfile-mode: Update to 1.3.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 4 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20201028162825.723-1-mike@rohleder.de
* gnu/packages/emacs-xyz.scm (emacs-dockerfile-mode): Update to 1.3.
---
gnu/packages/emacs-xyz.scm | 44 ++++++++++++++++++--------------------
1 file changed, 21 insertions(+), 23 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 40e4c6367e..45022e099a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20342,30 +20342,28 @@ constant expressions.")
(license license:gpl3+)))
(define-public emacs-dockerfile-mode
- ;; Latest upstream release is too old.
- (let ((commit "ed73e82dcc636dad00d1a8c3b32a49136d25ee60"))
- (package
- (name "emacs-dockerfile-mode")
- (version (git-version "1.2" "2" commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/spotify/dockerfile-mode")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0lri2rnx4lr23vqfphkpq39cd4xfgzkvz1xsz7ccdvl4qj0k7fdl"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-s" ,emacs-s)))
- (home-page "https://github.com/spotify/dockerfile-mode")
- (synopsis "Major mode for editing Dockerfile")
- (description
- "This package provides a major mode @code{dockerfile-mode} for use with
+ (package
+ (name "emacs-dockerfile-mode")
+ (version "1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/spotify/dockerfile-mode")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1br73dsls42fn4rwagljkpa3l4wwj6f7jxfn3gmgl6c54z81av3v"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-s" ,emacs-s)))
+ (home-page "https://github.com/spotify/dockerfile-mode")
+ (synopsis "Major mode for editing Dockerfile")
+ (description
+ "This package provides a major mode @code{dockerfile-mode} for use with
the standard @code{Dockerfile} file format.")
- (license license:asl2.0))))
+ (license license:asl2.0)))
(define-public emacs-lsp-mode
(package
--
2.29.1
Nicolas Goaziou wrote 4 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 44282-done@debbugs.gnu.org)
87k0vanhz7.fsf@nicolasgoaziou.fr
Hello,

Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-dockerfile-mode): Update to 1.3.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44282@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44282
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help