[PATCH 0/1] knot-resolver: Silence warning re: deprecated option

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Simon South
Owner
unassigned
Submitted by
Simon South
Severity
normal

Debbugs page

Simon South wrote 4 years ago
(address . guix-patches@gnu.org)(address . simon@simonsouth.net)
cover.1603822404.git.simon@simonsouth.net
This small patch silences this warning from Knot Resolver when it starts:

deprecation WARNING: use --noninteractive instead of --forks=1

With version 5.0.0 the "-f" option was deprecated[0] in favour of "-n" as a
means of starting the daemon as a non-interactive process.

The patch updates Guix's service definition to match, without any functional
change to the service.


--
Simon South
simon@simonsouth.net


Simon South (1):
services: knot-resolver: Replace deprecated command-line option.

gnu/services/dns.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

--
2.28.0
Simon South wrote 4 years ago
[PATCH 1/1] services: knot-resolver: Replace deprecated command-line option.
(address . 44260@debbugs.gnu.org)(address . simon@simonsouth.net)
89820a76bacd52ff2435780355da90cf6da07c71.1603822404.git.simon@simonsouth.net
This silences a warning from the service at startup.

* gnu/services/dns.scm (knot-resolver-shepherd-services)[start]: Use the "-n"
command-line option to kresd in place of the deprecated "-f 1".
---
gnu/services/dns.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/services/dns.scm b/gnu/services/dns.scm
index 572880561c..b339eb0619 100644
--- a/gnu/services/dns.scm
+++ b/gnu/services/dns.scm
@@ -700,7 +700,7 @@ cache.size = 100 * MB
(documentation "Run the Knot Resolver daemon.")
(start #~(make-forkexec-constructor
'(#$(file-append package "/sbin/kresd")
- "-c" #$kresd-config-file "-f" "1"
+ "-c" #$kresd-config-file "-n"
"/var/cache/knot-resolver")))
(stop #~(make-kill-destructor)))
(shepherd-service
--
2.28.0
Leo Famulari wrote 4 years ago
(name . Simon South)(address . simon@simonsouth.net)(address . 44260-done@debbugs.gnu.org)
20201027224310.GA32529@jasmine.lan
On Tue, Oct 27, 2020 at 02:23:19PM -0400, Simon South wrote:
Toggle quote (5 lines)
> This silences a warning from the service at startup.
>
> * gnu/services/dns.scm (knot-resolver-shepherd-services)[start]: Use the "-n"
> command-line option to kresd in place of the deprecated "-f 1".

Thanks! Pushed as 5ede2595260d74e2990a8f004298ecf23ea66206
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44260@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44260
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help