Christopher Baines wrote 4 years ago
(address . guix-patches@gnu.org)
* gnu/packages/patchutils.scm (pwclient): New variable.
---
gnu/packages/patchutils.scm | 41 +++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)
Toggle diff (51 lines)
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index 12dd472c68..e0ed30070b 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -468,3 +468,44 @@ patches, and displays the patches along with comments and state information.
Users can login allowing them to change the state of patches.")
(home-page "http://jk.ozlabs.org/projects/patchwork/")
(license gpl2+)))
+
+(define-public pwclient
+ (package
+ (name "pwclient")
+ (version "1.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/getpatchwork/pwclient")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xckwvcqklzpyh3xs4k2zm40ifp0q5fdkj2vmgb8vhfvl1ivs6jv"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* "test-requirements.txt"
+ (("pytest>=3.0,<5.0;")
+ "pytest>=3.0,<6.0;"))
+ #t))
+ (add-before 'build 'set-PBR_VERSION
+ (lambda _
+ (setenv "PBR_VERSION"
+ ,version)
+ #t)))))
+ (native-inputs
+ `(("npython-pbr" ,python-pbr)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-mock" ,python-mock)))
+ (home-page
+ "https://github.com/getpatchwork/pwclient")
+ (synopsis "Command-line client for the Patchwork patch tracking tool")
+ (description
+ "pwclient is a VCS-agnostic tool for interacting with Patchwork, the
+web-based patch tracking system.")
+ (license gpl2+)))
--
2.28.0