[PATCH] gnu: Add pwclient.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 4 years ago
(address . guix-patches@gnu.org)
20201027094602.13503-1-mail@cbaines.net
* gnu/packages/patchutils.scm (pwclient): New variable.
---
gnu/packages/patchutils.scm | 41 +++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index 12dd472c68..e0ed30070b 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -468,3 +468,44 @@ patches, and displays the patches along with comments and state information.
Users can login allowing them to change the state of patches.")
(home-page "http://jk.ozlabs.org/projects/patchwork/")
(license gpl2+)))
+
+(define-public pwclient
+ (package
+ (name "pwclient")
+ (version "1.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/getpatchwork/pwclient")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xckwvcqklzpyh3xs4k2zm40ifp0q5fdkj2vmgb8vhfvl1ivs6jv"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* "test-requirements.txt"
+ (("pytest>=3.0,<5.0;")
+ "pytest>=3.0,<6.0;"))
+ #t))
+ (add-before 'build 'set-PBR_VERSION
+ (lambda _
+ (setenv "PBR_VERSION"
+ ,version)
+ #t)))))
+ (native-inputs
+ `(("npython-pbr" ,python-pbr)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-mock" ,python-mock)))
+ (home-page
+ "https://github.com/getpatchwork/pwclient")
+ (synopsis "Command-line client for the Patchwork patch tracking tool")
+ (description
+ "pwclient is a VCS-agnostic tool for interacting with Patchwork, the
+web-based patch tracking system.")
+ (license gpl2+)))
--
2.28.0
Leo Famulari wrote 4 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 44251@debbugs.gnu.org)
20201027230524.GC32529@jasmine.lan
On Tue, Oct 27, 2020 at 09:46:02AM +0000, Christopher Baines wrote:
Toggle quote (9 lines)
> * gnu/packages/patchutils.scm (pwclient): New variable.

> + (add-after 'unpack 'patch
> + (lambda _
> + (substitute* "test-requirements.txt"
> + (("pytest>=3.0,<5.0;")
> + "pytest>=3.0,<6.0;"))
> + #t))

I would call the phase 'patch-requirements' or similar and add a brief
comment explaining it.

Toggle quote (3 lines)
> + (native-inputs
> + `(("npython-pbr" ,python-pbr)

Typo here --^
Christopher Baines wrote 4 years ago
[PATCH v2] gnu: Add pwclient.
(address . 44251@debbugs.gnu.org)
20201028132937.9750-1-mail@cbaines.net
* gnu/packages/patchutils.scm (pwclient): New variable.
---
gnu/packages/patchutils.scm | 54 +++++++++++++++++++++++++++++++++++++
1 file changed, 54 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index 12dd472c68..da0f13a01e 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -468,3 +468,57 @@ patches, and displays the patches along with comments and state information.
Users can login allowing them to change the state of patches.")
(home-page "http://jk.ozlabs.org/projects/patchwork/")
(license gpl2+)))
+
+(define-public pwclient
+ (package
+ (name "pwclient")
+ (version "1.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/getpatchwork/pwclient")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xckwvcqklzpyh3xs4k2zm40ifp0q5fdkj2vmgb8vhfvl1ivs6jv"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-requirements
+ (lambda _
+ (substitute* "test-requirements.txt"
+ ;; The pytest requirement is unnecessarily strict
+ (("pytest>=3.0,<5.0;")
+ "pytest>=3.0,<6.0;"))
+ #t))
+ (add-before 'build 'set-PBR_VERSION
+ (lambda _
+ (setenv "PBR_VERSION"
+ ,version)
+ #t))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest"))
+ #t))
+ (add-after 'install 'install-man-page
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "man/pwclient.1"
+ (string-append
+ (assoc-ref outputs "out")
+ "/share/man/man1"))
+ #t)))))
+ (native-inputs
+ `(("python-pbr" ,python-pbr)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-mock" ,python-mock)))
+ (home-page
+ "https://github.com/getpatchwork/pwclient")
+ (synopsis "Command-line client for the Patchwork patch tracking tool")
+ (description
+ "pwclient is a VCS-agnostic tool for interacting with Patchwork, the
+web-based patch tracking system.")
+ (license gpl2+)))
--
2.28.0
Christopher Baines wrote 4 years ago
Re: [bug#44251] [PATCH] gnu: Add pwclient.
(name . Leo Famulari)(address . leo@famulari.name)(address . 44251@debbugs.gnu.org)
871rhizddl.fsf@cbaines.net
Leo Famulari <leo@famulari.name> writes:

Toggle quote (13 lines)
> On Tue, Oct 27, 2020 at 09:46:02AM +0000, Christopher Baines wrote:
>> * gnu/packages/patchutils.scm (pwclient): New variable.
>
>> + (add-after 'unpack 'patch
>> + (lambda _
>> + (substitute* "test-requirements.txt"
>> + (("pytest>=3.0,<5.0;")
>> + "pytest>=3.0,<6.0;"))
>> + #t))
>
> I would call the phase 'patch-requirements' or similar and add a brief
> comment explaining it.

I've renamed the phase now, and added a comment.

Toggle quote (5 lines)
>> + (native-inputs
>> + `(("npython-pbr" ,python-pbr)
>
> Typo here --^

Indeed, I've removed the rogue n.

I've sent an updated patch, which fixes a few more things as well.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl+ZcoZfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xf7rA//bc7x61sr3MmaoM4In/QomcdrX7162wyD
5phjaJMwdiJ79fnPm1Nn3J8BZSSW9a/T/yeHgE5XX4XNnsh7H1qlQxPCHwZrv76o
gqZvDqLjffWJyqKLRkeyVddSbyCCcyk0eSSUY0fjiiXXpEYfHT4MtCVRfX3SRye+
chl4XMaJ6Kd1lWsfXZrAnbCCW0VTOGdxD9cpDPfTKaZ+9rYkVI2Ribi/p8icrTsF
69iucD5izpz5HnKLy0RitY+qrqMmd1S93mAJzl/LcxeGRpki0Pr/kSrTjlkS4LXL
fGHqmeY0vre6odbx0tSMe+e99kFT30s7NANbtvT1tjgDkHQdHQK2K9zbm61esVk8
NimfJgn0QlePGK/Pw0rtsfY+v0DUP6mB2MCh/7my99URLl3UClSADT07v8EQUXii
opEUwmagVJ0CVRspledUqAEKO3nLWEN3DAMQFs8vjk9ChNmbbIqlJakRMZNRZYhC
TYhlGtq1CfM6T+hzlTgaMZ8u47XFF+D+3wd9aVStmgMnDjDctMGXqpttDD+cQoUg
c8QtzqBq+v5vohAKHWbEXToiiJJb0+D2blDBH7qnJ2LyWuCyMdufG9VRdaO98BrB
mS4YKz7tDBCAW72Od9h1B4wUgJDvahp3c8nGXArpJ1sX7+hiuXQJ8WB3o85xRfUs
m6VaKgsTiYM=
=buVS
-----END PGP SIGNATURE-----

Leo Famulari wrote 4 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 44251@debbugs.gnu.org)
20201028153619.GA9989@jasmine.lan
On Wed, Oct 28, 2020 at 01:30:46PM +0000, Christopher Baines wrote:
Toggle quote (2 lines)
> I've sent an updated patch, which fixes a few more things as well.

Alright, then you can push as you see fit :)
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAl+Zj+8ACgkQJkb6MLrK
fwjzRxAA7kmXJbRWXLwrvu0blxMgfmQ9XpczOFdz7iCqWYg/+YLcg8zznuTl+pOK
IDp6Mt1DNUlFyRstCnfADMRu4vp0ClXJB3Y3bjf5DwQ8yzhbQ8t8vG8Ei5+zjvGQ
Jnlz3IiIN5p9RJkLuz4ft+1tbrDj/qWjQrkIZls3QAHBukvlFyKYZsChbK5rvGIV
YV0sJ/2rG7vBX1szc5x7isN7N3rx5omLid5siwrS+X8s+36cJXyPSbfvRQ05uCE0
IPImD0UK0Ks5mhGhuY5qfGQhnpzPkCEV1upuoOpGclhf06nl3eGsyeHzqZqPcMMC
p3DQzwCSVeggV7sq4ghfyi2l8GVr6vMqOx+7Tk91ca/HZlwQIJOiV/iRwkB6gf/l
g2I0C0y+Q8CyOuRaJWGIGqyAClHvnOvqodnhRXF2u4co8yG0q1ADMcjSSRaESiRr
ViQYAYNaz4q+m0QlwXK9Sg3ThMYiafSky5UZ7lbjlPrmNc0HKgYmO61WZAfuGwcl
hyGxGcBt/Ql+GjM2DkCSjTLtnRswDQHUPnOHNaTA7WO2I6f43O0QoemEYc1vOrhv
0qbf4Ysc+63zuy6woegGpudgFOHURSMKUqckkIHGP2/EAckSp3EgfYyOAy3sh4+f
hwHv8q4GIi0ICS01K4OStAFD4ULl3+0A7U8qa11rElu1jDRNSk4=
=iNQG
-----END PGP SIGNATURE-----


Christopher Baines wrote 4 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 44251-done@debbugs.gnu.org)
87y2jqxpes.fsf@cbaines.net
Leo Famulari <leo@famulari.name> writes:

Toggle quote (5 lines)
> On Wed, Oct 28, 2020 at 01:30:46PM +0000, Christopher Baines wrote:
>> I've sent an updated patch, which fixes a few more things as well.
>
> Alright, then you can push as you see fit :)

Thanks for taking a look! I've pushed this to master as
f6839fed5f2052fd257b4af73effb10dcd9bf35b now.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl+ZohtfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdF3Q//XGn1G8BIXFGzuYuntXfv1snFBILCsOoA
LlKc+8OetCxYnzIx+TuygtIcsBSzlmYlH0Hl91SfZZM7DUC3oiPyM5272NuNMZbg
nw0dDSWiyFOHKLY9AvrpM7Zy8jrRGWpQ0g0CYBF4bMCnOE1aVCW1v7YZrUmCbNad
MBfQouwwymJKo0DitpNIeu12RV7Bttbfpt0MhINJ/ZLtkHmtjmstCvQyMR1xKgqY
YUsOrkUycLp5wv0jKegFIdQhjbLrFvh3q7adhJkL7DPbc63GpJVAXbOU59fyMFLT
7kFLYUsXFjMAlMhQkUA5QFb6r4ygANV5b9+c9mTrprv5HXtG8R3oGxPXpmxC32kf
0WJGes+4qnR4lZRN/57PgjnTcRzdPKb+b7pAAxazep20CK5+xW2sUwwXLxYEPdJ7
CGUhzEsthNbnv5mN4DHGy465Ui/5y8+RCn/QUgj5XjfIliabWPqs2TtgWDim5uT1
EaJiqJP8iBVbnNEo8AlF0ONeXUqFSuSza4GC2KCch0DL6aufCQR46aUiEkI9yYv6
nziSc4Yjtuah9Z1xDkfK2lfhUdMAm+LtPLl4hxUFOMdjBXIwLmGAMB9Tifkyn7e8
KiJH4ZeLFfjBoZyLC1Kh4U/+zqHlAwUssZ4YHzhyZDa7+9gioCKBklJRuH3lFGwm
OCHzc8aJEu8=
=4LO8
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44251@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44251
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help