Morgan.J.Smith wrote 4 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
From: Morgan Smith <Morgan.J.Smith@outlook.com>
* gnu/packages/emacs.scm (emacs) [strip-double-wrap]:
Use regex to find emacs executable. This works even when the version is
changed by package transformations (ex: version=git.master)
---
gnu/packages/emacs.scm | 16 ++++++----------
1 file changed, 6 insertions(+), 10 deletions(-)
Toggle diff (30 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 4963379d74..5c89e4c6b6 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -196,17 +196,13 @@
(lambda* (#:key outputs #:allow-other-keys)
;; Directly copy emacs-X.Y to emacs, so that it is not wrapped
;; twice. This also fixes a minor issue, where WMs would not be
- ;; able to track emacs back to emacs.desktop. The version is
- ;; accessed using using THIS-PACKAGE so it "just works" for
- ;; inherited Emacs packages of different versions.
+ ;; able to track emacs back to emacs.desktop.
(with-directory-excursion (assoc-ref outputs "out")
- (copy-file (string-append
- "bin/emacs-"
- ,(let ((this-version (package-version this-package)))
- (or (false-if-exception
- (version-major+minor+point this-version))
- (version-major+minor this-version))))
- "bin/emacs")
+ (copy-file
+ (car
+ (find-files
+ "bin" (file-name-predicate "^emacs-([0-9]+\\.)+[0-9]+$")))
+ "bin/emacs")
#t)))
(add-before 'reset-gzip-timestamps 'make-compressed-files-writable
;; The 'reset-gzip-timestamps phase will throw a permission error
--
2.29.1