[PATCH] gnu: qgis: Fix many plugins.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jonathan Brielmaier
  • Christopher Baines
Owner
unassigned
Submitted by
Jonathan Brielmaier
Severity
normal

Debbugs page

Jonathan Brielmaier wrote 4 years ago
(address . guix-patches@gnu.org)(address . jonathan.brielmaier@web.de)
20201026090732.18508-1-jonathan.brielmaier@web.de
This fixes the installation of many plugins.

* gnu/packages/geo.scm (qgis)[inputs]: Add python-future.
---
gnu/packages/geo.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (12 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index ce14a9e861..c412ec35b6 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2099,6 +2099,7 @@ growing set of geoscientific methods.")
("python" ,python)
("python-chardet" ,python-chardet)
("python-dateutil" ,python-dateutil)
+ ("python-future" ,python-future)
("python-gdal" ,python-gdal)
("python-jinja2" ,python-jinja2)
("python-numpy" ,python-numpy)
--
2.28.0
Christopher Baines wrote 4 years ago
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 44233-done@debbugs.gnu.org)
87ft60zxly.fsf@cbaines.net
Jonathan Brielmaier <jonathan.brielmaier@web.de> writes:

Toggle quote (21 lines)
> This fixes the installation of many plugins.
>
> * gnu/packages/geo.scm (qgis)[inputs]: Add python-future.
> ---
> gnu/packages/geo.scm | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
> index ce14a9e861..c412ec35b6 100644
> --- a/gnu/packages/geo.scm
> +++ b/gnu/packages/geo.scm
> @@ -2099,6 +2099,7 @@ growing set of geoscientific methods.")
> ("python" ,python)
> ("python-chardet" ,python-chardet)
> ("python-dateutil" ,python-dateutil)
> + ("python-future" ,python-future)
> ("python-gdal" ,python-gdal)
> ("python-jinja2" ,python-jinja2)
> ("python-numpy" ,python-numpy)

I've pushed this now as
542dc0ee4f2385c4d71f65fe3a36f4fe9eb68b9a. Thanks!
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl+XDBlfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xe8ew/6A8WqwINk505Bi+N3zgFMTo7BoR7KLtL5
6PjP2yElBUzkMrAzhVC4NAXW3SkIsQoX7eotOQ45zq6GHgY8dUbr0jQjdJHc3ndk
6NDIDDbUDlSWwRraKXzD35RXxl7IO83nkIWtJzNAhCbsbKgmRfUiKxb3tECxtboE
u7lqR+tE5nGTXajudtEMd14/YajEHC48qPHNSP6bf6B/ewN4VwVne5XMEBm47WPn
eqqSwYHhlffRimllivSSaDXv8XghWQmzrfGMIe1m75X2XRdIXwE6aiksYSKcAQpy
rhIpzatDswPbvfxP8JO9wwuhEOgdKYti0EJh8+q40yTmWJpU8sCizxgJA0LFaXXG
ILwD+PS+dUsTpHya0Je1BOT29QwFABB6Z6DGIAfztkthq+ice1Wuvt/r9fZBZCJY
JZ+Kj1f3Jyf66N/oHLj4ueJCG9xjLvVjseQ0Wj/Acz+J7OdwdBGIPAWrPsFSfaPI
j7gw/nPbti5lkJ26PkFq0j+kSgSeRxQ+nQhrCatKuIJdzBO9XFu2B+1fCxxBni0X
pyahBmiWN9EKuB28tLYowelVEVb0LN1UzI2Rqfira0uKZrR0WoNJCcOxq64/5wWv
bGOSZ7k63Oskfgby6ZBSWWZmKI+QlYdlxDWGAKEQxck5zBOh6KaN7Fqd6gzPtjZx
uzfHQrqiQTk=
=qOj6
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44233@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44233
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help