emacs-lojban and emacs-lojban-mode packages

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Lemmer Webber
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Christopher Lemmer Webber
Severity
normal

Debbugs page

Christopher Lemmer Webber wrote 4 years ago
(address . guix-patches@gnu.org)
87h7qi9eu0.fsf@dustycloud.org
Well, here are some WIP patches... two of them. Sadly they don't work
as-is, I'm hitting an error:

starting phase `build'
Checking /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/...
Compiling /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/lojban-autoloads.el...
Compiling /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/lojban.el...
Symbol’s value as variable is void: lojban-c-rgx
command "/gnu/store/k826y34z8zzjj57jv2nldmpw6vsdd145-emacs-minimal-27.1/bin/emacs" "--quick" "--batch" "--eval=(eval '(progn (setq byte-compile-debug t) (byte-recompile-directory (file-name-as-directory \"/gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp\") 0 1)) t)" failed with status 255
builder for `/gnu/store/lsjlw04kn85k7f38s7ni1g0ax8lbqzi4-emacs-lojban-0.23.drv' failed with exit code 1
build of /gnu/store/lsjlw04kn85k7f38s7ni1g0ax8lbqzi4-emacs-lojban-0.23.drv failed

But if I look at the downloaded lojban.el file, I see it there:

$ grep lojban-c-rgx /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/lojban.el
(defconst lojban-c-rgx (concat "[" lojban-c-letter-set "]")
...

Any ideas what might be causing it?
From 117fe9cafdce1946fd7b00d850b7f0c0961e8bfe Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Sun, 25 Oct 2020 17:21:08 -0400
Subject: [PATCH] gnu: Add emacs-lojban.

* gnu/packages/emacs-xyz.scm (emacs-lojban): New variable.
---
gnu/packages/emacs-xyz.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7dba5c50b8..ce5b8ac4ca 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25161,3 +25161,20 @@ the TypeScript implementation.")
(description "This package provides an Emacs client for the Rocket.chat
service.")
(license license:expat))))
+
+(define-public emacs-lojban
+ (package
+ (name "emacs-lojban")
+ (version "0.23")
+ (source
+ (origin
+ (method url-fetch)
+ (uri "https://www.emacswiki.org/emacs/download/lojban.el")
+ (sha256 (base32 "07fhlwhlbq0j19hw6cqdb9fkq9c6zvcpg6y909vsq98pg4ccsjg5"))))
+ (build-system emacs-build-system)
+ (home-page "https://www.emacswiki.org/emacs/lojban.el")
+ (synopsis "Emacs utilities for operating on lojban text")
+ (description
+ "lojban.el is an emacs library of functions, variables, regexps and
+interactive commands for handling lojban text.")
+ (license license:gpl2+)))
--
2.28.0
From 4eabeccaf2aaf879e3cc829899c143aaf55d082b Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Sun, 25 Oct 2020 17:21:56 -0400
Subject: [PATCH] gnu: Add emacs-lojban-mode.

* gnu/packages/emacs-xyz.scm (emacs-lojban-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ce5b8ac4ca..107bd6a9bf 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25178,3 +25178,25 @@ service.")
"lojban.el is an emacs library of functions, variables, regexps and
interactive commands for handling lojban text.")
(license license:gpl2+)))
+
+(define-public emacs-lojban-mode
+ (package
+ (name "emacs-lojban-mode")
+ (version "0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri "https://www.emacswiki.org/emacs/download/lojban-mode.el")
+ (sha256 (base32 "1l8wq3hzr77k5ibqb2ghzjskfvjhgfvwan1v8gma4msi5mjfiv30"))))
+ (build-system emacs-build-system)
+ (home-page "https://www.emacswiki.org/emacs/lojban-mode.el")
+ (synopsis "Emacs minor mode for lojban text")
+ (propagated-inputs
+ `(("emacs-lojban" ,emacs-lojban)))
+ (description
+ "lojban-mode provides a specialized minor mode for lojban text.
+It includes syntactical highlighting for lojban words.
+The three basic word types (cmavo, cmene, and brivla), sentence
+separators and attitudinal indicators are highlighted with
+different faces.")
+ (license license:gpl2+)))
--
2.28.0
Nicolas Goaziou wrote 4 years ago
(name . Christopher Lemmer Webber)(address . cwebber@dustycloud.org)(address . 44222@debbugs.gnu.org)
87361z4ats.fsf@nicolasgoaziou.fr
Hello,

Christopher Lemmer Webber <cwebber@dustycloud.org> writes:

Toggle quote (25 lines)
> Well, here are some WIP patches... two of them. Sadly they don't work
> as-is, I'm hitting an error:
>
> starting phase `build'
> Checking /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/...
> Compiling /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/lojban-autoloads.el...
> Compiling /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/lojban.el...
> Symbol’s value as variable is void: lojban-c-rgx
> command
> "/gnu/store/k826y34z8zzjj57jv2nldmpw6vsdd145-emacs-minimal-27.1/bin/emacs"
> "--quick" "--batch" "--eval=(eval '(progn (setq byte-compile-debug t)
> (byte-recompile-directory (file-name-as-directory
> \"/gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp\")
> 0 1)) t)" failed with status 255
> builder for `/gnu/store/lsjlw04kn85k7f38s7ni1g0ax8lbqzi4-emacs-lojban-0.23.drv' failed with exit code 1
> build of /gnu/store/lsjlw04kn85k7f38s7ni1g0ax8lbqzi4-emacs-lojban-0.23.drv failed
>
> But if I look at the downloaded lojban.el file, I see it there:
>
> $ grep lojban-c-rgx /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/lojban.el
> (defconst lojban-c-rgx (concat "[" lojban-c-letter-set "]")
> ...
>
> Any ideas what might be causing it?

This:

(eval-when-compile
(concat "\\(" lojban-c-rgx "\\)\\1"))

is the culprit. This is evaluated before compiling the file, when the
defconst is not defined yet.

Considering `lojban-c-rgx' is a constant, I'm not sure why
`eval-when-compile' would be better than defining the result as a new
constant.

In any case, a poor man's fix could be replacing `eval-when-compile'
with `progn', or

(concat "\\(" lojban-c-rgx "\\)\\1")

with

"\\([bcdfgj-npr-tvxz]\\)\\1"

Also,

+ (synopsis "Emacs utilities for operating on lojban text")
+ (description
+ "lojban.el is an emacs library of functions, variables, regexps and
+interactive commands for handling lojban text.")

I would capitalize Emacs, and Lojban.

Regards,
--
Nicolas Goaziou
Christopher Lemmer Webber wrote 4 years ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 44222@debbugs.gnu.org)
878sbr57m5.fsf@dustycloud.org
Nicolas Goaziou writes:

Toggle quote (37 lines)
> Hello,
>
> Christopher Lemmer Webber <cwebber@dustycloud.org> writes:
>
>> Well, here are some WIP patches... two of them. Sadly they don't work
>> as-is, I'm hitting an error:
>>
>> starting phase `build'
>> Checking /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/...
>> Compiling /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/lojban-autoloads.el...
>> Compiling /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/lojban.el...
>> Symbol’s value as variable is void: lojban-c-rgx
>> command
>> "/gnu/store/k826y34z8zzjj57jv2nldmpw6vsdd145-emacs-minimal-27.1/bin/emacs"
>> "--quick" "--batch" "--eval=(eval '(progn (setq byte-compile-debug t)
>> (byte-recompile-directory (file-name-as-directory
>> \"/gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp\")
>> 0 1)) t)" failed with status 255
>> builder for `/gnu/store/lsjlw04kn85k7f38s7ni1g0ax8lbqzi4-emacs-lojban-0.23.drv' failed with exit code 1
>> build of /gnu/store/lsjlw04kn85k7f38s7ni1g0ax8lbqzi4-emacs-lojban-0.23.drv failed
>>
>> But if I look at the downloaded lojban.el file, I see it there:
>>
>> $ grep lojban-c-rgx /gnu/store/2hgmjkw6m1id4gr9zcg7qgig9wj758mv-emacs-lojban-0.23/share/emacs/site-lisp/lojban.el
>> (defconst lojban-c-rgx (concat "[" lojban-c-letter-set "]")
>> ...
>>
>> Any ideas what might be causing it?
>
> This:
>
> (eval-when-compile
> (concat "\\(" lojban-c-rgx "\\)\\1"))
>
> is the culprit. This is evaluated before compiling the file, when the
> defconst is not defined yet.

I see!

Toggle quote (13 lines)
> Considering `lojban-c-rgx' is a constant, I'm not sure why
> `eval-when-compile' would be better than defining the result as a new
> constant.
>
> In any case, a poor man's fix could be replacing `eval-when-compile'
> with `progn', or
>
> (concat "\\(" lojban-c-rgx "\\)\\1")
>
> with
>
> "\\([bcdfgj-npr-tvxz]\\)\\1"

I'll give that a try.

Toggle quote (9 lines)
> Also,
>
> + (synopsis "Emacs utilities for operating on lojban text")
> + (description
> + "lojban.el is an emacs library of functions, variables, regexps and
> +interactive commands for handling lojban text.")
>
> I would capitalize Emacs, and Lojban.

Sounds sensible!

I'll try to follow up on this patch sometime in the next week (but no
promises).

Toggle quote (1 lines)
> Regards,
Nicolas Goaziou wrote 2 years ago
emacs-lojban and emacs-lojban-mode packages
(address . 44222-done@debbugs.gnu.org)
87v8hix0ut.fsf@nicolasgoaziou.fr
Hello,

Someone created a repository holding both files, so I took the liberty
to change upstream location in your package, and applied the patch.

Thanks,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44222@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44222
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help