[PATCH] gnu: emacs-evil: Add info page.

  • Done
  • quality assurance status badge
Details
2 participants
  • Oleg Pykhalov
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 4 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20201019220550.5120-1-mike@rohleder.de
* gnu/packages/emacs-xyz.scm (emacs-evil): Add info page.
[arguments]: Add phase make-info.
[native-inputs]: Add texinfo.
---
gnu/packages/emacs-xyz.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5acb8ce6ec..41f76132a6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9392,8 +9392,14 @@ news items, openrc and runscripts.")
(lambda _
(substitute* "evil-test-helpers.el"
(("\\(undo-tree-mode 1\\)") ""))
- #t)))))
+ #t))
+ (add-before 'install 'make-info
+ (lambda _
+ (chdir "doc/build/texinfo")
+ (invoke "makeinfo" "--no-split"
+ "-o" "evil.info" "evil.texi"))))))
(build-system emacs-build-system)
+ (native-inputs `(("texinfo" ,texinfo)))
(home-page "https://github.com/emacs-evil/evil")
(synopsis "Extensible Vi layer for Emacs")
(description
--
2.28.0
Oleg Pykhalov wrote 4 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 44086-done@debbugs.gnu.org)
87d01do0u4.fsf@gmail.com
Hi,

Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (6 lines)
> * gnu/packages/emacs-xyz.scm (emacs-evil): Add info page.
> [arguments]: Add phase make-info.
> [native-inputs]: Add texinfo.
> ---
> gnu/packages/emacs-xyz.scm | 8 +++++++-
> 1 file changed, 7 insertions(+), 1 deletion(-)
[…]

Pushed to master with "with-directory-excursion" instead of "chdir":
Toggle diff (17 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 41f76132a6..aab3f26e8b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9395,9 +9395,9 @@ news items, openrc and runscripts.")
#t))
(add-before 'install 'make-info
(lambda _
- (chdir "doc/build/texinfo")
- (invoke "makeinfo" "--no-split"
- "-o" "evil.info" "evil.texi"))))))
+ (with-directory-excursion "doc/build/texinfo"
+ (invoke "makeinfo" "--no-split"
+ "-o" "evil.info" "evil.texi")))))))
(build-system emacs-build-system)
(native-inputs `(("texinfo" ,texinfo)))
(home-page "https://github.com/emacs-evil/evil")
Oleg.
-----BEGIN PGP SIGNATURE-----

iQJIBAEBCgAyFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAl+OhsMUHGdvLndpZ3Vz
dEBnbWFpbC5jb20ACgkQFn+OpQAa+pxhVg/+I2blab5CAyZejH/We62IaCfIgbnt
1XhEokX9CuZM9Ng9UcazPJFfTVAocZS3S/IBlnhGZQgVf8BCdLVPquTAAMiwXo4J
jhN/ZXlMrYV2zR1jq32iX6VtZtapmQ6TBnmZjx+G+Z8g+fWodNhL39uT8IEqQvjs
0IGoGNSyv6dcFwjELuoXBCii/x5M5/U6vKGzHj6Np8M3vBjMvyKpfTtgpB7WvAXh
6aUAbLkjicPGL7LTM0XwFeucO3oOThcWqu9Nn8748GAIG7cWIh6NxJca8cIc+yTS
BAk/utg4y0mcBtG0HOImcoQq8Uu0uH0EknmtxiufTiDO7hR6qkXyx0RpXmSG617j
fDkPFC9ohQ36ASnBB3jtCI8fvah3/vcRtHa2bBKXuxw3zOttjV8M0WOywJZpiG+V
qzz9wNPyEi94/1GhVEu1jjeX3AzNgXWZQIRb0dr+5tP5JpRNd0rK7zL+LKae0hYq
rCBADNup/FBbKunSWcPAMZD1YYRPvDTjdNMR37U+tYKUlqBnE6izaVaw7lTASvn8
nlY3Iv1PcOBHK+5cGanRUUBu+xdmB0tiiH4n7ZABnPinJY0jiv/hE1aD1HM39AO+
EXJCgqkKaTdLGNcjQ6l6xiEMR4b0nr2j1288EaxWX44byF5l6WDwOD7U9wfkQo1B
PYVooHzXwV7nHuY=
=DjhY
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44086@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44086
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help