[PATCH] website: Add conference announcement.

  • Done
  • quality assurance status badge
Details
4 participants
  • Julien Lepiller
  • Ludovic Courtès
  • Tobias Geerinckx-Rice
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 15 Oct 2020 21:02
(address . guix-patches@gnu.org)
20201015190208.32131-1-zimon.toutoune@gmail.com
From: Julien Lepiller <julien@lepiller.eu>

* website/posts/virtual-guix-days-announce-1.md: New file.
* apps/base/templates/theme.scm: Add announcement bar on top of every
page.
* static/base/css/common.css: Add CSS for the announcement bar.

Co-authored-by: Simon Tournier <zimon.toutoune@gmail.com>
---
website/apps/base/templates/theme.scm | 6 +
website/posts/virtual-guix-days-announce-1.md | 104 ++++++++++++++++++
website/static/base/css/common.css | 11 ++
3 files changed, 121 insertions(+)
create mode 100644 website/posts/virtual-guix-days-announce-1.md

Toggle diff (153 lines)
diff --git a/website/apps/base/templates/theme.scm b/website/apps/base/templates/theme.scm
index 4734ee5..d875e5b 100644
--- a/website/apps/base/templates/theme.scm
+++ b/website/apps/base/templates/theme.scm
@@ -107,6 +107,12 @@
scripts))
(body
+ (div (@ (id "confbar"))
+ (p ,(G_ `("Guix will hold its first virtual conference November 22nd. "
+ "Propose a talk before October 20th. "
+ (a
+ (@ (href ,(guix-url "blog/2020/virtual-guix-days-announce-1/")))
+ "Learn more!")))))
,(navbar #:active-item active-menu-item)
,(if (null? crumbs) "" (breadcrumbs crumbs))
diff --git a/website/posts/virtual-guix-days-announce-1.md b/website/posts/virtual-guix-days-announce-1.md
new file mode 100644
index 0000000..c24bf0c
--- /dev/null
+++ b/website/posts/virtual-guix-days-announce-1.md
@@ -0,0 +1,104 @@
+title: Announcing the first virtual Guix Day Conference
+date: 2020-10-16 00:00
+author: Guix Hackers
+slug: virtual-guix-days-announce-1
+tags: Conference
+---
+
+The Guix hackers are very happy to announce the first virtual Guix Day
+Conference on **Sunday November, 22nd**. This conference is open to everyone
+and will be held online. Want to speak? Submit your proposal!
+
+Important dates:
+
+1. **November 6th**: Deadline for talks proposal.
+1. **November 14th**: Deadline for releasing your pre-recorded talks.
+1. **November 16th**: Release of the schedule.
+1. **November 22nd**: Conference day!
+
+The layout of the day is:
+
+ - pre-recorded talks with live question and answer sessions
+ - birds of a feather (BoF) sessions
+ - lightning round talks, if possible
+ - hack together
+
+*There will be no presentation on the 22nd!* And **no registration fee**.
+
+##### Until November 6th: talks proposal
+
+Propose your talks by sending them to `guix-devel@gnu.org`. Feel free to drop
+in `#guix` on irc.freenode.net to discuss what you would like to talk about
+before submitting. :)
+
+Please describe with 10 lines or more what your proposal is about. Even if it
+is a BoFs topic (smaller group who want to talk about specific topics).
+
+Once you have sent your proposal, you will be notified in the coming days
+whether we would like to have your talk be part of the Guix Day.
+
+Good topics include your own experience with Guix and what you feel important
+to share with your other fellows, for example a non-exhaustive topic list is:
+installer, Maven build system, Data Service, GNU Hurd and cross-compilation,
+Cuirass and continuous integration, authentication, secret services, website
+translation, translation infrastructure,… It is a single day so we won't be
+able to cover all. ;-)
+
+
+##### November 9th-14th: prepare your talk
+
+The aim of the pre-recorded talk is to demonstrate new features, what you are
+hacking on, introduce the subject for easing the live question and answer
+sessions or BoFs. These pre-recorded talks should be **15-45 minutes
+long**. Feel free to ask if you need help with the recording.
+
+You are free to choose whichever storage platform you want (e.g., your own
+website, a peertube instance, a nextcloud instance, etc.), but we will need to
+have access to the original file so we can publish it later on
+[audio-video.gnu.org](https://audio-video.gnu.org). Your video must be
+released under a license that at least allows anyone to copy and share it, for
+any purpose.
+
+You will have to release the video publicly before November 14th, so everyone
+has a chance to see it before the conference. If you are not able to do so
+(for instance your server cannot handle a huge load), you can alternatively
+send us a private link to the video and we will upload it on
+[audio-video.gnu.org](https://audio-video.gnu.org). If you decide to do so,
+you will need to have the video ready by November 12th.
+
+
+##### November 16th-22nd: watch the talks
+
+Be sure to watch the pre-recorded talks before the conference. There will be
+no presentation on the 22nd.
+
+
+##### November 22nd: participate
+
+Coming soon! Stay tuned.
+
+
+#### Code of Conduct
+
+This online conference is an official Guix communication channel. Therefore,
+the [Code of Conduct](http://git.savannah.gnu.org/cgit/guix.git/tree/CODE-OF-CONDUCT)
+applies. Please be sure to read it beforehand!
+
+#### About GNU Guix
+
+[GNU Guix](https://www.gnu.org/software/guix) is a transactional package
+manager and an advanced distribution of the GNU system that [respects
+user
+freedom](https://www.gnu.org/distros/free-system-distribution-guidelines.html).
+Guix can be used on top of any system running the Hurd or the Linux
+kernel, or it can be used as a standalone operating system distribution
+for i686, x86_64, ARMv7, and AArch64 machines.
+
+In addition to standard package management features, Guix supports
+transactional upgrades and roll-backs, unprivileged package management,
+per-user profiles, and garbage collection. When used as a standalone
+GNU/Linux distribution, Guix offers a declarative, stateless approach to
+operating system configuration management. Guix is highly customizable
+and hackable through [Guile](https://www.gnu.org/software/guile)
+programming interfaces and extensions to the
+[Scheme](http://schemers.org) language.
diff --git a/website/static/base/css/common.css b/website/static/base/css/common.css
index ee7a4e7..44e23c6 100644
--- a/website/static/base/css/common.css
+++ b/website/static/base/css/common.css
@@ -156,6 +156,17 @@
background-repeat: repeat-x;
}
+#confbar {
+ background-color: #542414;
+ color: #F5F5F5;
+ padding: 10px;
+ text-align: center;
+}
+
+#confbar a {
+ color: white;
+}
+
@media screen and (min-width: 1280px) {

base-commit: 2e0252dfa809d5a38ce87245764d936b659c16b4
--
2.28.0
L
L
Ludovic Courtès wrote on 16 Oct 2020 12:01
(name . zimoun)(address . zimon.toutoune@gmail.com)
877drq8p76.fsf@gnu.org
Howdy!

zimoun <zimon.toutoune@gmail.com> skribis:

Toggle quote (9 lines)
> From: Julien Lepiller <julien@lepiller.eu>
>
> * website/posts/virtual-guix-days-announce-1.md: New file.
> * apps/base/templates/theme.scm: Add announcement bar on top of every
> page.
> * static/base/css/common.css: Add CSS for the announcement bar.
>
> Co-authored-by: Simon Tournier <zimon.toutoune@gmail.com>

Yay!

Toggle quote (2 lines)
> +tags: Conference

Also “Community”.

Toggle quote (7 lines)
> + (div (@ (id "confbar"))
> + (p ,(G_ `("Guix will hold its first virtual conference November 22nd. "
> + "Propose a talk before October 20th. "
> + (a
> + (@ (href ,(guix-url "blog/2020/virtual-guix-days-announce-1/")))
> + "Learn more!")))))

I’d suggest s/virtual/on-line/ because it’s very real. :-)

Also, Oct. 20 is a short deadline no?

BTW, Nov. 23 will be the 8th anniversary:


Toggle quote (2 lines)
> +The layout of the day is:

s/layout/agenda/

Toggle quote (4 lines)
> +#### Code of Conduct
> +
> +This online conference is an official Guix communication channel. Therefore,

s/communication channel/event/

Toggle quote (3 lines)
> +applies. Please be sure to read it beforehand!

We should add a note (but maybe just before the event) of who to talk to
and how during the event to report abuse: specific IRC or BBB nicknames,
etc.

The rest looks *great* to me!

Also, make sure to adjust the date header before pushing.

Thanks,
Ludo’.
Z
Z
zimoun wrote on 16 Oct 2020 12:56
[PATCH v2] website: Add conference announcement.
(address . 44022@debbugs.gnu.org)
20201016105622.28410-1-zimon.toutoune@gmail.com
From: Julien Lepiller <julien@lepiller.eu>

* website/posts/virtual-guix-days-announce-1.md: New file.
* apps/base/templates/theme.scm: Add announcement bar on top of every
page.
* static/base/css/common.css: Add CSS for the announcement bar.

Co-authored-by: Simon Tournier <zimon.toutoune@gmail.com>
---
website/apps/base/templates/theme.scm | 6 +
website/posts/virtual-guix-days-announce-1.md | 104 ++++++++++++++++++
website/static/base/css/common.css | 11 ++
3 files changed, 121 insertions(+)
create mode 100644 website/posts/virtual-guix-days-announce-1.md

Toggle diff (151 lines)
diff --git a/website/apps/base/templates/theme.scm b/website/apps/base/templates/theme.scm
index 4734ee5..f0df9d1 100644
--- a/website/apps/base/templates/theme.scm
+++ b/website/apps/base/templates/theme.scm
@@ -107,6 +107,12 @@
scripts))
(body
+ (div (@ (id "confbar"))
+ (p ,(G_ `("Guix will hold its first online conference November 22nd. "
+ "Propose a talk before November 6th. "
+ (a
+ (@ (href ,(guix-url "blog/2020/virtual-guix-days-announce-1/")))
+ "Learn more!")))))
,(navbar #:active-item active-menu-item)
,(if (null? crumbs) "" (breadcrumbs crumbs))
diff --git a/website/posts/virtual-guix-days-announce-1.md b/website/posts/virtual-guix-days-announce-1.md
new file mode 100644
index 0000000..ed919c2
--- /dev/null
+++ b/website/posts/virtual-guix-days-announce-1.md
@@ -0,0 +1,104 @@
+title: Announcing the first online Guix Day Conference
+date: 2020-10-16 00:00
+author: Guix Hackers
+slug: virtual-guix-days-announce-1
+tags: Conference, Community
+---
+
+The Guix hackers are very happy to announce the first online Guix Day
+Conference on **Sunday November, 22nd**. This conference is open to everyone
+and will be held online. Want to speak? Submit your proposal!
+
+Important dates:
+
+1. **November 6th**: Deadline for talks proposal.
+1. **November 14th**: Deadline for releasing your pre-recorded talks.
+1. **November 16th**: Release of the schedule.
+1. **November 22nd**: Conference day!
+
+The agenda of the day is:
+
+ - pre-recorded talks with live question and answer sessions
+ - birds of a feather (BoF) sessions
+ - lightning round talks, if possible
+ - hack together
+
+*There will be no presentation on the 22nd!* And **no registration fee**.
+
+##### Until November 6th: talks proposal
+
+Propose your talks by sending them to `guix-devel@gnu.org`. Feel free to drop
+in `#guix` on irc.freenode.net to discuss what you would like to talk about
+before submitting. :)
+
+Please describe with 10 lines or more what your proposal is about. Even if it
+is a BoFs topic (smaller group who want to talk about specific topics).
+
+Once you have sent your proposal, you will be notified in the coming days
+whether we would like to have your talk be part of the Guix Day.
+
+Good topics include your own experience with Guix and what you feel important
+to share with your other fellows, for example a non-exhaustive topic list is:
+installer, Maven build system, Data Service, GNU Hurd and cross-compilation,
+Cuirass and continuous integration, authentication, secret services, website
+translation, translation infrastructure,… It is a single day so we won't be
+able to cover all. ;-)
+
+
+##### November 9th-14th: prepare your talk
+
+The aim of the pre-recorded talk is to demonstrate new features, what you are
+hacking on, introduce the subject for easing the live question and answer
+sessions or BoFs. These pre-recorded talks should be **15-45 minutes
+long**. Feel free to ask if you need help with the recording.
+
+You are free to choose whichever storage platform you want (e.g., your own
+website, a peertube instance, a nextcloud instance, etc.), but we will need to
+have access to the original file so we can publish it later on
+[audio-video.gnu.org](https://audio-video.gnu.org). Your video must be
+released under a license that at least allows anyone to copy and share it, for
+any purpose.
+
+You will have to release the video publicly before November 14th, so everyone
+has a chance to see it before the conference. If you are not able to do so
+(for instance your server cannot handle a huge load), you can alternatively
+send us a private link to the video and we will upload it on
+[audio-video.gnu.org](https://audio-video.gnu.org). If you decide to do so,
+you will need to have the video ready by November 12th.
+
+
+##### November 16th-22nd: watch the talks
+
+Be sure to watch the pre-recorded talks before the conference. There will be
+no presentation on the 22nd.
+
+
+##### November 22nd: participate
+
+Coming soon! Stay tuned.
+
+
+#### Code of Conduct
+
+This online conference is an official Guix event. Therefore, the [Code of
+Conduct](http://git.savannah.gnu.org/cgit/guix.git/tree/CODE-OF-CONDUCT)
+applies. Please be sure to read it beforehand!
+
+#### About GNU Guix
+
+[GNU Guix](https://www.gnu.org/software/guix) is a transactional package
+manager and an advanced distribution of the GNU system that [respects
+user
+freedom](https://www.gnu.org/distros/free-system-distribution-guidelines.html).
+Guix can be used on top of any system running the Hurd or the Linux
+kernel, or it can be used as a standalone operating system distribution
+for i686, x86_64, ARMv7, and AArch64 machines.
+
+In addition to standard package management features, Guix supports
+transactional upgrades and roll-backs, unprivileged package management,
+per-user profiles, and garbage collection. When used as a standalone
+GNU/Linux distribution, Guix offers a declarative, stateless approach to
+operating system configuration management. Guix is highly customizable
+and hackable through [Guile](https://www.gnu.org/software/guile)
+programming interfaces and extensions to the
+[Scheme](http://schemers.org) language.
diff --git a/website/static/base/css/common.css b/website/static/base/css/common.css
index ee7a4e7..44e23c6 100644
--- a/website/static/base/css/common.css
+++ b/website/static/base/css/common.css
@@ -156,6 +156,17 @@
background-repeat: repeat-x;
}
+#confbar {
+ background-color: #542414;
+ color: #F5F5F5;
+ padding: 10px;
+ text-align: center;
+}
+
+#confbar a {
+ color: white;
+}
+
@media screen and (min-width: 1280px) {
--
2.28.0
Z
Z
zimoun wrote on 16 Oct 2020 13:03
Re: [bug#44022] [PATCH] website: Add conference announcement.
(name . Ludovic Courtès)(address . ludo@gnu.org)
CAJ3okZ0Y-jf8dPHGcQaa6nk3mmEtgA2bkXuZJOWz+==OKrUoyg@mail.gmail.com
Hi Ludo,

Thank you for the review. Your comments are in the v2 patch.


On Fri, 16 Oct 2020 at 12:01, Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (2 lines)
> Also, Oct. 20 is a short deadline no?

The deadline is November 6th.


Toggle quote (4 lines)
> BTW, Nov. 23 will be the 8th anniversary:
>
> https://lists.gnu.org/archive/html/gnu-system-discuss/2012-11/msg00000.html

Is it really a coincidence? ;-)


Toggle quote (7 lines)
> > +applies. Please be sure to read it beforehand!
>
> We should add a note (but maybe just before the event) of who to talk to
> and how during the event to report abuse: specific IRC or BBB nicknames,
> etc.

The v2 patch does not tweak this part. I suggest to word something
for the next announcement when releasing the schedule. We could
provide details on how to participate and what does it mean, etc.

Cheers,
simon
J
J
Julien Lepiller wrote on 16 Oct 2020 13:33
(address . 44022@debbugs.gnu.org)
2BD0B5F6-60C2-4FBB-9C59-160C0E8AF2A8@lepiller.eu
Le 16 octobre 2020 07:03:20 GMT-04:00, zimoun <zimon.toutoune@gmail.com> a écrit :
Toggle quote (37 lines)
>Hi Ludo,
>
>Thank you for the review. Your comments are in the v2 patch.
>
>
>On Fri, 16 Oct 2020 at 12:01, Ludovic Courtès <ludo@gnu.org> wrote:
>
>> Also, Oct. 20 is a short deadline no?
>
>The deadline is November 6th.
>
>
>> BTW, Nov. 23 will be the 8th anniversary:
>>
>>
>https://lists.gnu.org/archive/html/gnu-system-discuss/2012-11/msg00000.html
>
>Is it really a coincidence? ;-)
>
>
>> > +the [Code of
>Conduct](http://git.savannah.gnu.org/cgit/guix.git/tree/CODE-OF-CONDUCT)
>> > +applies. Please be sure to read it beforehand!
>>
>> We should add a note (but maybe just before the event) of who to talk
>to
>> and how during the event to report abuse: specific IRC or BBB
>nicknames,
>> etc.
>
>The v2 patch does not tweak this part. I suggest to word something
>for the next announcement when releasing the schedule. We could
>provide details on how to participate and what does it mean, etc.
>
>Cheers,
>simon

Maybe fix the slug too, and the link as a consequence.
Z
Z
zimoun wrote on 16 Oct 2020 13:59
(name . Julien Lepiller)(address . julien@lepiller.eu)
CAJ3okZ0ee8MVh2eH9DmXSLfB09yQJaeAna3Tm1Af0u+41dezxQ@mail.gmail.com
On Fri, 16 Oct 2020 at 13:33, Julien Lepiller <julien@lepiller.eu> wrote:

Toggle quote (2 lines)
> Maybe fix the slug too, and the link as a consequence.

Slug*? And which link?
(about the 8th anniversary?)


Cheers,
simon

*slug=limace? Slang I miss?
J
J
Julien Lepiller wrote on 16 Oct 2020 14:00
(name . zimoun)(address . zimon.toutoune@gmail.com)
B2F95520-744C-417E-9D1C-738FDBEB0B79@lepiller.eu
Le 16 octobre 2020 07:59:27 GMT-04:00, zimoun <zimon.toutoune@gmail.com> a écrit :
Toggle quote (14 lines)
>On Fri, 16 Oct 2020 at 13:33, Julien Lepiller <julien@lepiller.eu>
>wrote:
>
>> Maybe fix the slug too, and the link as a consequence.
>
>Slug*? And which link?
>(about the 8th anniversary?)
>
>
>Cheers,
>simon
>
>*slug=limace? Slang I miss?

In the header of the blog post. That's what produces the URL. And so, the link to the blog post in the header.
Z
Z
zimoun wrote on 16 Oct 2020 14:23
[PATCH v3] website: Add conference announcement.
(address . 44022@debbugs.gnu.org)
20201016122336.28675-1-zimon.toutoune@gmail.com
From: Julien Lepiller <julien@lepiller.eu>

* website/posts/online-guix-days-announce-1.md: New file.
* apps/base/templates/theme.scm: Add announcement bar on top of every
page.
* static/base/css/common.css: Add CSS for the announcement bar.

Co-authored-by: Simon Tournier <zimon.toutoune@gmail.com>
---
website/apps/base/templates/theme.scm | 6 ++
website/posts/online-guix-days-announce-1.md | 104 +++++++++++++++++++
website/static/base/css/common.css | 11 ++
3 files changed, 121 insertions(+)
create mode 100644 website/posts/online-guix-days-announce-1.md

Toggle diff (151 lines)
diff --git a/website/apps/base/templates/theme.scm b/website/apps/base/templates/theme.scm
index 4734ee5..f0df9d1 100644
--- a/website/apps/base/templates/theme.scm
+++ b/website/apps/base/templates/theme.scm
@@ -107,6 +107,12 @@
scripts))
(body
+ (div (@ (id "confbar"))
+ (p ,(G_ `("Guix will hold its first online conference November 22nd. "
+ "Propose a talk before November 6th. "
+ (a
+ (@ (href ,(guix-url "blog/2020/virtual-guix-days-announce-1/")))
+ "Learn more!")))))
,(navbar #:active-item active-menu-item)
,(if (null? crumbs) "" (breadcrumbs crumbs))
diff --git a/website/posts/online-guix-days-announce-1.md b/website/posts/online-guix-days-announce-1.md
new file mode 100644
index 0000000..ed919c2
--- /dev/null
+++ b/website/posts/online-guix-days-announce-1.md
@@ -0,0 +1,104 @@
+title: Announcing the first online Guix Day Conference
+date: 2020-10-16 00:00
+author: Guix Hackers
+slug: virtual-guix-days-announce-1
+tags: Conference, Community
+---
+
+The Guix hackers are very happy to announce the first online Guix Day
+Conference on **Sunday November, 22nd**. This conference is open to everyone
+and will be held online. Want to speak? Submit your proposal!
+
+Important dates:
+
+1. **November 6th**: Deadline for talks proposal.
+1. **November 14th**: Deadline for releasing your pre-recorded talks.
+1. **November 16th**: Release of the schedule.
+1. **November 22nd**: Conference day!
+
+The agenda of the day is:
+
+ - pre-recorded talks with live question and answer sessions
+ - birds of a feather (BoF) sessions
+ - lightning round talks, if possible
+ - hack together
+
+*There will be no presentation on the 22nd!* And **no registration fee**.
+
+##### Until November 6th: talks proposal
+
+Propose your talks by sending them to `guix-devel@gnu.org`. Feel free to drop
+in `#guix` on irc.freenode.net to discuss what you would like to talk about
+before submitting. :)
+
+Please describe with 10 lines or more what your proposal is about. Even if it
+is a BoFs topic (smaller group who want to talk about specific topics).
+
+Once you have sent your proposal, you will be notified in the coming days
+whether we would like to have your talk be part of the Guix Day.
+
+Good topics include your own experience with Guix and what you feel important
+to share with your other fellows, for example a non-exhaustive topic list is:
+installer, Maven build system, Data Service, GNU Hurd and cross-compilation,
+Cuirass and continuous integration, authentication, secret services, website
+translation, translation infrastructure,… It is a single day so we won't be
+able to cover all. ;-)
+
+
+##### November 9th-14th: prepare your talk
+
+The aim of the pre-recorded talk is to demonstrate new features, what you are
+hacking on, introduce the subject for easing the live question and answer
+sessions or BoFs. These pre-recorded talks should be **15-45 minutes
+long**. Feel free to ask if you need help with the recording.
+
+You are free to choose whichever storage platform you want (e.g., your own
+website, a peertube instance, a nextcloud instance, etc.), but we will need to
+have access to the original file so we can publish it later on
+[audio-video.gnu.org](https://audio-video.gnu.org). Your video must be
+released under a license that at least allows anyone to copy and share it, for
+any purpose.
+
+You will have to release the video publicly before November 14th, so everyone
+has a chance to see it before the conference. If you are not able to do so
+(for instance your server cannot handle a huge load), you can alternatively
+send us a private link to the video and we will upload it on
+[audio-video.gnu.org](https://audio-video.gnu.org). If you decide to do so,
+you will need to have the video ready by November 12th.
+
+
+##### November 16th-22nd: watch the talks
+
+Be sure to watch the pre-recorded talks before the conference. There will be
+no presentation on the 22nd.
+
+
+##### November 22nd: participate
+
+Coming soon! Stay tuned.
+
+
+#### Code of Conduct
+
+This online conference is an official Guix event. Therefore, the [Code of
+Conduct](http://git.savannah.gnu.org/cgit/guix.git/tree/CODE-OF-CONDUCT)
+applies. Please be sure to read it beforehand!
+
+#### About GNU Guix
+
+[GNU Guix](https://www.gnu.org/software/guix) is a transactional package
+manager and an advanced distribution of the GNU system that [respects
+user
+freedom](https://www.gnu.org/distros/free-system-distribution-guidelines.html).
+Guix can be used on top of any system running the Hurd or the Linux
+kernel, or it can be used as a standalone operating system distribution
+for i686, x86_64, ARMv7, and AArch64 machines.
+
+In addition to standard package management features, Guix supports
+transactional upgrades and roll-backs, unprivileged package management,
+per-user profiles, and garbage collection. When used as a standalone
+GNU/Linux distribution, Guix offers a declarative, stateless approach to
+operating system configuration management. Guix is highly customizable
+and hackable through [Guile](https://www.gnu.org/software/guile)
+programming interfaces and extensions to the
+[Scheme](http://schemers.org) language.
diff --git a/website/static/base/css/common.css b/website/static/base/css/common.css
index ee7a4e7..44e23c6 100644
--- a/website/static/base/css/common.css
+++ b/website/static/base/css/common.css
@@ -156,6 +156,17 @@
background-repeat: repeat-x;
}
+#confbar {
+ background-color: #542414;
+ color: #F5F5F5;
+ padding: 10px;
+ text-align: center;
+}
+
+#confbar a {
+ color: white;
+}
+
@media screen and (min-width: 1280px) {
--
2.28.0
Z
Z
zimoun wrote on 16 Oct 2020 14:25
Re: [bug#44022] [PATCH] website: Add conference announcement.
(name . Julien Lepiller)(address . julien@lepiller.eu)
CAJ3okZ3S5cG-i62BatQgEmhwF56x+5g17gCu98dUkZ2Wiiy63g@mail.gmail.com
On Fri, 16 Oct 2020 at 14:00, Julien Lepiller <julien@lepiller.eu> wrote:

Toggle quote (2 lines)
> In the header of the blog post. That's what produces the URL. And so, the link to the blog post in the header.

Sorry. I got it. See v4.

Cheers,
simon
T
T
Tobias Geerinckx-Rice wrote on 16 Oct 2020 14:39
(name . zimoun)(address . zimon.toutoune@gmail.com)
87a6wmbb0a.fsf@nckx
Julien, Zimoun,

Thank you both!

Toggle quote (3 lines)
> first online Guix Day
> will be held online.

Right. ‘Entirely online’ if for emphasis?

(Missing double-space BTW.)

Toggle quote (2 lines)
> whether we would like to have your talk be part of the Guix Day.

‘whether your talk will be part of the Guix Day’, unless this is
deliberately hedged? Then it sounds a little clumsy, but I guess
that's OK.

Toggle quote (2 lines)
> what you feel important

‘what you feel is important’

Toggle quote (2 lines)
> birds of a feather (BoF) sessions

I know this is well-known conference-goer slang, but I had to look
it up. Even knowing what it stands for isn't enough to know what
it means. Is there a short synonym?

Toggle quote (2 lines)
> lightning round talks

= lightning talks?

Toggle quote (2 lines)
> a peertube instance, a nextcloud instance

‘PeerTube’; ‘Nextcloud’.

Toggle quote (3 lines)
> :)
> ;-)

Now you're just trolling my neuroses. ;[-])

zimoun ???
Toggle quote (2 lines)
> *slug=limace? Slang I miss?

Old printer's slang appropriated for the digital age:

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCX4mUhQ0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15VKIA/RDrAkFDdbWvcckC2mWjCV6CP94diMqjri74boDx
4JMoAP9wCUF6UhtziVLJ+3g0upFAB8wd3ILxuYQI+LIUX4wPDA==
=y5+A
-----END PGP SIGNATURE-----

Z
Z
zimoun wrote on 16 Oct 2020 14:53
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)
CAJ3okZ2EjB+ioQyLqxh00mQ49r3Cq9ybCR7AJv3E3CmJ14KwEA@mail.gmail.com
Hi Tobias,

Thank you for the review. Will be incorporated in v4.

On Fri, 16 Oct 2020 at 14:39, Tobias Geerinckx-Rice <me@tobias.gr> wrote:

Toggle quote (6 lines)
> > birds of a feather (BoF) sessions
>
> I know this is well-known conference-goer slang, but I had to look
> it up. Even knowing what it stands for isn't enough to know what
> it means. Is there a short synonym?

There is this: "BoFs topic (smaller group who want to talk about
specific topics)." under "talk proposals". Maybe the wrong place.
WDYT?

Toggle quote (6 lines)
> zimoun ???
> > *slug=limace? Slang I miss?
>
> Old printer's slang appropriated for the digital age:
> https://en.wikipedia.org/wiki/Slug_(typesetting).

Oh! You did my day. :-) Thank you.

Cheers,
simon
Z
Z
zimoun wrote on 16 Oct 2020 18:58
[PATCH v4] website: Add conference announcement.
(address . 44022@debbugs.gnu.org)
20201016165843.5537-1-zimon.toutoune@gmail.com
From: Julien Lepiller <julien@lepiller.eu>

* website/posts/online-guix-day-announce-1.md: New file.
* apps/base/templates/theme.scm: Add announcement bar on top of every
page.
* static/base/css/common.css: Add CSS for the announcement bar.

Co-authored-by: Simon Tournier <zimon.toutoune@gmail.com>
---
website/apps/base/templates/theme.scm | 6 ++
website/posts/online-guix-day-announce-1.md | 104 ++++++++++++++++++++
website/static/base/css/common.css | 11 +++
3 files changed, 121 insertions(+)
create mode 100644 website/posts/online-guix-day-announce-1.md

Toggle diff (151 lines)
diff --git a/website/apps/base/templates/theme.scm b/website/apps/base/templates/theme.scm
index 4734ee5..f5677a9 100644
--- a/website/apps/base/templates/theme.scm
+++ b/website/apps/base/templates/theme.scm
@@ -107,6 +107,12 @@
scripts))
(body
+ (div (@ (id "confbar"))
+ (p ,(G_ `("Guix will hold its first online conference November 22nd. "
+ "Propose a talk before November 6th. "
+ (a
+ (@ (href ,(guix-url "blog/2020/online-guix-day-announce-1/")))
+ "Learn more!")))))
,(navbar #:active-item active-menu-item)
,(if (null? crumbs) "" (breadcrumbs crumbs))
diff --git a/website/posts/online-guix-day-announce-1.md b/website/posts/online-guix-day-announce-1.md
new file mode 100644
index 0000000..b856201
--- /dev/null
+++ b/website/posts/online-guix-day-announce-1.md
@@ -0,0 +1,104 @@
+title: Announcing the first online Guix Day Conference
+date: 2020-10-16 00:00
+author: Guix Hackers
+slug: online-guix-day-announce-1
+tags: Conference, Community
+---
+
+The Guix hackers are very happy to announce the first online Guix Day
+Conference on **Sunday November, 22nd**. This conference is open to everyone
+and will be held entirely online. Want to speak? Submit your proposal!
+
+Important dates:
+
+1. **November 6th**: Deadline for talks proposal.
+1. **November 14th**: Deadline for releasing your pre-recorded talks.
+1. **November 16th**: Release of the schedule.
+1. **November 22nd**: Conference day!
+
+The agenda of the day is:
+
+ - pre-recorded talks with live question and answer sessions
+ - birds of a feather (BoF) sessions
+ - lightning round talks, if possible
+ - hack together
+
+*There will be no presentation on the 22nd!* And **no registration fee**.
+
+##### Until November 6th: talks proposal
+
+Propose your talks by sending them to `guix-devel@gnu.org`. Feel free to drop
+in `#guix` on irc.freenode.net to discuss what you would like to talk about
+before submitting. :)
+
+Please describe with 10 lines or more what your proposal is about. Even if it
+is a BoFs topic (smaller group who want to talk about specific topics).
+
+Once you have sent your proposal, you will be notified in the coming days
+whether your talk be part of the Guix Day.
+
+Good topics include your own experience with Guix and what you feel is
+important to share with your other fellows, for example a non-exhaustive topic
+list is: installer, Maven build system, Data Service, GNU Hurd and
+cross-compilation, Cuirass and continuous integration, authentication, secret
+services, website translation, translation infrastructure,… It is a single
+day so we won't be able to cover all. ;-)
+
+
+##### November 9th-14th: prepare your talk
+
+The aim of the pre-recorded talk is to demonstrate new features, what you are
+hacking on, introduce the subject for easing the live question and answer
+sessions or BoFs. These pre-recorded talks should be **15-45 minutes
+long**. Feel free to ask if you need help with the recording.
+
+You are free to choose whichever storage platform you want (e.g., your own
+website, a PeerTube instance, a Nextcloud instance, etc.), but we will need to
+have access to the original file so we can publish it later on
+[audio-video.gnu.org](https://audio-video.gnu.org). Your video must be
+released under a license that at least allows anyone to copy and share it, for
+any purpose.
+
+You will have to release the video publicly before November 14th, so everyone
+has a chance to see it before the conference. If you are not able to do so
+(for instance your server cannot handle a huge load), you can alternatively
+send us a private link to the video and we will upload it on
+[audio-video.gnu.org](https://audio-video.gnu.org). If you decide to do so,
+you will need to have the video ready by November 12th.
+
+
+##### November 16th-22nd: watch the talks
+
+Be sure to watch the pre-recorded talks before the conference. There will be
+no presentation on the 22nd.
+
+
+##### November 22nd: participate
+
+Coming soon! Stay tuned.
+
+
+#### Code of Conduct
+
+This online conference is an official Guix event. Therefore, the [Code of
+Conduct](http://git.savannah.gnu.org/cgit/guix.git/tree/CODE-OF-CONDUCT)
+applies. Please be sure to read it beforehand!
+
+#### About GNU Guix
+
+[GNU Guix](https://www.gnu.org/software/guix) is a transactional package
+manager and an advanced distribution of the GNU system that [respects
+user
+freedom](https://www.gnu.org/distros/free-system-distribution-guidelines.html).
+Guix can be used on top of any system running the Hurd or the Linux
+kernel, or it can be used as a standalone operating system distribution
+for i686, x86_64, ARMv7, and AArch64 machines.
+
+In addition to standard package management features, Guix supports
+transactional upgrades and roll-backs, unprivileged package management,
+per-user profiles, and garbage collection. When used as a standalone
+GNU/Linux distribution, Guix offers a declarative, stateless approach to
+operating system configuration management. Guix is highly customizable
+and hackable through [Guile](https://www.gnu.org/software/guile)
+programming interfaces and extensions to the
+[Scheme](http://schemers.org) language.
diff --git a/website/static/base/css/common.css b/website/static/base/css/common.css
index ee7a4e7..44e23c6 100644
--- a/website/static/base/css/common.css
+++ b/website/static/base/css/common.css
@@ -156,6 +156,17 @@
background-repeat: repeat-x;
}
+#confbar {
+ background-color: #542414;
+ color: #F5F5F5;
+ padding: 10px;
+ text-align: center;
+}
+
+#confbar a {
+ color: white;
+}
+
@media screen and (min-width: 1280px) {
--
2.28.0
L
L
Ludovic Courtès wrote on 19 Oct 2020 11:15
(name . zimoun)(address . zimon.toutoune@gmail.com)
87d01e1sqx.fsf@gnu.org
Hi there!

Congrats on publishing this!

How about using the attached image, based on
when advertising the event?

Is the name fine? Is it OK to advertise the dates like this? (I think
so, people will have to read the instructions anyway.)

Thanks,
Ludo’.
Z
Z
zimoun wrote on 19 Oct 2020 12:18
(name . Ludovic Courtès)(address . ludo@gnu.org)
CAJ3okZ1e1jMaq2Fb7R4x9QOPyof=7pGjR3BiYhPR-zzU-Ux_og@mail.gmail.com
Hi,

On Mon, 19 Oct 2020 at 11:15, Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (4 lines)
> How about using the attached image, based on
> <https://git.savannah.gnu.org/cgit/guix/guix-artwork.git/tree/logo/Guix-Days-2020.svg>,
> when advertising the event?

Nice!


Toggle quote (3 lines)
> Is the name fine? Is it OK to advertise the dates like this? (I think
> so, people will have to read the instructions anyway.)

Yes, why not? Do you think this could be added to the blog post ?

Cheers,
simon
L
L
Ludovic Courtès wrote on 21 Oct 2020 19:14
control message for bug #44022
(address . control@debbugs.gnu.org)
87y2jzzeld.fsf@gnu.org
tags 44022 fixed
close 44022
quit
?