add dbus-cxx

  • Done
  • quality assurance status badge
Details
2 participants
  • Miguel Ángel Arruga Vivas
  • tiregram arthur
Owner
unassigned
Submitted by
tiregram arthur
Severity
normal
T
T
tiregram arthur wrote on 15 Oct 2020 19:19
(address . guix-patches@gnu.org)
CAHBH9LCizAbb+dyCZP3a6WYssqBKgQJiu=KxPHo6NMti0od-3w@mail.gmail.com
From c3804aca21c496e66e44ba48fd150501154dfb6d Mon Sep 17 00:00:00 2001
From: ruhtra <ruhtra.mar@gmail.com>
Date: Thu, 15 Oct 2020 18:58:46 +0200
Subject: [PATCH] to add dbus-cxx package add gnu/packages/dbus-cxx.scm

---
gnu/packages/dbus-cxx.scm | 52 +++++++++++++++++++++++++++++++++++++++
1 file changed, 52 insertions(+)
create mode 100644 gnu/packages/dbus-cxx.scm

Toggle diff (58 lines)
diff --git a/gnu/packages/dbus-cxx.scm b/gnu/packages/dbus-cxx.scm
new file mode 100644
index 0000000000..4ec08fb4ac
--- /dev/null
+++ b/gnu/packages/dbus-cxx.scm
@@ -0,0 +1,52 @@
+;;; Copyright © 2020 Arthur Margerit <ruhtra.mar@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages dbus-cxx)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system cmake)
+ #:use-module (guix licenses)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages m4)
+ #:use-module ((gnu packages glib) #:select (dbus libsigc++)))
+
+(define-public dbus-cxx
+ (package
+ (name "dbus-cxx")
+ (version "0.12.0")
+ (source (origin
+ (file-name (git-file-name name version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dbus-cxx/dbus-cxx")
+ (commit "ea7f8e361d11dc7d41d9ae2c4128aed2cdadd84e")))
+ (sha256
+ (base32
+ "1sa448icfvl08rnik0lnk4scmkwhfyd3mrxh36jh8x7xndp90khp"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f))
+ (inputs `(("dbus-glib", dbus) ("libsigc++", libsigc++)))
+ (native-inputs `(("pkg-config", pkg-config) ("m4", m4)))
+ (synopsis "C++ wrapper for dbus")
+ (description "Dbus-cxx is a C++ wrapper for dbus.
+It exposes the C API to allow direct manipulation and
+relies on sigc++ to provide an OO interface.
+Also included is dbus-cxx-xml2cpp to generate proxy and adapter
+ interfaces from DBus XML introspection-like documents.")
+ (home-page "https://dbus-cxx.github.io/")
+ (license gpl3)))
--
2.28.0
M
M
Miguel Ángel Arruga Vivas wrote on 19 Oct 2020 16:32
(name . tiregram arthur)(address . ruhtra.mar@gmail.com)(address . 44019@debbugs.gnu.org)
87h7qqnv5u.fsf@gmail.com
Hi Arthur,

Thank you very much for your patch. Nonetheless, there is already a
package named dbus-c++ and that can be found in gnu/packages/glib.scm
and the description fits almost exactly this one, but it's being used
currently only by libring (Jami). Even if they are different projects
(dbus-c++ and dbus-cxx), they should belong together in the source code
(gnu/packages/glib.scm).

Could you confirm that they are different code bases, and also move that
definition there for the patch if that's the case?

Happy hacking!
Miguel

tiregram arthur <ruhtra.mar@gmail.com> writes:

Toggle quote (70 lines)
>>From c3804aca21c496e66e44ba48fd150501154dfb6d Mon Sep 17 00:00:00 2001
> From: ruhtra <ruhtra.mar@gmail.com>
> Date: Thu, 15 Oct 2020 18:58:46 +0200
> Subject: [PATCH] to add dbus-cxx package add gnu/packages/dbus-cxx.scm
>
> ---
> gnu/packages/dbus-cxx.scm | 52 +++++++++++++++++++++++++++++++++++++++
> 1 file changed, 52 insertions(+)
> create mode 100644 gnu/packages/dbus-cxx.scm
>
> diff --git a/gnu/packages/dbus-cxx.scm b/gnu/packages/dbus-cxx.scm
> new file mode 100644
> index 0000000000..4ec08fb4ac
> --- /dev/null
> +++ b/gnu/packages/dbus-cxx.scm
> @@ -0,0 +1,52 @@
> +;;; Copyright © 2020 Arthur Margerit <ruhtra.mar@gmail.com>
> +;;;
> +;;; This file is part of GNU Guix.
> +;;;
> +;;; GNU Guix is free software; you can redistribute it and/or modify it
> +;;; under the terms of the GNU General Public License as published by
> +;;; the Free Software Foundation; either version 3 of the License, or (at
> +;;; your option) any later version.
> +;;;
> +;;; GNU Guix is distributed in the hope that it will be useful, but
> +;;; WITHOUT ANY WARRANTY; without even the implied warranty of
> +;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
> +;;; GNU General Public License for more details.
> +;;;
> +;;; You should have received a copy of the GNU General Public License
> +;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
> +
> +(define-module (gnu packages dbus-cxx)
> + #:use-module (guix packages)
> + #:use-module (guix git-download)
> + #:use-module (guix build-system cmake)
> + #:use-module (guix licenses)
> + #:use-module (gnu packages pkg-config)
> + #:use-module (gnu packages m4)
> + #:use-module ((gnu packages glib) #:select (dbus libsigc++)))
> +
> +(define-public dbus-cxx
> + (package
> + (name "dbus-cxx")
> + (version "0.12.0")
> + (source (origin
> + (file-name (git-file-name name version))
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/dbus-cxx/dbus-cxx")
> + (commit "ea7f8e361d11dc7d41d9ae2c4128aed2cdadd84e")))
> + (sha256
> + (base32
> + "1sa448icfvl08rnik0lnk4scmkwhfyd3mrxh36jh8x7xndp90khp"))))
> + (build-system cmake-build-system)
> + (arguments
> + `(#:tests? #f))
> + (inputs `(("dbus-glib", dbus) ("libsigc++", libsigc++)))
> + (native-inputs `(("pkg-config", pkg-config) ("m4", m4)))
> + (synopsis "C++ wrapper for dbus")
> + (description "Dbus-cxx is a C++ wrapper for dbus.
> +It exposes the C API to allow direct manipulation and
> +relies on sigc++ to provide an OO interface.
> +Also included is dbus-cxx-xml2cpp to generate proxy and adapter
> + interfaces from DBus XML introspection-like documents.")
> + (home-page "https://dbus-cxx.github.io/")
> + (license gpl3)))
> --
> 2.28.0
M
M
Miguel Ángel Arruga Vivas wrote on 19 Oct 2020 16:33
control message for bug #44019
(address . control@debbugs.gnu.org)
87ft6anv42.fsf@gmail.com
tags 44019 + moreinfo
quit
T
T
tiregram arthur wrote on 19 Oct 2020 18:04
Re: [bug#44019] add dbus-cxx
(name . Miguel Ángel Arruga Vivas)(address . rosen644835@gmail.com)(address . 44019@debbugs.gnu.org)
CAHBH9LChQyWrAD+hL7dBvNrVVDyWYDORT1EGgrBMEXz1b+G1ug@mail.gmail.com
Hi, thanks for the answer

As you can, read in the cpp binding section they are many dbus binding.
And they are différents code base.

I will move the définition to glib.scm.




Le lun. 19 oct. 2020 à 16:33, Miguel Ángel Arruga Vivas <
rosen644835@gmail.com> a écrit :

Toggle quote (91 lines)
> Hi Arthur,
>
> Thank you very much for your patch. Nonetheless, there is already a
> package named dbus-c++ and that can be found in gnu/packages/glib.scm
> and the description fits almost exactly this one, but it's being used
> currently only by libring (Jami). Even if they are different projects
> (dbus-c++ and dbus-cxx), they should belong together in the source code
> (gnu/packages/glib.scm).
>
> Could you confirm that they are different code bases, and also move that
> definition there for the patch if that's the case?
>
> Happy hacking!
> Miguel
>
> tiregram arthur <ruhtra.mar@gmail.com> writes:
>
> >>From c3804aca21c496e66e44ba48fd150501154dfb6d Mon Sep 17 00:00:00 2001
> > From: ruhtra <ruhtra.mar@gmail.com>
> > Date: Thu, 15 Oct 2020 18:58:46 +0200
> > Subject: [PATCH] to add dbus-cxx package add gnu/packages/dbus-cxx.scm
> >
> > ---
> > gnu/packages/dbus-cxx.scm | 52 +++++++++++++++++++++++++++++++++++++++
> > 1 file changed, 52 insertions(+)
> > create mode 100644 gnu/packages/dbus-cxx.scm
> >
> > diff --git a/gnu/packages/dbus-cxx.scm b/gnu/packages/dbus-cxx.scm
> > new file mode 100644
> > index 0000000000..4ec08fb4ac
> > --- /dev/null
> > +++ b/gnu/packages/dbus-cxx.scm
> > @@ -0,0 +1,52 @@
> > +;;; Copyright © 2020 Arthur Margerit <ruhtra.mar@gmail.com>
> > +;;;
> > +;;; This file is part of GNU Guix.
> > +;;;
> > +;;; GNU Guix is free software; you can redistribute it and/or modify it
> > +;;; under the terms of the GNU General Public License as published by
> > +;;; the Free Software Foundation; either version 3 of the License, or
> (at
> > +;;; your option) any later version.
> > +;;;
> > +;;; GNU Guix is distributed in the hope that it will be useful, but
> > +;;; WITHOUT ANY WARRANTY; without even the implied warranty of
> > +;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
> > +;;; GNU General Public License for more details.
> > +;;;
> > +;;; You should have received a copy of the GNU General Public License
> > +;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
> > +
> > +(define-module (gnu packages dbus-cxx)
> > + #:use-module (guix packages)
> > + #:use-module (guix git-download)
> > + #:use-module (guix build-system cmake)
> > + #:use-module (guix licenses)
> > + #:use-module (gnu packages pkg-config)
> > + #:use-module (gnu packages m4)
> > + #:use-module ((gnu packages glib) #:select (dbus libsigc++)))
> > +
> > +(define-public dbus-cxx
> > + (package
> > + (name "dbus-cxx")
> > + (version "0.12.0")
> > + (source (origin
> > + (file-name (git-file-name name version))
> > + (method git-fetch)
> > + (uri (git-reference
> > + (url "https://github.com/dbus-cxx/dbus-cxx")
> > + (commit
> "ea7f8e361d11dc7d41d9ae2c4128aed2cdadd84e")))
> > + (sha256
> > + (base32
> > +
> "1sa448icfvl08rnik0lnk4scmkwhfyd3mrxh36jh8x7xndp90khp"))))
> > + (build-system cmake-build-system)
> > + (arguments
> > + `(#:tests? #f))
> > + (inputs `(("dbus-glib", dbus) ("libsigc++", libsigc++)))
> > + (native-inputs `(("pkg-config", pkg-config) ("m4", m4)))
> > + (synopsis "C++ wrapper for dbus")
> > + (description "Dbus-cxx is a C++ wrapper for dbus.
> > +It exposes the C API to allow direct manipulation and
> > +relies on sigc++ to provide an OO interface.
> > +Also included is dbus-cxx-xml2cpp to generate proxy and adapter
> > + interfaces from DBus XML introspection-like documents.")
> > + (home-page "https://dbus-cxx.github.io/")
> > + (license gpl3)))
> > --
> > 2.28.0
>
Attachment: file
M
M
Miguel Ángel Arruga Vivas wrote on 19 Oct 2020 19:24
(name . tiregram arthur)(address . ruhtra.mar@gmail.com)(address . 44019@debbugs.gnu.org)
87sgaam8mx.fsf@gmail.com
Hi,

tiregram arthur <ruhtra.mar@gmail.com> writes:
Toggle quote (4 lines)
> As you can, read in the cpp binding section they are many dbus binding.
> And they are différents code base.

Thank you very much for the info, I didn't look there.

Toggle quote (2 lines)
> I will move the définition to glib.scm.

And thank you very much for your effort. :-)

Happy hacking!
Miguel
M
M
Miguel Ángel Arruga Vivas wrote on 19 Oct 2020 19:30
control message for bug #44019
(address . control@debbugs.gnu.org)
87o8kym8cj.fsf@gmail.com
tags 44019 - moreinfo
quit
M
M
Miguel Ángel Arruga Vivas wrote on 22 Oct 2020 18:26
Re: [bug#44019] add dbus-cxx
(name . tiregram arthur)(address . ruhtra.mar@gmail.com)(address . 44019@debbugs.gnu.org)
873626jkgc.fsf@gmail.com
Hi,

The list was lost at some point in this email, I add it again.

I've checked the code of the library and I'm almost sure it's a fork of
the (unmantained) dbus-c++ project, but I'm not sure about changing the
dependency for jami and its compatibility, so I think it's worth keeping
it as a separate package, at least for now.

Reading and testing your patch I've found several issues about it, all
of them have an easy solution. :-)

tiregram arthur <ruhtra.mar@gmail.com> writes:
Toggle quote (5 lines)
> From 8664346cc76e728806c1a797fc59b47d66b603ef Mon Sep 17 00:00:00 2001
> From: ruhtra <ruhtra.mar@gmail.com>
> Date: Tue, 20 Oct 2020 18:52:37 +0200
> Subject: [PATCH] add dbus-cxx package

The commit message title should be with "gnu: Add dbus-cxx."

Also, changelog information is required in the body of the commit, e.g.:

* gnu/packages/glib.scm (dbux-cxx): New package.

Toggle quote (27 lines)
> ---
> gnu/packages/glib.scm | 32 ++++++++++++++++++++++++++++++++
> 1 file changed, 32 insertions(+)
>
> diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
> index cde95b13eb..c79060cf8b 100644
> --- a/gnu/packages/glib.scm
> +++ b/gnu/packages/glib.scm
> @@ -13,6 +13,7 @@
> ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
> ;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
> ;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
> +;;; Copyright © 2020 Arthur Margerit <ruhtra.mar@gmail.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -61,10 +62,12 @@
> #:use-module (gnu packages xml)
> #:use-module (gnu packages xorg)
> #:use-module (guix build-system gnu)
> + #:use-module (guix build-system cmake)
> #:use-module (guix build-system meson)
> #:use-module (guix build-system perl)
> #:use-module (guix build-system python)
> #:use-module (guix download)
> + #:use-module (guix git-download)

This shouldn't be needed, there is a tarball for the release on the
sourceforge page.

Toggle quote (9 lines)
> #:use-module ((guix licenses) #:prefix license:)
> #:use-module (guix packages)
> #:use-module (guix utils)
> @@ -932,6 +935,35 @@ programming language. It also contains the utility
> (home-page "https://sourceforge.net/projects/dbus-cplusplus/")
> (license license:lgpl2.1+)))
>
> +

That extra line break should be removed.

Toggle quote (11 lines)
> +(define-public dbus-cxx
> + (package
> + (name "dbus-cxx")
> + (version "0.12.0")
> + (source (origin
> + (file-name (git-file-name name version))
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/dbus-cxx/dbus-cxx")
> + (commit "ea7f8e361d11dc7d41d9ae2c4128aed2cdadd84e")))

Here it should point to the tarball from sourceforge (like the one for
dbus-c++):
"mirror://sourceforge/dbus-cxx/dbus-cxx/0.12.0/dbus-cxx-0.12.0.tar.gz"

Toggle quote (4 lines)
> + (sha256
> + (base32
> + "1sa448icfvl08rnik0lnk4scmkwhfyd3mrxh36jh8x7xndp90khp"))))

The sha256 for the tarball would be
"1acsgpkd9v7b9jdc79ijmh9dbdfrzgkwkaff518i3zpk7y6g5mzw".


Toggle quote (4 lines)
> + (build-system cmake-build-system)
> + (arguments
> + `(#:tests? #f))

We should run tests as much as possible as the software is going to be
distributed. For that, -DENABLE_TESTS=ON must be provided through
#:build-arguments, and #:tests? #f removed.

Also, the description doesn't match the options default options,
-DENABLE_TOOLS=ON has to be provided to generate dbus-cxx-xml2cpp and
dbus-cxx-introspection.

There is a third option that could be interesting, -DENABLE_GLIBMM=ON,
but I'm not sure what it really does, apart from generating extra
headers and libs.

Toggle quote (2 lines)
> + (inputs `(("dbus-glib", dbus) ("libsigc++", libsigc++)))

The comma (,) there is reader syntax, so it applies to the right side,
not the left one: ,libsigc++ expands to the contents of the variable
libsigc++ inside the quasiquote (`). Also, they should be one on each
line, and I would change dbus-glib for dbus too. To build the tools you
need expat, already available, and popt from (gnu packages popt), like
this code:

(inputs `(("dbus" ,dbus)
("expat" ,expat)
("libsigc++" ,libsigc++)
("popt" ,popt)))

If the glibmm option worths it, it has to be added to that list too.

Toggle quote (2 lines)
> + (native-inputs `(("pkg-config", pkg-config) ("m4", m4)))

Same indentation problems, one line per dependency, comma with the
variable, not on the left.

Toggle quote (7 lines)
> + (synopsis "C++ wrapper for dbus")
> + (description "Dbus-cxx is a C++ wrapper for dbus.
> +It exposes the C API to allow direct manipulation and
> +relies on sigc++ to provide an OO interface.
> +Also included is dbus-cxx-xml2cpp to generate proxy and adapter
> + interfaces from DBus XML introspection-like documents.")

This has been directly copied from the web page. If you don't have any
idea on what to write, the dbus-c++ package description has better
formatting at least. :-)

Toggle quote (5 lines)
> + (license license:gpl3)))
> +
> +

There's an extra line here too.

The main two issues are the compilation options and the description.
Would you mind to send a new version of the patch with these fixes?

Happy hacking!
Miguel
M
M
Miguel Ángel Arruga Vivas wrote on 23 Oct 2020 16:28
(name . tiregram arthur)(address . ruhtra.mar@gmail.com)(address . 44019@debbugs.gnu.org)
87sga5hv8v.fsf@gmail.com
Hi,

tiregram arthur <ruhtra.mar@gmail.com> writes:
Toggle quote (9 lines)
>> update.
>> i remove newline.
>> i move to tar
>> i add compilation option for test, tools and glibmm
>> i modified description
>> i indent the code as expected.
>>
>> you can find the new version atach to this email.

Thank you very much, this version looks superb! :-)

Toggle quote (3 lines)
> I just get the warning about softwareheritage.
> Who is in charge of this part?

I still need an answer for this. As soon as I have it, I hope sooner
than later, I'll push this with the right origin, as you provided both
versions already.

Thank you again,
Miguel

---
From e3dcfc10dcd9fff1486b282b3d77309411c44ac9 Mon Sep 17 00:00:00 2001
From: ruhtra <ruhtra.mar@gmail.com>
Date: Fri, 23 Oct 2020 14:40:20 +0200
Subject: [PATCH] gnu: Add dbus-cxx.

---
gnu/packages/glib.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (76 lines)
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index cde95b13eb..898b44a9e4 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2020 Arthur Margerit <ruhtra.mar@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -53,6 +54,7 @@
#:use-module (gnu packages package-management)
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
+ #:use-module (gnu packages popt)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
@@ -61,6 +63,7 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system meson)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
@@ -932,6 +935,45 @@ programming language. It also contains the utility
(home-page "https://sourceforge.net/projects/dbus-cplusplus/")
(license license:lgpl2.1+)))
+(define-public dbus-cxx
+ (package
+ (name "dbus-cxx")
+ (version "0.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/dbus-cxx/dbus-cxx/"
+ version "/dbus-cxx-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1acsgpkd9v7b9jdc79ijmh9dbdfrzgkwkaff518i3zpk7y6g5mzw"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags '("-DENABLE_TESTS=ON"
+ "-DENABLE_TOOLS=ON"
+ "-DENABLE_GLIBMM=ON")))
+ (inputs `(("dbus-glib" ,dbus)
+ ("libsigc++" ,libsigc++)
+ ("glibmm" ,glibmm)
+ ("python" ,python)
+ ("popt" ,popt)
+ ("expat" ,expat)))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("m4" ,m4)))
+ (synopsis "C++ wrapper for dbus")
+ (description "Dbus-cxx is a C++ wrapper for dbus.\n
+It exposes the C API to allow direct manipulation and
+relies on sigc++ to provide an Oriented Object interface.\n
+This package provide 2 utils:
+@enumerate
+@item @command{dbus-cxx-xml2cpp} to generate proxy and adapter
+@item @command{dbus-cxx-introspect} to introspect a dbus interface
+@end enumerate
+
+Some codes examples can be find at:
+@url{https://dbus-cxx.github.io/examples.html}")
+ (home-page "https://dbus-cxx.github.io/")
+ (license license:gpl3)))
+
(define-public appstream-glib
(package
(name "appstream-glib")
--
2.28.0
M
M
Miguel Ángel Arruga Vivas wrote on 24 Oct 2020 03:02
(name . tiregram arthur)(address . ruhtra.mar@gmail.com)(address . 44019-done@debbugs.gnu.org)
87blgsighh.fsf@gmail.com
Hi again,

Miguel Ángel Arruga Vivas <rosen644835@gmail.com> writes:
Toggle quote (4 lines)
> I still need an answer for this. As soon as I have it, I hope sooner
> than later, I'll push this with the right origin, as you provided both
> versions already.

I've been checking this thread[1] and I've decided to keep url-fetch for
consistency inside the same file.

It has been pushed to master[2] with the indentation proposed by
etc/indent-code.el and a minor change there:

Toggle quote (2 lines)
> + (inputs `(("dbus-glib" ,dbus)

I changed the name of the input from "dbus-glib" (that it's a different
library in the same file) to "dbus".

Again, thank you very much for your contribution. :-)

Happy hacking!
Miguel

-----BEGIN PGP SIGNATURE-----

iQGzBAEBCgAdFiEEiIeExBRZrMuD5+hMY0xuiXn6vsIFAl+TfQsACgkQY0xuiXn6
vsL4FwwAiQx57u+ukRa24fniwyKvEsdNFjsPnKTVmK9KwQzB0qX8bJ8G2/Ley3i/
IaCm2XAYvycHFEUpILmxrKt6+z9sigiEvgjFuNbDylANgjpFWzMFPV+IQw1EhetG
KmtV1yOXQER8jIInFsyilvQs7BR4l/JvdBPRY349wujYwO63eoC6uViFnY3417I2
QoQbzcFuRVT6M5zYNQlX6qmaG8xIknyPFMbFJg5t5NGAln4wyDfUvY71cyDpAWOx
72to778EWrVqLHwk9i7+2IEuEVFKxyiQmoTJNdWxqEUp75Y8XYY4Uu1unxg9ncgj
NGhbXm0i1M8CmHS0bj1+Q++J+Ijz5f7yEHgtlPDsSiW8ztGdI+mRmZpSl6Ze7S4s
axUkosvTrbGjziMOTUpDpy9fxjeam3tbXqO9o8NznurWfsGdZCEWe8WMkXuxNpOS
PLZkoBtg2mUc9YbjOh+3vKs8szgcS3ddW3dhxaulbG0AtiMZ9Gmz2MwtBKYeITl7
C3F/QoRJ
=JqEq
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44019@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44019
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch