[PATCH] gnu: Add tsukundere.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Christopher Baines
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 4 years ago
(address . guix-patches@gnu.org)
20201015102040.12598-1-leo.prikler@student.tugraz.at
* gnu/packages/game-development.scm (tsukundere): New variable.
---
gnu/packages/game-development.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 061dc13f69..0f2734e3c4 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2476,3 +2476,31 @@ fully dynamic omnidirectional shadows, global illumination, HDR lighting,
deferred shading, morphological / temporal / multisample anti-aliasing, and
much more.")
(license license:zlib))))
+
+(define-public tsukundere
+ (package
+ (name "tsukundere")
+ (version "0.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/leoprikler/tsukundere")
+ (commit version)))
+ (sha256
+ (base32
+ "0qmqch8hh7vsa8qaz853vwbkz0krb106955dnz8dsl7skbm5jpn6"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf-wrapper)
+ ("automake" ,automake)
+ ("guile" ,guile-3.0)
+ ("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("guile-sdl2" ,guile3.0-sdl2)))
+ (home-page "https://gitlab.com/leoprikler/tsukundere")
+ (synopsis "Visual novel engine")
+ (description "Tsukundere is a game engine geared heavily towards the
+development of visual novels, written on top of Guile-SDL2. It is still
+experimental and at the time of writing contains little more than the Guile
+modules, that make up its runtime.")
+ (license license:lgpl3+)))
--
2.28.0
Christopher Baines wrote 4 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 44008-done@debbugs.gnu.org)
87imbbi7rp.fsf@cbaines.net
Leo Prikler <leo.prikler@student.tugraz.at> writes:

Toggle quote (42 lines)
> * gnu/packages/game-development.scm (tsukundere): New variable.
> ---
> gnu/packages/game-development.scm | 28 ++++++++++++++++++++++++++++
> 1 file changed, 28 insertions(+)
>
> diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
> index 061dc13f69..0f2734e3c4 100644
> --- a/gnu/packages/game-development.scm
> +++ b/gnu/packages/game-development.scm
> @@ -2476,3 +2476,31 @@ fully dynamic omnidirectional shadows, global illumination, HDR lighting,
> deferred shading, morphological / temporal / multisample anti-aliasing, and
> much more.")
> (license license:zlib))))
> +
> +(define-public tsukundere
> + (package
> + (name "tsukundere")
> + (version "0.2.0")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://gitlab.com/leoprikler/tsukundere")
> + (commit version)))
> + (sha256
> + (base32
> + "0qmqch8hh7vsa8qaz853vwbkz0krb106955dnz8dsl7skbm5jpn6"))))
> + (build-system gnu-build-system)
> + (native-inputs
> + `(("autoconf" ,autoconf-wrapper)
> + ("automake" ,automake)
> + ("guile" ,guile-3.0)
> + ("pkg-config" ,pkg-config)))
> + (propagated-inputs
> + `(("guile-sdl2" ,guile3.0-sdl2)))
> + (home-page "https://gitlab.com/leoprikler/tsukundere")
> + (synopsis "Visual novel engine")
> + (description "Tsukundere is a game engine geared heavily towards the
> +development of visual novels, written on top of Guile-SDL2. It is still
> +experimental and at the time of writing contains little more than the Guile
> +modules, that make up its runtime.")
> + (license license:lgpl3+)))

Thanks, I made a couple of changes detailed below, but pushed the
tweaked patch to master as 3e072a59be55107bdcde4d1eabe2c857a254ebcc.

Guix lint said "the source file name should contain the package name",
this is because the source file is a Git repository, and the default
name for those doesn't contain the package name:

→ ./pre-inst-env guix build -S tsukundere
/gnu/store/65xkcflmr0lwk1jzgrac1n28s9as65xn-git-checkout

It's useful to not have lots of ...-git-checkout directories in the
store, as it makes it harder to know what they are. This can be avoided
by adding a (file-name (git-file-name name version)) bit in to the
origin record.

Also, adding new packages to the bottom of modules can be problematic,
if others do similarly, because it makes applying the patches
awkward. For that reason, if you don't especially want the package to go
at the bottom of the module, slot it in somewhere else. I moved the
tsukundere package up to beneath the tiled package, as that's somewhat
alphabetically ordered.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl+IqSpfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfIjA/+JBAJmImeskBItMIuTW8VoBKEC03o9qw9
wT/wmCmsMsm/0KkI0Oz0ebypaoJX0keTQ+CqpvHXjWnrkxajshdYHntT6lgkOt8j
jU4LVNPNLKDmUA/LuSou/dXc+UmQqEOFcTEuiInmLuR+Uow7A9nyd598LtLkQEYU
/VFHf03JXu7Bbv9zqAHyAGuTYS+cmavX3A9sMy7xnaoeR7GVMo5EzFM1Sr21L/T1
T8WRS1i6lLhU4CPecTdMXDjENfp3LPrfi8+g+n4DndJQ1CyCxsYUgyx6zIXks6Da
b7exhfnvmgUOx5azkHowfVGPnGacPCWOrV+/3oaX9/V/FUSPuoYFoFwzb+phtYJy
8UKQGb2jBgO6JxQnAS9rb9O0/BttMTs1RLTnSHvv4ZJVi6KYj+1xpoG1cnMCOI2y
b+r7f6TgbS5Rxc80rewf2+VEZ29Wo9oo3IMyrfaWLP/Sc8y0kRsT6bndPIN5+al4
PE6nUSBOluAkayaqMkb1IlHqNdMQfoNJLLe3arlkuTe9EUpwG3pb7uFD+uN54YWy
VZulI9mOqAm9REd2tLAIkswSQ3P0YuSK2WH4lBh2Q4+YgOQiQgG5CDSASHUpQLWk
FqHq/hFkZ5rVZBqP9v8CXsJw3dPIrPsIWl7b8V3oOYRnn0IVDg0VPFLNfUz0bF7m
Muyg1LwMVZ4=
=Euww
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44008@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44008
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help