[PATCH] gnu: Add r-calculus.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Magali Lemes
  • zimoun
Owner
unassigned
Submitted by
Magali Lemes
Severity
normal
M
M
Magali Lemes wrote on 14 Oct 2020 21:06
(address . guix-patches@gnu.org)(name . Magali Lemes)(address . magalilemes00@gmail.com)
20201014190609.80701-1-magalilemes00@gmail.com
---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 59a409f8e9..8a4f0085f6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24596,3 +24596,30 @@ enrichment analysis (GSEA) calculation with or without the absolute filtering.
Without filtering, users can perform (original) two-tailed or one-tailed
absolute GSEA.")
(license license:gpl2)))
+
+(define-public r-calculus
+ (package
+ (name "r-calculus")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "calculus" version))
+ (sha256
+ (base32
+ "0hs7hzjl6xjza20v9zx9a1piywxa6w3h2rskr52d1dcbc0vwhinp"))))
+ (properties `((upstream-name . "calculus")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-rcpp" ,r-rcpp)))
+ (home-page "https://github.com/emanuele-guidotti/calculus")
+ (synopsis "High Dimensional Numerical and Symbolic Calculus")
+ (description
+ "Efficient C++ optimized functions for numerical and symbolic calculus.
+It includes basic symbolic arithmetic, tensor calculus, Einstein summing
+convention, fast computation of the Levi-Civita symbol and generalized
+Kronecker delta, Taylor series expansion, multivariate Hermite polynomials,
+accurate high-order derivatives, differential operators (Gradient, Jacobian,
+Hessian, Divergence, Curl, Laplacian) and numerical integration in arbitrary
+orthogonal coordinate systems: cartesian, polar, spherical, cylindrical,
+parabolic or user defined by custom scale factors.")
+ (license license:gpl3)))
\ No newline at end of file
--
2.25.1
Z
Z
zimoun wrote on 15 Oct 2020 13:09
(name . Magali Lemes)(address . magalilemes00@gmail.com)(address . 43994@debbugs.gnu.org)
86sgaf21bh.fsf@gmail.com
Hi,

Thank you for your contribution. It is fine. For the sake of the
learning process, I suggest some minor tweaks and then you can send a v2
patch. Does it make sense?



In the commit message, it is missing:

* gnu/packages/cran.scm (r-calculus): New variable.


Toggle quote (24 lines)
> ---
> gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
> 1 file changed, 27 insertions(+)
>
> diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
> index 59a409f8e9..8a4f0085f6 100644
> --- a/gnu/packages/cran.scm
> +++ b/gnu/packages/cran.scm
> @@ -24596,3 +24596,30 @@ enrichment analysis (GSEA) calculation with or without the absolute filtering.
> Without filtering, users can perform (original) two-tailed or one-tailed
> absolute GSEA.")
> (license license:gpl2)))
> +
> +(define-public r-calculus
> + (package
> + (name "r-calculus")
> + (version "0.2.1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (cran-uri "calculus" version))
> + (sha256
> + (base32

Here, and issue of indentation.

(uri (cran-uri "calculus" version))
(sha256
(base32

Usually, with Emacs (with the correct setup “.dir-locals.el“), the
simplest is to go to the first opening parenthesis and press ‘C-M-q’.


Toggle quote (5 lines)
> + "0hs7hzjl6xjza20v9zx9a1piywxa6w3h2rskr52d1dcbc0vwhinp"))))
> + (properties `((upstream-name . "calculus")))
> + (build-system r-build-system)
> + (propagated-inputs `(("r-rcpp" ,r-rcpp)))

Usually, it is preferred to list below:

(propagated-inputs
`(("r-rcpp" ,r-rcpp)))


Toggle quote (7 lines)
> + (synopsis "High Dimensional Numerical and Symbolic Calculus")
> + (description
> + "Efficient C++ optimized functions for numerical and symbolic calculus.
> +It includes basic symbolic arithmetic, tensor calculus, Einstein summing
> +convention, fast computation of the Levi-Civita symbol and generalized

End of line: extra whitespace

Toggle quote (5 lines)
> +Kronecker delta, Taylor series expansion, multivariate Hermite polynomials,
> +accurate high-order derivatives, differential operators (Gradient, Jacobian,
> +Hessian, Divergence, Curl, Laplacian) and numerical integration in arbitrary
> +orthogonal coordinate systems: cartesian, polar, spherical, cylindrical,

Idem


Again with Emacs, I personally have ’(whitespace-mode)’ with this
config and then it is really easy to spot out.

Toggle snippet (8 lines)
(with-eval-after-load 'whitespace
(setq whitespace-line-column nil
whitespace-style '(face trailing lines-tail
space-before-tab newline
indentation empty space-after-tab)))


Toggle quote (4 lines)
> +parabolic or user defined by custom scale factors.")
> + (license license:gpl3)))
> \ No newline at end of file

Add RET. I guess.



Well, now you should do an “interactive rebase” and resend. Using Emacs
(again!) and Magit , it looks like:

r i
edit C-c C-c
# do your tweaks
r r
W c C-m b master C-m v 2 c
! git send-email --to=43994@debbugs.gnu.org v2-0001-blabla.patch

Does it make sense?


All the best,
simon

PS:
You can use any tools you want. :-) Sorry for the Emacs’s
evangelism. ;-)
M
M
Magali Lemes wrote on 16 Oct 2020 20:51
[PATCH v2] gnu: Add r-calculus.
(address . 43994@debbugs.gnu.org)(name . Magali Lemes)(address . magalilemes00@gmail.com)
20201016185107.27947-1-magalilemes00@gmail.com
* gnu/packages/cran.scm (r-calculus): New variable.
---
gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 252699c691..ce5ae7f64a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Antoine Côté <antoine.cote@posteo.net>
;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2020 Magali Lemes <magalilemes00@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24598,3 +24599,32 @@ enrichment analysis (GSEA) calculation with or without the absolute filtering.
Without filtering, users can perform (original) two-tailed or one-tailed
absolute GSEA.")
(license license:gpl2)))
+
+(define-public r-calculus
+ (package
+ (name "r-calculus")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "calculus" version))
+ (sha256
+ (base32
+ "0hs7hzjl6xjza20v9zx9a1piywxa6w3h2rskr52d1dcbc0vwhinp"))))
+ (properties `((upstream-name . "calculus")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rcpp" ,r-rcpp)))
+ (home-page "https://github.com/emanuele-guidotti/calculus")
+ (synopsis "High Dimensional Numerical and Symbolic Calculus")
+ (description
+ "Efficient C++ optimized functions for numerical and symbolic calculus.
+It includes basic symbolic arithmetic, tensor calculus, Einstein summing
+convention, fast computation of the Levi-Civita symbol and generalized
+Kronecker delta, Taylor series expansion, multivariate Hermite polynomials,
+accurate high-order derivatives, differential operators (Gradient, Jacobian,
+Hessian, Divergence, Curl, Laplacian) and numerical integration in arbitrary
+orthogonal coordinate systems: cartesian, polar, spherical, cylindrical,
+parabolic or user defined by custom scale factors.")
+ (license license:gpl3)))
+
--
2.25.1
L
L
Ludovic Courtès wrote on 17 Oct 2020 22:39
(name . Magali Lemes)(address . magalilemes00@gmail.com)(address . 43994-done@debbugs.gnu.org)
87ft6c4mel.fsf@gnu.org
Hi Magali,

Magali Lemes <magalilemes00@gmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-calculus): New variable.

Applied with the minor changes below (the URL change was suggested by
‘guix lint r-calculus’.) Apart from that it’s all good.

Thanks!

Ludo’.
Toggle diff (15 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ce5ae7f64a..fea560f7a1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24615,8 +24615,8 @@ absolute GSEA.")
(build-system r-build-system)
(propagated-inputs
`(("r-rcpp" ,r-rcpp)))
- (home-page "https://github.com/emanuele-guidotti/calculus")
- (synopsis "High Dimensional Numerical and Symbolic Calculus")
+ (home-page "https://github.com/guidotti/calculus")
+ (synopsis "High dimensional numerical and symbolic calculus")
(description
"Efficient C++ optimized functions for numerical and symbolic calculus.
It includes basic symbolic arithmetic, tensor calculus, Einstein summing
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43994@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43994
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch