[PATCH] gnu: kodi: Add nfs functionality.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 4 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20201012160847.5935-1-mike@rohleder.de
* gnu/packages/kodi.scm (kodi): Add nfs functionality.
[inputs]: Add libnfs.
---
gnu/packages/kodi.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/kodi.scm b/gnu/packages/kodi.scm
index 2edf5c0614..6673916ebb 100644
--- a/gnu/packages/kodi.scm
+++ b/gnu/packages/kodi.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2017 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -42,6 +43,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages file-systems)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages fribidi)
@@ -375,7 +377,6 @@ alternatives. In compilers, this can reduce the cascade of secondary errors.")
(lambda _
(invoke "make" "kodi-test"))))))
;; TODO: Add dependencies for:
- ;; - nfs
;; - cec
;; - plist
;; - shairplay
@@ -424,6 +425,7 @@ alternatives. In compilers, this can reduce the cascade of secondary errors.")
("libmad" ,libmad)
("libmicrohttpd" ,libmicrohttpd)
("libmpeg2" ,libmpeg2)
+ ("libnfs" ,libnfs)
("libogg" ,libogg)
("libpng" ,libpng)
("libssh" ,libssh)
--
2.28.0
Ludovic Courtès wrote 4 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 43964-done@debbugs.gnu.org)
87tuulnkzc.fsf@gnu.org
Hi,

Michael Rohleder <mike@rohleder.de> skribis:

Toggle quote (3 lines)
> * gnu/packages/kodi.scm (kodi): Add nfs functionality.
> [inputs]: Add libnfs.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43964@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43964
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help