gnu: Add emacs-graphql-mode.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Soo
  • Nicolas Goaziou
Owner
unassigned
Submitted by
John Soo
Severity
normal

Debbugs page

John Soo wrote 4 years ago
(address . guix-patches@gnu.org)
87imbgofzz.fsf@asu.edu
Hi Guix,

I've been writing some graphql recently and graphql-mode has been
invaluable.

Thanks!

John
From b1203ce58608f70de97c9cf44f53eef026c60bf4 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Tue, 29 Sep 2020 09:58:05 -0700
Subject: [PATCH] gnu: Add emacs-graphql-mode.

* gnu/packages/emacs-xyz.scm (emacs-graphql-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fca4c22569..612248ad96 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -765,6 +765,31 @@ GraphQL is a data query language and runtime designed and used to request and
deliver data to mobile and web apps.")
(license license:gpl3+)))
+(define-public emacs-graphql-mode
+ (let ((commit "9bed568ec86242dbe30bdbab324aa0eb2cd9bf08")
+ (revision "1"))
+ (package
+ (name "emacs-graphql-mode")
+ (version commit)
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/davazp/graphql-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0x9y7qq6y0zg8ncamzvk68ccmdyzh7xsj0xs0ykyl20d5wdpplj4"))))
+ (build-system emacs-build-system)
+ (home-page
+ "https://github.com/davazp/graphql-mode")
+ (synopsis "Emacs mode to edit GraphQL schema and queries")
+ (description
+ "This package provides an Emacs mode for editing graphql queries and
+schemas.")
+ (license license:gpl3+))))
+
(define-public emacs-ghub
(package
(name "emacs-ghub")
--
2.28.0
Nicolas Goaziou wrote 4 years ago
(name . John Soo)(address . jsoo1@asu.edu)(address . 43930@debbugs.gnu.org)
87imbe61gn.fsf@nicolasgoaziou.fr
Hello,

John Soo <jsoo1@asu.edu> writes:

Toggle quote (3 lines)
> I've been writing some graphql recently and graphql-mode has been
> invaluable.

Thank you. Some comments follow.

Toggle quote (3 lines)
> +(define-public emacs-graphql-mode
> + (let ((commit "9bed568ec86242dbe30bdbab324aa0eb2cd9bf08")

Could you add a comment explaining why you don't use a tagged commit
(in this case, there is none)?

Toggle quote (15 lines)
> + (revision "1"))
> + (package
> + (name "emacs-graphql-mode")
> + (version commit)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/davazp/graphql-mode")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0x9y7qq6y0zg8ncamzvk68ccmdyzh7xsj0xs0ykyl20d5wdpplj4"))))

Nitpick: please move the string on the same line as `base32'.

Toggle quote (4 lines)
> + (build-system emacs-build-system)
> + (home-page
> + "https://github.com/davazp/graphql-mode")

Nitpick: please move the string on the same line as `home-page'.

Toggle quote (5 lines)
> + (synopsis "Emacs mode to edit GraphQL schema and queries")
> + (description
> + "This package provides an Emacs mode for editing graphql queries and
> +schemas.")

I suggest to expound the description a bit. For example, using
commentary section of the library, it could be something along the lines
of:

This package implements a major mode to edit GraphQL schemas and
query. The basic functionality includes syntax highlight and
indentation. Additionally, it is able to send GraphQL queries to an
end-point URL.

Files with the @file{.graphql} and @file{.gql} extensions are
automatically opened with this mode.


Could you send an updated patch?

Regards,
--
Nicolas Goaziou
John Soo wrote 4 years ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 43930@debbugs.gnu.org)
87r1pu2jr5.fsf@asu.edu
Hi Nicolas,

Thanks for the review.

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (3 lines)
> Could you add a comment explaining why you don't use a tagged commit
> (in this case, there is none)?

Done.

Toggle quote (17 lines)
>> + (revision "1"))
>> + (package
>> + (name "emacs-graphql-mode")
>> + (version commit)
>> + (source
>> + (origin
>> + (method git-fetch)
>> + (uri (git-reference
>> + (url "https://github.com/davazp/graphql-mode")
>> + (commit commit)))
>> + (file-name (git-file-name name version))
>> + (sha256
>> + (base32
>> + "0x9y7qq6y0zg8ncamzvk68ccmdyzh7xsj0xs0ykyl20d5wdpplj4"))))
>
> Nitpick: please move the string on the same line as `base32'.

Done.

Toggle quote (6 lines)
>> + (build-system emacs-build-system)
>> + (home-page
>> + "https://github.com/davazp/graphql-mode")
>
> Nitpick: please move the string on the same line as `home-page'.

Done.

Toggle quote (17 lines)
>> + (synopsis "Emacs mode to edit GraphQL schema and queries")
>> + (description
>> + "This package provides an Emacs mode for editing graphql queries and
>> +schemas.")
>
> I suggest to expound the description a bit. For example, using
> commentary section of the library, it could be something along the lines
> of:
>
> This package implements a major mode to edit GraphQL schemas and
> query. The basic functionality includes syntax highlight and
> indentation. Additionally, it is able to send GraphQL queries to an
> end-point URL.
>
> Files with the @file{.graphql} and @file{.gql} extensions are
> automatically opened with this mode.

Done. I missed the description in graphql-mode.el.

Thanks again,

John
From 5dcdcad8869f5c63ed6f86499aaa9e162196d076 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Tue, 29 Sep 2020 09:58:05 -0700
Subject: [PATCH] gnu: Add emacs-graphql-mode.

* gnu/packages/emacs-xyz.scm (emacs-graphql-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fca4c22569..2859028809 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -765,6 +765,40 @@ GraphQL is a data query language and runtime designed and used to request and
deliver data to mobile and web apps.")
(license license:gpl3+)))
+(define-public emacs-graphql-mode
+ ;; No tagged commit
+ (let ((commit "9bed568ec86242dbe30bdbab324aa0eb2cd9bf08")
+ (revision "1"))
+ (package
+ (name "emacs-graphql-mode")
+ (version commit)
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/davazp/graphql-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0x9y7qq6y0zg8ncamzvk68ccmdyzh7xsj0xs0ykyl20d5wdpplj4"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/davazp/graphql-mode")
+ (synopsis "Emacs mode to edit GraphQL schema and queries")
+ (description
+ "This package implements a major mode to edit GraphQL schemas and
+query. The basic functionality includes:
+@itemize
+@item Syntax highlight
+@item Automatic indentation
+Additionally, it is able to
+@end itemize
+@itemize
+@item Sending GraphQL queries to an end-point URL
+@end itemize
+Files with the @file{.graphql} and @file{.gql} extensions are automatically
+opened with this mode.")
+ (license license:gpl3+))))
+
(define-public emacs-ghub
(package
(name "emacs-ghub")
--
2.28.0
Nicolas Goaziou wrote 4 years ago
(name . John Soo)(address . jsoo1@asu.edu)(address . 43930-done@debbugs.gnu.org)
87lfg27xny.fsf@nicolasgoaziou.fr
Hello,

John Soo <jsoo1@asu.edu> writes:

Toggle quote (4 lines)
> Subject: [PATCH] gnu: Add emacs-graphql-mode.
>
> * gnu/packages/emacs-xyz.scm (emacs-graphql-mode): New variable.

Applied. Thank you.

I sticked to the description I suggested because I thinks lists are not
warranted in this case.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43930@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43930
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help