Morgan.J.Smith wrote 4 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
From: Morgan Smith <Morgan.J.Smith@outlook.com>
* gnu/packages/emacs-xyz.scm (emacs-modus-vivendi-theme): Update to 0.13.0.
[source]: Use git instead of elpa, as elpa is out of date
[arguments]: Add phase to remove modus-operandi-theme.el
---
gnu/packages/emacs-xyz.scm | 20 +++++++++++++++-----
1 file changed, 15 insertions(+), 5 deletions(-)
Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 44aaaa0541..f1ebdd90ff 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22685,15 +22685,25 @@ standard. This is the highest standard of its kind.")
(define-public emacs-modus-vivendi-theme
(package
(name "emacs-modus-vivendi-theme")
- (version "0.12.0")
+ (version "0.13.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://elpa.gnu.org/packages/"
- "modus-vivendi-theme-" version ".el"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/protesilaos/modus-themes")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "01f6z5xjnmki1k9m83jwva42lxidb31pdpwm4wpxjzxqmb96picn"))))
+ (base32
+ "0i6n3pzrmlgabsijy6z0hhs71q7g99yagwr2m33lr30skqc9rvdn"))))
(build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-other-theme
+ (lambda _
+ (delete-file "modus-operandi-theme.el")
+ #t)))))
(home-page "https://gitlab.com/protesilaos/modus-themes")
(synopsis "Accessible dark theme (WCAG AAA)")
(description
--
2.28.0