cuirass: uncaught exception 'read-error' in 'metrics' fiber

  • Done
  • quality assurance status badge
Details
2 participants
  • Jonathan Brielmaier
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Jonathan Brielmaier
Severity
normal

Debbugs page

Jonathan Brielmaier wrote 4 years ago
(name . bug-guix)(address . bug-guix@gnu.org)
28e7af94-24fd-a1f9-8f73-ad682f75a61e@web.de
I'm running current cuirass (0.0.1-51.cb2c4e3) but if fails directly
after the start with the following error log:

```
2020-10-10T11:47:50 retrieving list of pending builds...
2020-10-10T11:47:50 heap: 11.93 MiB; threads: 19; file descriptors: 78
2020-10-10T11:47:50 canceling 0 stale builds
2020-10-10T11:47:50 restarting 0 pending builds
2020-10-10T11:47:50 building 0 derivations in batches of 200
2020-10-10T11:47:50 done with 0 derivations
2020-10-10T11:47:50 done with restarted builds
2020-10-10T11:47:50 fatal: uncaught exception 'read-error' in 'metrics'
fiber!
2020-10-10T11:47:50 exception arguments: ("scm_lreadr" "#<unknown
port>:1:94: end of file in string constant" () #f)
In ice-9/boot-9.scm:
1731:15 12 (with-exception-handler #<procedure 7f9ae7ffdab0 at ic?> ?)
1736:10 11 (with-exception-handler _ _ #:unwind? _ # _)
718:2 10 (call-with-prompt ("break") #<procedure 7f9aeb549ce0 a?> ?)
718:2 9 (call-with-prompt ("continue") #<procedure 7f9aeb54962?> ?)
In ice-9/eval.scm:
619:8 8 (_ #(#(#<directory (guile-user) 7f9aeb139f00> #<vari?>)))
In cuirass/logging.scm:
58:18 7 (call-with-time-logging "Metrics update" #<procedure 7f?>)
In cuirass/metrics.scm:
330:34 6 (db-update-metrics)
In ice-9/boot-9.scm:
1669:16 5 (raise-exception _ #:continuable? _)
1764:13 4 (_ #<&compound-exception components: (#<&lexical> #<&or?>)
In cuirass/utils.scm:
284:8 3 (_ _ . _)
In ice-9/boot-9.scm:
1731:15 2 (with-exception-handler #<procedure 7f9ae8a8d4e0 at ic?> ?)
In cuirass/utils.scm:
285:22 1 (_)
In unknown file:
0 (make-stack #t)
ERROR: In procedure make-stack:
In procedure scm_lreadr: #<unknown port>:1:94: end of file in string
constant
2020-10-10T11:47:50 fatal: uncaught exception 'read-error' in 'build' fiber!
2020-10-10T11:47:50 exception arguments: ("scm_lreadr" "#<unknown
port>:1:94: end of file in string constant" () #f)
In ice-9/boot-9.scm:
1731:15 12 (with-exception-handler #<procedure 7f9ae7f93c90 at ic?> ?)
1736:10 11 (with-exception-handler _ _ #:unwind? _ # _)
152:2 10 (with-fluid* _ _ _)
718:2 9 (call-with-prompt ("break") #<procedure 7f9aeb547e20 a?> ?)
718:2 8 (call-with-prompt ("continue") #<procedure 7f9aeb54768?> ?)
In ice-9/eval.scm:
619:8 7 (_ #(#(#<directory (guile-user) 7f9aeb139f00> #<var?> ?)))
155:9 6 (_ #(#(#<directory (guile-user) 7f9aeb139f00> #<var?> ?)))
In ice-9/boot-9.scm:
1669:16 5 (raise-exception _ #:continuable? _)
1764:13 4 (_ #<&compound-exception components: (#<&lexical> #<&or?>)
In cuirass/utils.scm:
284:8 3 (_ _ . _)
In ice-9/boot-9.scm:
1731:15 2 (with-exception-handler #<procedure 7f9ad4426420 at ic?> ?)
In cuirass/utils.scm:
285:22 1 (_)
In unknown file:
0 (make-stack #t)
ERROR: In procedure make-stack:
In procedure scm_lreadr: #<unknown port>:1:94: end of file in string
constant
```
Jonathan Brielmaier wrote 4 years ago
Re: bug#43905: Acknowledgement (cuirass: uncaught exception 'read-error' in 'metrics' fiber)
(address . 43905@debbugs.gnu.org)
9b85950c-d961-eba8-ad0f-5a213074436e@web.de
It happens when scamping around in the database:
update Specifications set proc_args='((subset "htop" "icedove") (systems
"x86_64-linux))';

So I guess it's not a real bug.
Mathieu Othacehe wrote 4 years ago
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 43905@debbugs.gnu.org)
87tuuzrj1k.fsf@gnu.org
Hello Jonathan,

Toggle quote (4 lines)
> It happens when scamping around in the database:
> update Specifications set proc_args='((subset "htop" "icedove") (systems
> "x86_64-linux))';

You mean it happens only when modifying 'proc_args' while Cuirass is
running? Could you share your specifications so that I can try to
reproduce it?

Thanks,

Mathieu
Jonathan Brielmaier wrote 4 years ago
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 43905@debbugs.gnu.org)
1216ca5e-f9ab-e9ce-0117-5c0228a791aa@web.de
On 12.10.20 09:37, Mathieu Othacehe wrote:
Toggle quote (11 lines)
>
> Hello Jonathan,
>
>> It happens when scamping around in the database:
>> update Specifications set proc_args='((subset "htop" "icedove") (systems
>> "x86_64-linux))';
>
> You mean it happens only when modifying 'proc_args' while Cuirass is
> running? Could you share your specifications so that I can try to
> reproduce it?

Sorry for the late answer

```
(define %cuirass-specs

#~(list

'((#:name . "foo-master")

(#:load-path-inputs . ())

(#:package-path-inputs . ("foo-packages"))

(#:proc-input . "guix")

(#:proc-file . "build-aux/cuirass/gnu-system.scm")

(#:proc . cuirass-jobs)

(#:proc-args . ((subset . ("htop" "icedove"))

(systems . ("x86_64-linux"))))

(#:inputs . (((#:name . "guix")


(#:load-path . ".")

(#:branch . "master")

(#:no-compile? . #t))

((#:name . "foo-packages")


(#:load-path . ".")

(#:branch . "master")

(#:no-compile? . #t))))

(#:build-outputs . ()))))


```
Mathieu Othacehe wrote 4 years ago
Re: bug#43905: cuirass: uncaught exception 'read-error' in 'metrics' fiber
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 43905-done@debbugs.gnu.org)
87eeg35re9.fsf@gnu.org
Hello,

Closing this one as the specification/evaluation model in Cuirass has
been rewritten.

Thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43905@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43905
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help