Jonathan Brielmaier wrote 4 years ago
(name . bug-guix)(address . bug-guix@gnu.org)
I'm running current cuirass (0.0.1-51.cb2c4e3) but if fails directly
after the start with the following error log:
```
2020-10-10T11:47:50 retrieving list of pending builds...
2020-10-10T11:47:50 heap: 11.93 MiB; threads: 19; file descriptors: 78
2020-10-10T11:47:50 canceling 0 stale builds
2020-10-10T11:47:50 restarting 0 pending builds
2020-10-10T11:47:50 building 0 derivations in batches of 200
2020-10-10T11:47:50 done with 0 derivations
2020-10-10T11:47:50 done with restarted builds
2020-10-10T11:47:50 fatal: uncaught exception 'read-error' in 'metrics'
fiber!
2020-10-10T11:47:50 exception arguments: ("scm_lreadr" "#<unknown
port>:1:94: end of file in string constant" () #f)
In ice-9/boot-9.scm:
1731:15 12 (with-exception-handler #<procedure 7f9ae7ffdab0 at ic?> ?)
1736:10 11 (with-exception-handler _ _ #:unwind? _ # _)
718:2 10 (call-with-prompt ("break") #<procedure 7f9aeb549ce0 a?> ?)
718:2 9 (call-with-prompt ("continue") #<procedure 7f9aeb54962?> ?)
In ice-9/eval.scm:
619:8 8 (_ #(#(#<directory (guile-user) 7f9aeb139f00> #<vari?>)))
In cuirass/logging.scm:
58:18 7 (call-with-time-logging "Metrics update" #<procedure 7f?>)
In cuirass/metrics.scm:
330:34 6 (db-update-metrics)
In ice-9/boot-9.scm:
1669:16 5 (raise-exception _ #:continuable? _)
1764:13 4 (_ #<&compound-exception components: (#<&lexical> #<&or?>)
In cuirass/utils.scm:
284:8 3 (_ _ . _)
In ice-9/boot-9.scm:
1731:15 2 (with-exception-handler #<procedure 7f9ae8a8d4e0 at ic?> ?)
In cuirass/utils.scm:
285:22 1 (_)
In unknown file:
0 (make-stack #t)
ERROR: In procedure make-stack:
In procedure scm_lreadr: #<unknown port>:1:94: end of file in string
constant
2020-10-10T11:47:50 fatal: uncaught exception 'read-error' in 'build' fiber!
2020-10-10T11:47:50 exception arguments: ("scm_lreadr" "#<unknown
port>:1:94: end of file in string constant" () #f)
In ice-9/boot-9.scm:
1731:15 12 (with-exception-handler #<procedure 7f9ae7f93c90 at ic?> ?)
1736:10 11 (with-exception-handler _ _ #:unwind? _ # _)
152:2 10 (with-fluid* _ _ _)
718:2 9 (call-with-prompt ("break") #<procedure 7f9aeb547e20 a?> ?)
718:2 8 (call-with-prompt ("continue") #<procedure 7f9aeb54768?> ?)
In ice-9/eval.scm:
619:8 7 (_ #(#(#<directory (guile-user) 7f9aeb139f00> #<var?> ?)))
155:9 6 (_ #(#(#<directory (guile-user) 7f9aeb139f00> #<var?> ?)))
In ice-9/boot-9.scm:
1669:16 5 (raise-exception _ #:continuable? _)
1764:13 4 (_ #<&compound-exception components: (#<&lexical> #<&or?>)
In cuirass/utils.scm:
284:8 3 (_ _ . _)
In ice-9/boot-9.scm:
1731:15 2 (with-exception-handler #<procedure 7f9ad4426420 at ic?> ?)
In cuirass/utils.scm:
285:22 1 (_)
In unknown file:
0 (make-stack #t)
ERROR: In procedure make-stack:
In procedure scm_lreadr: #<unknown port>:1:94: end of file in string
constant
```