[PATCH] gnu: Add bindfs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Marius Bakke
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 4 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR1001MB21057F09A2DC9C18FE1EA65AC5080@DM5PR1001MB2105.namprd10.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/file-systems.scm (bindfs): New variable.
---
gnu/packages/file-systems.scm | 39 +++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index c6486c67ef..9179272ec9 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
+;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -141,6 +142,44 @@ large and/or frequently changing (network) environment.")
(license (list license:bsd-3 ; modules/cyrus-sasl.c
license:gpl2+)))) ; the rest
+(define-public bindfs
+ (package
+ (name "bindfs")
+ (version "1.14.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://bindfs.org/downloads/bindfs-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "15y4brlcrqhxl6z73785m0dr1vp2q3wc6xss08x9jjr0apzmmjp5"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; XXX: The tests have no hope of passing until there is a "nogroup"
+ ;; entry (or at least some group to which the guix builder does
+ ;; not belong) in the /etc/group file of the build environment.
+ ;; Currently we do not have such a group. Disable tests for now.
+ '(#:tests? #f))
+ (native-inputs
+ ;; Native inputs to run the tests
+ ;; ("ruby" ,ruby)
+ ;; ("valgrind" ,valgrind)
+ ;; ("which" ,which)
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("fuse" ,fuse)))
+ (home-page "https://bindfs.org")
+ (synopsis "FUSE filesystem for mirroring a directory to another directory")
+ (description "bindfs can be used for:
+@itemize
+@item Making a directory read-only.
+@item Making all executables non-executable.
+@item Sharing a directory with a list of users (or groups).
+@item Modifying permission bits using rules with chmod-like syntax.
+@item Changing the permissions with which files are created.
+@end itemize ")
+ (license license:gpl2+)))
+
(define-public fsarchiver
(package
(name "fsarchiver")
--
2.28.0
Marius Bakke wrote 4 years ago
(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
87ft6hrfcs.fsf@gnu.org
Morgan.J.Smith@outlook.com writes:

Toggle quote (4 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/file-systems.scm (bindfs): New variable.

Applied with this minor tweak to the description, thanks!
Toggle diff (17 lines)
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 9179272ec9..6ceaad4fd1 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -169,8 +169,10 @@ large and/or frequently changing (network) environment.")
(inputs
`(("fuse" ,fuse)))
(home-page "https://bindfs.org")
- (synopsis "FUSE filesystem for mirroring a directory to another directory")
- (description "bindfs can be used for:
+ (synopsis "Bind mount a directory and alter permission bits")
+ (description
+ "@command{bindfs} is a FUSE filesystem for mounting a directory to
+another location, similar to @command{mount --bind}. It can be used for:
@itemize
@item Making a directory read-only.
@item Making all executables non-executable.
-----BEGIN PGP SIGNATURE-----

iQFDBAEBCgAtFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl+GGoMPHG1hcml1c0Bn
bnUub3JnAAoJEKKgbfKjOlT6x3AH/2/VvxYb1myqSdQ11Va3fu4ZBRJNOEj6jh1t
w/TuA9PlM07Srdgck2nczhF5cGl90xiBxRg2ODW5PfkKxVH5/i8wRPt/P0c6BGRC
7svGvw29XVPv49keCk0lBhD1dSVNFajtYWcWbk5IsKYbAZvxQLN8xstQcrzaZJex
WHe206DLVlqEd8FfM+poBk6BcweXC8gxohE8E0rrLgG4p/axCsQ6lrb5ub217NeX
3SIaDcj8Moz0VUCaPjOrn2hx82cRFg3pZSA7H9j18I5N98ITKN5bbpDRzf+0lRMd
fn7sRsvo8n7ByzAX1ohQc6Lzpg5r2Y5gUdKtJO7mdLLplBwoVoA=
=1dby
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43894@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43894
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help