[PATCH] gnu: Add libebur128.

  • Done
  • quality assurance status badge
Details
2 participants
  • Marius Bakke
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal

Debbugs page

Vinicius Monego wrote 4 years ago
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20201009151256.7949-1-monego@posteo.net
* gnu/packages/audio.scm (libebur128): New variable.
---
gnu/packages/audio.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 0e93a7263e..bd88987e13 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3060,6 +3060,33 @@ that toolkit will work in all hosts that use Suil automatically.
Suil currently supports every combination of Gtk, Qt, and X11.")
(license license:isc)))
+(define-public libebur128
+ (package
+ (name "libebur128")
+ (version "1.2.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jiixyj/libebur128")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0n81rnm8dm1zmibkr2v3q79rsd609y0dbbsrbay18njcjva88p0g"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(;; Tests require .wav files that are not distributed with the code.
+ ;; See https://github.com/jiixyj/libebur128/issues/82.
+ #:tests? #f
+ #:configure-flags '("-DCMAKE_BUILD_TYPE=Release"
+ "-DBUILD_STATIC_LIBS=OFF")))
+ (home-page "https://github.com/jiixyj/libebur128")
+ (synopsis "Library implementing the EBU R 128 loudness standard")
+ (description
+ "@code{libebur128} is a C library that implements the EBU R 128 standard
+for loudness normalisation.")
+ (license license:expat)))
+
(define-public timidity++
(package
(name "timidity++")
--
2.20.1
Marius Bakke wrote 4 years ago
(name . Vinicius Monego)(address . monego@posteo.net)
87imbdrfo7.fsf@gnu.org
Vinicius Monego <monego@posteo.net> writes:

Toggle quote (2 lines)
> * gnu/packages/audio.scm (libebur128): New variable.

[...]
Toggle quote (5 lines)
> + (arguments
> + `(;; Tests require .wav files that are not distributed with the code.
> + ;; See https://github.com/jiixyj/libebur128/issues/82.
> + #:tests? #f

It is easy to provide these data files using an (origin ...) in
native-inputs, like e.g. 'json-modern-cxx'. Obviously we should check
the terms of use first, as the data set is unrelated to this package.

(I don't really have a strong opinion here, just sayin')

Toggle quote (2 lines)
> + #:configure-flags '("-DCMAKE_BUILD_TYPE=Release"

Note: you can use #:build-type "Release" instead. The default is
"RelWithDebInfo", so it's customary to add a comment when changing it.
Is there a particular reason to not provide debugging information here?

Otherwise the patch LGTM.
-----BEGIN PGP SIGNATURE-----

iQFDBAEBCgAtFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl+GGOgPHG1hcml1c0Bn
bnUub3JnAAoJEKKgbfKjOlT6NrsH/RwUpkDiUk6TiwHL7Ed/pXJfVscTmVp/3CvU
HOGiHctftsyf9c/8pEAkMnQO7df4QudJ2v4P4s71JrOD9xytUP9sL+bRIAbBEqba
NADmW+cppqU2Iu5BkNzWvkExjuftZSjoeYg7EL4XIsVOM4otxwRzBrx47dyQ4F4N
tYy06kF5lI48gAnf/CaFNktJHjHw1Hv0NMyTM1KW5iarbjePI0GuPhbXkalUq0Jl
VX9jZTLqJZSH++ZIewww2a0CEQQ8nVCs4gWMf+MjvPd7Jgt3ZJhojDDI8V2XaU9y
9jDWNCarpBamoVjK6jEv8gvClHS9FU6Wb+/pVgpHtAm9bSn//tY=
=35UP
-----END PGP SIGNATURE-----

Vinicius Monego wrote 4 years ago
(name . Marius Bakke)(address . marius@gnu.org)(address . 43883@debbugs.gnu.org)
87imbb11s3.fsf@posteo.net
Marius Bakke writes:

Toggle quote (18 lines)
> Vinicius Monego <monego@posteo.net> writes:
>
>> * gnu/packages/audio.scm (libebur128): New variable.
>
> [...]
>
>> + (arguments
>> + `(;; Tests require .wav files that are not distributed with the code.
>> + ;; See https://github.com/jiixyj/libebur128/issues/82.
>> + #:tests? #f
>
> It is easy to provide these data files using an (origin ...) in
> native-inputs, like e.g. 'json-modern-cxx'. Obviously we should check
> the terms of use first, as the data set is unrelated to this package.
>
> (I don't really have a strong opinion here, just sayin')
>

I had a look at the terms (link provided in the issue referenced above)
and commercial usage is forbidden, making the audio files nonfree. Also, the
zip file weighs 87 MB.

Toggle quote (6 lines)
>> + #:configure-flags '("-DCMAKE_BUILD_TYPE=Release"
>
> Note: you can use #:build-type "Release" instead. The default is
> "RelWithDebInfo", so it's customary to add a comment when changing it.
> Is there a particular reason to not provide debugging information here?

Oh, I wasn't aware of #:build-type. Thanks.

I remove debugging information to save space. The ideal case is to move
it to a separate output as in


, but that is something I have yet to take a look at.

I will enable it again in the v2 and add a comment about the data.
Vinicius Monego wrote 4 years ago
[PATCH v2] gnu: Add libebur128.
(address . 43883@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20201016142143.46684-1-monego@posteo.net
* gnu/packages/audio.scm (libebur128): New variable.
---
Changed comment about why tests are disabled and build with debug information.

gnu/packages/audio.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 0e93a7263e..5bdbec40a2 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3060,6 +3060,32 @@ that toolkit will work in all hosts that use Suil automatically.
Suil currently supports every combination of Gtk, Qt, and X11.")
(license license:isc)))
+(define-public libebur128
+ (package
+ (name "libebur128")
+ (version "1.2.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jiixyj/libebur128")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0n81rnm8dm1zmibkr2v3q79rsd609y0dbbsrbay18njcjva88p0g"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(;; Tests require proprietary .wav files. See
+ ;; https://github.com/jiixyj/libebur128/issues/82.
+ #:tests? #f
+ #:configure-flags '("-DBUILD_STATIC_LIBS=OFF")))
+ (home-page "https://github.com/jiixyj/libebur128")
+ (synopsis "Library implementing the EBU R 128 loudness standard")
+ (description
+ "@code{libebur128} is a C library that implements the EBU R 128 standard
+for loudness normalisation.")
+ (license license:expat)))
+
(define-public timidity++
(package
(name "timidity++")
--
2.20.1
Marius Bakke wrote 4 years ago
Re: [bug#43883] [PATCH] gnu: Add libebur128.
(name . Vinicius Monego)(address . monego@posteo.net)(address . 43883-done@debbugs.gnu.org)
87wnznjiut.fsf@gnu.org
Vinicius Monego <monego@posteo.net> writes:

Toggle quote (24 lines)
> Marius Bakke writes:
>
>> Vinicius Monego <monego@posteo.net> writes:
>>
>>> * gnu/packages/audio.scm (libebur128): New variable.
>>
>> [...]
>>
>>> + (arguments
>>> + `(;; Tests require .wav files that are not distributed with the code.
>>> + ;; See https://github.com/jiixyj/libebur128/issues/82.
>>> + #:tests? #f
>>
>> It is easy to provide these data files using an (origin ...) in
>> native-inputs, like e.g. 'json-modern-cxx'. Obviously we should check
>> the terms of use first, as the data set is unrelated to this package.
>>
>> (I don't really have a strong opinion here, just sayin')
>>
>
> I had a look at the terms (link provided in the issue referenced above)
> and commercial usage is forbidden, making the audio files nonfree. Also, the
> zip file weighs 87 MB.

Oh, thanks for checking, too bad.

Toggle quote (17 lines)
>>> + #:configure-flags '("-DCMAKE_BUILD_TYPE=Release"
>>
>> Note: you can use #:build-type "Release" instead. The default is
>> "RelWithDebInfo", so it's customary to add a comment when changing it.
>> Is there a particular reason to not provide debugging information here?
>
> Oh, I wasn't aware of #:build-type. Thanks.
>
> I remove debugging information to save space. The ideal case is to move
> it to a separate output as in
>
> https://guix.gnu.org/manual/en/html_node/Installing-Debugging-Files.html
>
> , but that is something I have yet to take a look at.
>
> I will enable it again in the v2 and add a comment about the data.

Excellent, applied!
-----BEGIN PGP SIGNATURE-----

iQFDBAEBCgAtFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl+MusoPHG1hcml1c0Bn
bnUub3JnAAoJEKKgbfKjOlT65sgH/2ZKf2VYiif1LjicjLlaTELTDZojHS5CyOIS
1UNsj/6X94NcgqGiroF3N0SuVGNIRy7kfnar11YBZNu+T0qB9F7TdAXNURJ8G7Y4
SlCMxSOxpzTaZyT2iov8dYhdPZwkKtJCcsXFW0xO9kmeLXhwS89a6zUKxbefSihU
JKl4IWSlVl71dJJt7k+w8XuONv1QJPmdosRYPCSQcWrDhtVPz7xceNGonyfgp8am
5g7vyt15qDjkKfumCYTmE64HK110EbBfX8jwJ/OCYfeIBMZQSi137ZFv4l6jEBOF
JdL8OyzZD88TOXeUAD5oexVeqOLqWqEwZyHaNdn21GIdaEucD0o=
=naON
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43883@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43883
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help