Problem with graphical installer

  • Done
  • quality assurance status badge
Details
5 participants
  • Ludovic Courtès
  • Marinus Savoritias
  • Marinus Savoritias
  • Mathieu Othacehe
  • Miguel Ángel Arruga Vivas
Owner
unassigned
Submitted by
Marinus Savoritias
Severity
normal
M
M
Marinus Savoritias wrote on 9 Oct 2020 12:00
(address . bug-guix@gnu.org)
8b7e2678-d9b0-698b-7e91-2b6145b3de7f@disroot.org
If you follow the guided graphical install guix will fail to reconfigure
afterwards.

Everytime you will reconfigure it will say no space left on device. On
/boot.

the command to reconfigure i runed was: sudo guix system reconfigure
/etc/config.scm

Even if it is a new installation. I tried to format the disk seperately
and then install Guix but the same thing happen.

The only way to work around this bug if you use the graphical install,
is to choose manually partition the disk at the partition step of the
installer.

This bug was reproducible everytime in my machine with the latest iso
yesterday.

iso code: GUIX_i686-LINUX_024B273

Marinus Savoritias
M
M
Miguel Ángel Arruga Vivas wrote on 19 Oct 2020 16:41
(name . Marinus Savoritias)(address . marinus.savoritias@disroot.org)(address . 43879@debbugs.gnu.org)
87blgynuqr.fsf@gmail.com
Hi Marinius,

Marinus Savoritias <marinus.savoritias@disroot.org> writes:
Toggle quote (6 lines)
> If you follow the guided graphical install guix will fail to
> reconfigure afterwards.
>
> Everytime you will reconfigure it will say no space left on device. On
> /boot.

The default installation should not create a separate /boot partition,
only creates /boot/efi for EFI installations when it cannot be already
found.

Could you provide the partition map you had when the error happened? A
simple df -h would do the trick.

Also, could you confirm the bootloader you were using (grub,
grub-efi...)?

Best regards,
Miguel
M
M
Marinus Savoritias wrote on 19 Oct 2020 21:18
(name . Miguel Ángel Arruga Vivas)(address . rosen644835@gmail.com)(address . 43879@debbugs.gnu.org)
363c246d-90b2-1a8d-9b7b-6092e0836cc9@disroot.org
Hi,

The steps that I followed were:

1. Use guided installation using full disk with graphical installer

2. I selected use entire disk and not a separate /home

3. It gave me the warning that its going to format the disk.

At that point it formatted and I rebooted into the new system. There
were two partitions there.

One /boot/efi and one root (/). Every time I tried to reconfigure it
always ended with /boot not having enough space. At that point I went
into the /boot partition to check what are the files. I curiously found
that the files from the previous installation of Gentoo were there. Even
though the installer said that it formatted the disk.

I was using the default that the guided installation uses. I didn't
change anything there.

At that point as I said I formatted the disk separately to make sure it
was properly formatted this time but the same thing happened.

The only way I could work around the bug was by selecting the manual
partitioning instead of guided in the graphical installer.

Regards,

Marinus Savoritias

On 10/19/20 4:41 PM, Miguel Ángel Arruga Vivas wrote:
Toggle quote (20 lines)
> Hi Marinius,
>
> Marinus Savoritias <marinus.savoritias@disroot.org> writes:
>> If you follow the guided graphical install guix will fail to
>> reconfigure afterwards.
>>
>> Everytime you will reconfigure it will say no space left on device. On
>> /boot.
> The default installation should not create a separate /boot partition,
> only creates /boot/efi for EFI installations when it cannot be already
> found.
>
> Could you provide the partition map you had when the error happened? A
> simple df -h would do the trick.
>
> Also, could you confirm the bootloader you were using (grub,
> grub-efi...)?
>
> Best regards,
> Miguel
M
M
Miguel Ángel Arruga Vivas wrote on 31 Oct 2020 13:04
(name . Marinus Savoritias)(address . marinus.savoritias@disroot.org)
877dr64n5c.fsf@gmail.com
Hi,

I CC the list, as we are currently on freeze, but this might require a
fix or at least a big explanation somewhere, my bad for not answering
soon enough. :-(

Marinus Savoritias <marinus.savoritias@disroot.org> writes:
Toggle quote (10 lines)
> Hi,
>
> The steps that I followed were:
>
> 1. Use guided installation using full disk with graphical installer
>
> 2. I selected use entire disk and not a separate /home
>
> 3. It gave me the warning that its going to format the disk.

Testing this I think this warning may be the confusion source. "All
data will be lost" doesn't include in this case the old ESP partition
(the one in /boot/efi) as that one is not removed when it exists.

Toggle quote (4 lines)
> [...] I curiously found that the files from the previous installation
> of Gentoo were there. Even though the installer said that it formatted
> the disk.

To clarify this I propose the attached patch.

Toggle quote (3 lines)
> I was using the default that the guided installation uses. I didn't
> change anything there.

Probably it's too late to add new options to that list, or a new
selection step when the partitioning is guided asking if esp should be
kept, as the tests have to be updated too.

Toggle quote (6 lines)
> At that point as I said I formatted the disk separately to make sure
> it was properly formatted this time but the same thing happened.
>
> The only way I could work around the bug was by selecting the manual
> partitioning instead of guided in the graphical installer.

I'm throwing a guess here: did you format the root partition but not
/boot/efi the second time?

Happy hacking!
Miguel
From 2c7f127fbf51de89500a6310d6d1ed130587d111 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Miguel=20=C3=81ngel=20Arruga=20Vivas?=
<rosen644835@gmail.com>
Date: Sat, 31 Oct 2020 12:15:35 +0100
Subject: [PATCH] installer: Report to the user the formatted partitions.

* gnu/installer/newt/partitions.scm (define-module): Use (ice-9 format).
(draw-formatting-page): Add parameter partitions and provide the list of
formatted partitions to the user.
(run-partitioning-page): Provide user-partitions to draw-formatting-page.
---
gnu/installer/newt/partition.scm | 15 +++++++++++----
1 file changed, 11 insertions(+), 4 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/installer/newt/partition.scm b/gnu/installer/newt/partition.scm
index 3b891d693a..bb452a4925 100644
--- a/gnu/installer/newt/partition.scm
+++ b/gnu/installer/newt/partition.scm
@@ -25,6 +25,7 @@
#:use-module (gnu installer newt page)
#:use-module (gnu installer newt utils)
#:use-module (guix i18n)
+ #:use-module (ice-9 format)
#:use-module (ice-9 match)
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26)
@@ -56,11 +57,17 @@
#:button-callback-procedure button-exit-action)))
(car result)))
-(define (draw-formatting-page)
+(define (draw-formatting-page partitions)
"Draw a page asking for confirmation, and then indicating that partitions
are being formatted."
- (run-confirmation-page (G_ "We are about to format your hard disk. All \
-its data will be lost. Do you wish to continue?")
+ ;; TRANSLATORS: The ~{ and ~} format specifiers are used to iterate the list
+ ;; of device names of the user partitions that will be formatted.
+ (run-confirmation-page (format #f (G_ "We are about to write the configured \
+partition table to the disk and format the partitions listed below. All its \
+data will be lost. Do you wish to continue?~%~{ - ~a~%~}")
+ (map user-partition-file-name
+ (filter user-partition-need-formatting?
+ partitions)))
(G_ "Format disk?")
#:exit-button-procedure button-exit-action)
(draw-info-page
@@ -773,7 +780,7 @@ by pressing the Exit button.~%~%")))
(user-partitions (run-page non-install-devices))
(user-partitions-with-pass (prompt-luks-passwords
user-partitions))
- (form (draw-formatting-page)))
+ (form (draw-formatting-page user-partitions)))
;; Make sure the disks are not in use before proceeding to formatting.
(free-parted non-install-devices)
(format-user-partitions user-partitions-with-pass)
--
2.28.0
-----BEGIN PGP SIGNATURE-----

iQGzBAEBCgAdFiEEiIeExBRZrMuD5+hMY0xuiXn6vsIFAl+dUtAACgkQY0xuiXn6
vsJaFQwAjLHepJFDC5NNcGJn9cApFkol0lW44EAvQnEY10ySR9tffmIkGepp2vbM
FN7L+A5veyrgBu4GJ0xVxYcNXtRBU8WOlZtRLfnz/EpUXj+JTM3HoiIF1ffDQP+z
aH2z/AfC4GjkLkcguG2X3FfyK2FVeCDQUdAjM7v5bjQzbwy1lLt/KSNrzTSFwvlL
4nSMIc887jh+R2y28Ye8DdJAOWw6g2FUGKHFu0Aav9sRaB/FN4afoBJufrM4cO8a
vB738C0gBqyssTqRhpb6mImz4ztG4EU0QMwemhlT5R2JwO48meaJVf2zxQTRlrrz
fVPMTTHDD1IHA0IZlpi73P3mIkVIs3ZwsxTCtNOj1apgOYGrWVg2IVGXgN9IAkNS
vw45H85GHqxNAFmffgthnSQAwLkHv6h03voWOSt+j6h6gNMsLYqmhXJkD7Wg/DD7
fh0iQIJ0pPNavYAEzOqIoEBnG0l/DaPtKMRM6Fw1RPTh0JCbsUITWHDV4NEMzntU
jS+LKTOv
=fcri
-----END PGP SIGNATURE-----

M
M
Marinus Savoritias wrote on 31 Oct 2020 15:52
dfd4a930-dd76-1639-b9ef-eec9f2009701@oezhayl.dev
On 10/31/20 1:04 PM, Miguel Ángel Arruga Vivas wrote:
Toggle quote (27 lines)
> Hi,
>
> I CC the list, as we are currently on freeze, but this might require a
> fix or at least a big explanation somewhere, my bad for not answering
> soon enough. :-(
>
> Marinus Savoritias <marinus.savoritias@disroot.org> writes:
>> Hi,
>>
>> The steps that I followed were:
>>
>> 1. Use guided installation using full disk with graphical installer
>>
>> 2. I selected use entire disk and not a separate /home
>>
>> 3. It gave me the warning that its going to format the disk.
>
> Testing this I think this warning may be the confusion source. "All
> data will be lost" doesn't include in this case the old ESP partition
> (the one in /boot/efi) as that one is not removed when it exists.
>
>> [...] I curiously found that the files from the previous installation
>> of Gentoo were there. Even though the installer said that it formatted
>> the disk.
>
> To clarify this I propose the attached patch.

Agreed on this part. I think there should be a clarification.

Toggle quote (17 lines)
>
>> I was using the default that the guided installation uses. I didn't
>> change anything there.
>
> Probably it's too late to add new options to that list, or a new
> selection step when the partitioning is guided asking if esp should be
> kept, as the tests have to be updated too.
>
>> At that point as I said I formatted the disk separately to make sure
>> it was properly formatted this time but the same thing happened.
>>
>> The only way I could work around the bug was by selecting the manual
>> partitioning instead of guided in the graphical installer.
>
> I'm throwing a guess here: did you format the root partition but not
> /boot/efi the second time?

If you mean the workaround I found in the end no. I deleted both of the
partitions. I also deleted both partitions when I tried to do it
separately from the installation.

That is what makes this bug so interesting. Because even if you delete
both the partitions with parted. And then start the graphical guix
installation it doesn't solve anything.

The only way to solve it is to format both the partitions manually with
the installer.

Marinus

Toggle quote (4 lines)
>
> Happy hacking!
> Miguel
>
M
M
Mathieu Othacehe wrote on 1 Nov 2020 20:47
(name . Miguel Ángel Arruga Vivas)(address . rosen644835@gmail.com)
87imaoluzv.fsf@gnu.org
Hello Miguel,

Toggle quote (9 lines)
> + ;; TRANSLATORS: The ~{ and ~} format specifiers are used to iterate the list
> + ;; of device names of the user partitions that will be formatted.
> + (run-confirmation-page (format #f (G_ "We are about to write the configured \
> +partition table to the disk and format the partitions listed below. All its \
> +data will be lost. Do you wish to continue?~%~{ - ~a~%~}")
> + (map user-partition-file-name
> + (filter user-partition-need-formatting?
> + partitions)))

"All its data will be lost" refers to the hard drive. Maybe we should
say "Their data will be lost", referring to the partitions?

Otherwise, looks nice.

Thanks,

Mathieu
M
M
Miguel Ángel Arruga Vivas wrote on 2 Nov 2020 12:17
(name . Mathieu Othacehe)(address . othacehe@gnu.org)
877dr42eku.fsf@gmail.com
Hi Mathieu,

Mathieu Othacehe <othacehe@gnu.org> writes:
Toggle quote (3 lines)
> "All its data will be lost" refers to the hard drive. Maybe we should
> say "Their data will be lost", referring to the partitions?

Thanks for the review, I overlooked that.

Toggle quote (2 lines)
> Otherwise, looks nice.

Pushed as bc9e66f0feb25c77898222cfe5f3ef484dcee95e with the message
changed as suggested.

Happy hacking!
Miguel
-----BEGIN PGP SIGNATURE-----

iQGzBAEBCgAdFiEEiIeExBRZrMuD5+hMY0xuiXn6vsIFAl+f6rIACgkQY0xuiXn6
vsJb+gv/e4ANABOZN2+euqR1PNSxhD3vZem4p2HcGdZbDVaz18COOuFwHvqif+3F
on9I5tJsdY8+67PAwjPA8+W1wsU7bKUmYxqtF6U/svqZTpmqPKlj0z7fIhng8zdA
f0VqlDiGX1VEYhL2fg80fTTkvS96BLyU4nPAKBHtl+4ruYs8qYhefZMs2+SBOzdT
aDydJYUW1nym2zHSqcjvRC+raSsG64UPiiDHA/Yp7ibSwAeeP7eAZjIfq2GStUUM
+z4lZlJCX3MuBavj8QpjIG8TmnGbXwv4/qMqKMoFhMTIfx7vzwo0SdA/+0l91bxR
bjLeJIb9AdYidqYUGC05QTLB+B8slQSaU3hxR5i8Utr8zAn33Lug+Onozexht0A1
g+RF81isCkVeWAy9p8vZi0Ewa1bGMb12aCgWzClR0/ufyYYQwLbRJgoKoS4r8Iz7
CAexq9bYFLmzfOfG1x98eHJObHSHYmb7MxHcR3Lvbzu5TodTcZvQf2ACJ5s/Y3+r
BR/IuBAU
=KKoq
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 25 Apr 2021 22:09
control message for bug #43879
(address . control@debbugs.gnu.org)
87tunuf7no.fsf@gnu.org
tags 43879 fixed
close 43879
quit
?