Hello!
(+Cc: Luís Felipe, the web site designer.)
Julien Lepiller <julien@lepiller.eu> skribis:
Toggle quote (15 lines)
> From fe6910a5877ad039e2d6cf95efc10a62c0762871 Mon Sep 17 00:00:00 2001
> From: Julien Lepiller <julien@lepiller.eu>
> Date: Fri, 9 Oct 2020 00:32:56 +0200
> Subject: [PATCH] website: Add community page.
>
> * website/apps/media/templates/community.scm: New file.
> * website/apps/media/builder.scm: Add community builder.
> * website/apps/base/templates/components.scm: Add it to the menu.
> * website/apps/media/templates/components.scm: Add resource->shtml.
> * website/apps/media/types.scm: New resource data type.
> * website/apps/media/data.scm: Add community resources.
> * website/static/base/css/index.css: Add css for new classes.
> * website/static/media/css/community.css: New file.
> * website/static/media/img/community/carl-dong-bitcoin-security.webp: New file.
Nice! It was a bit sad that all this material wasn’t linked.
I wonder if “Community” is the right heading and/or if we should group
additional things in there?
Toggle quote (46 lines)
> +(define resources
> + (list
> + (resource
> + #:title (C_ "community resource title" "Everyday use of Guix")
> + #:link "https://media.marusich.info/everyday-use-of-gnu-guix-chris-marusich-seagl-2018.webm"
> + #:type 'video
> + #:language (G_ "English")
> + #:author "Chris Marushich"
> + #:date (string->date "2018-10-10" "~Y-~m-~d"))
> + (resource
> + #:title (C_ "community resource title" "Bitcoin Build System Security")
> + #:link "https://www.youtube.com/watch?v=I2iShmUTEl8"
> + #:type 'video
> + #:language (G_ "English")
> + #:preview (guix-url "static/media/img/community/carl-dong-bitcoin-security.webp")
> + #:author "Carl Dong"
> + #:date (string->date "2019-06-08" "~Y-~m-~d"))
> + (resource
> + #:title (C_ "community resource title" "Reproducible System Administration with GNU Guix")
> + #:link "https://replay.jres.org/videos/watch/c77b3a44-b75f-4c10-9f39-8fb55ae096d7"
> + #:type 'video
> + #:language (G_ "French")
> + #:author "Julien Lepiller"
> + #:date (string->date "2019-12-04" "~Y-~m-~d"))
> + (resource
> + #:title (C_ "community resource title" "Au-delà des conteneurs : environnements logiciels reproductibles avec GNU Guix")
> + #:link "https://webcast.in2p3.fr/video/au-dela-des-conteneurs-environnements-logiciels-reproductibles-avec-gnu-guix-1"
> + #:type 'video
> + #:language (G_ "French")
> + #:author "Ludovic Courtès"
> + #:date (string->date "2019-05-23" "~Y-~m-~d"))
> + (resource
> + #:title (C_ "community resource title" "Code Staging in GNU Guix")
> + #:link "https://arxiv.org/abs/1709.00833"
> + #:type 'article
> + #:language (G_ "English")
> + #:author "Ludovic Courtès"
> + #:date (string->date "2017-09-04" "~Y-~m-~d"))
> + (resource
> + #:title (C_ "community resource title" "Guix: A most advanced operating system")
> + #:link "https://ambrevar.xyz/guix-advance/index.html"
> + #:type 'blog
> + #:language (G_ "English")
> + #:author "Pierre Neidhardt"
> + #:date (string->date "2019-01-14" "~Y-~m-~d"))))
At least for the one that’s on YouTube, but perhaps also for the other
videos, we should host a copy at audio-video.gnu.org (I’ll check what it
takes to do that.)
We should also have a policy to not link to material that steers towards
non-free software (I believe the links above are fine).
Last but not least: we should encourage people to submit their things,
because I’m sure there’s much more we could add here! :-)
That’s all I have to say. Luís, everyone: thoughts?
Ludo’.