[PATCH website] Add community page

  • Done
  • quality assurance status badge
Details
5 participants
  • Brett Gilio
  • Julien Lepiller
  • Ludovic Courtès
  • Luis Felipe
  • zimoun
Owner
unassigned
Submitted by
Julien Lepiller
Severity
normal
J
J
Julien Lepiller wrote on 9 Oct 2020 00:38
(address . guix-patches@gnu.org)
20201009003823.0a15114b@tachikoma
Hi Guix!

This patch aims at adding a new page on the website that lists external
resources that talk about guix (conference talks, blog posts and even
academic papers).
Z
Z
zimoun wrote on 9 Oct 2020 01:16
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 43871@debbugs.gnu.org)
86lfgg8g1o.fsf@gmail.com
Dear,

On Fri, 09 Oct 2020 at 00:38, Julien Lepiller <julien@lepiller.eu> wrote:

Toggle quote (4 lines)
> This patch aims at adding a new page on the website that lists external
> resources that talk about guix (conference talks, blog posts and even
> academic papers).

Cool!


Toggle quote (5 lines)
> diff --git a/website/apps/media/data.scm b/website/apps/media/data.scm
> index 76af25d..89f7a8c 100644
> --- a/website/apps/media/data.scm
> +++ b/website/apps/media/data.scm

[...]

Toggle quote (6 lines)
> @@ -85,6 +87,53 @@ distribution."))
> #:last-updated (string->date "2020-03-28T16:00:00" "~Y-~m-~dT~H:~M:~S")))))
>
>
> +(define resources

Maybe chronological order? Last first:

Toggle quote (26 lines)
> + (list
> + (resource
> + #:title (C_ "community resource title" "Reproducible System Administration with GNU Guix")
> + #:date (string->date "2019-12-04" "~Y-~m-~d"))

> + (resource
> + #:title (C_ "community resource title" "Bitcoin Build System Security")
> + #:date (string->date "2019-06-08" "~Y-~m-~d"))

> + (resource
> + #:title (C_ "community resource title" "Au-delà des conteneurs : environnements logiciels reproductibles avec GNU Guix")
> + #:date (string->date "2019-05-23" "~Y-~m-~d"))

> + (resource
> + #:title (C_ "community resource title" "Guix: A most advanced operating system")
> + #:date (string->date "2019-01-14" "~Y-~m-~d"))))

> + (resource
> + #:title (C_ "community resource title" "Everyday use of Guix")
> + #:date (string->date "2018-10-10" "~Y-~m-~d"))

> + (resource
> + #:title (C_ "community resource title" "Code Staging in GNU Guix")
> + #:date (string->date "2017-09-04" "~Y-~m-~d"))


Does it make sense to add all the FOSDEM ones? For example:


etc. well what under talks/fosdem-*


All the best,
simon
L
L
Ludovic Courtès wrote on 12 Oct 2020 18:41
(name . Julien Lepiller)(address . julien@lepiller.eu)
87pn5no0rm.fsf@gnu.org
Hello!

(+Cc: Luís Felipe, the web site designer.)

Julien Lepiller <julien@lepiller.eu> skribis:

Toggle quote (15 lines)
> From fe6910a5877ad039e2d6cf95efc10a62c0762871 Mon Sep 17 00:00:00 2001
> From: Julien Lepiller <julien@lepiller.eu>
> Date: Fri, 9 Oct 2020 00:32:56 +0200
> Subject: [PATCH] website: Add community page.
>
> * website/apps/media/templates/community.scm: New file.
> * website/apps/media/builder.scm: Add community builder.
> * website/apps/base/templates/components.scm: Add it to the menu.
> * website/apps/media/templates/components.scm: Add resource->shtml.
> * website/apps/media/types.scm: New resource data type.
> * website/apps/media/data.scm: Add community resources.
> * website/static/base/css/index.css: Add css for new classes.
> * website/static/media/css/community.css: New file.
> * website/static/media/img/community/carl-dong-bitcoin-security.webp: New file.

Nice! It was a bit sad that all this material wasn’t linked.

I wonder if “Community” is the right heading and/or if we should group
additional things in there?

Toggle quote (46 lines)
> +(define resources
> + (list
> + (resource
> + #:title (C_ "community resource title" "Everyday use of Guix")
> + #:link "https://media.marusich.info/everyday-use-of-gnu-guix-chris-marusich-seagl-2018.webm"
> + #:type 'video
> + #:language (G_ "English")
> + #:author "Chris Marushich"
> + #:date (string->date "2018-10-10" "~Y-~m-~d"))
> + (resource
> + #:title (C_ "community resource title" "Bitcoin Build System Security")
> + #:link "https://www.youtube.com/watch?v=I2iShmUTEl8"
> + #:type 'video
> + #:language (G_ "English")
> + #:preview (guix-url "static/media/img/community/carl-dong-bitcoin-security.webp")
> + #:author "Carl Dong"
> + #:date (string->date "2019-06-08" "~Y-~m-~d"))
> + (resource
> + #:title (C_ "community resource title" "Reproducible System Administration with GNU Guix")
> + #:link "https://replay.jres.org/videos/watch/c77b3a44-b75f-4c10-9f39-8fb55ae096d7"
> + #:type 'video
> + #:language (G_ "French")
> + #:author "Julien Lepiller"
> + #:date (string->date "2019-12-04" "~Y-~m-~d"))
> + (resource
> + #:title (C_ "community resource title" "Au-delà des conteneurs : environnements logiciels reproductibles avec GNU Guix")
> + #:link "https://webcast.in2p3.fr/video/au-dela-des-conteneurs-environnements-logiciels-reproductibles-avec-gnu-guix-1"
> + #:type 'video
> + #:language (G_ "French")
> + #:author "Ludovic Courtès"
> + #:date (string->date "2019-05-23" "~Y-~m-~d"))
> + (resource
> + #:title (C_ "community resource title" "Code Staging in GNU Guix")
> + #:link "https://arxiv.org/abs/1709.00833"
> + #:type 'article
> + #:language (G_ "English")
> + #:author "Ludovic Courtès"
> + #:date (string->date "2017-09-04" "~Y-~m-~d"))
> + (resource
> + #:title (C_ "community resource title" "Guix: A most advanced operating system")
> + #:link "https://ambrevar.xyz/guix-advance/index.html"
> + #:type 'blog
> + #:language (G_ "English")
> + #:author "Pierre Neidhardt"
> + #:date (string->date "2019-01-14" "~Y-~m-~d"))))

At least for the one that’s on YouTube, but perhaps also for the other
videos, we should host a copy at audio-video.gnu.org (I’ll check what it
takes to do that.)

We should also have a policy to not link to material that steers towards
non-free software (I believe the links above are fine).

Last but not least: we should encourage people to submit their things,
because I’m sure there’s much more we could add here! :-)

That’s all I have to say. Luís, everyone: thoughts?

Ludo’.
B
B
Brett Gilio wrote on 12 Oct 2020 21:45
(name . Ludovic Courtès)(address . ludo@gnu.org)
87y2kbns8b.fsf@debian
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (9 lines)
>
> At least for the one that’s on YouTube, but perhaps also for the other
> videos, we should host a copy at audio-video.gnu.org (I’ll check what it
> takes to do that.)
>
> We should also have a policy to not link to material that steers towards
> non-free software (I believe the links above are fine).
>

You can open a ticket for audio-video with the webmasters and we can
move it to the AV queue, or you can email audio-video@gnu.org directly.

--
Brett M. Gilio
<brettg@gnu.org>
L
L
Luis Felipe wrote on 13 Oct 2020 14:47
(name . Ludovic Courtès)(address . ludo@gnu.org)
q1zs49KModf58A5fGfRcemgcOdE87-D20jZt3lBRQmJ52htHXfk3gz3AhjzGQDsmzamOoQxIU6_5pf8MtFTePDPH-rxlynmd071bupoTc3E=@protonmail.com
Hi,

??????? Original Message ???????
On Monday, October 12, 2020 4:41 PM, Ludovic Courtès ludo@gnu.org wrote:

[...]

Toggle quote (8 lines)
> We should also have a policy to not link to material that steers towards
> non-free software (I believe the links above are fine).
>
> Last but not least: we should encourage people to submit their things,
> because I’m sure there’s much more we could add here! :-)
>
> That’s all I have to say. Luís, everyone: thoughts?

Well, my idea was to have these kinds of resources grouped according to their types (https://lists.gnu.org/archive/html/guix-devel/2017-12/msg00356.html).So, instead of a Community resources entry in the Media menu, there would be separate entries like Talks, Papers, etc.

So the Media part of the website could work like the Blog in that you could explore all kinds of media (/lang/media/) or media of some type (e.g. /lang/media/talks/).

Also, at this point you can see that blog posts and media items are resources that usually have a preview with similar information: title, date, summary, etc. Using record types you end up defining one preview procedure for every record type (type->shtml) with pretty much the same body. At that time I was looking for records that allow some kind of inheritance, or GOOPS, to have one preview procedure (or method) that would accept different records/objects with a common ancestor specifying the common fields (title, date, summary, etc.). I tried GOOPS at that time and it worked.

I don't know, I'm still inclined to do it this way...
L
L
Ludovic Courtès wrote on 13 Oct 2020 22:06
(name . Luis Felipe)(address . luis.felipe.la@protonmail.com)
87y2k9hov8.fsf@gnu.org
Hi,

Luis Felipe <luis.felipe.la@protonmail.com> skribis:

Toggle quote (4 lines)
> Well, my idea was to have these kinds of resources grouped according to their types (https://lists.gnu.org/archive/html/guix-devel/2017-12/msg00356.html).So, instead of a Community resources entry in the Media menu, there would be separate entries like Talks, Papers, etc.
>
> So the Media part of the website could work like the Blog in that you could explore all kinds of media (/lang/media/) or media of some type (e.g. /lang/media/talks/).

Interesting, that makes sense to me, thanks for the reminder!

And yes, there’s already “Videos” and “Screenshots” (without /media in
the URL though), so I guess we could add “Talks” and “Papers” similarly.

Julien, does that look like a reasonable change to make? WDYT?

Thanks,
Ludo’.
J
J
Julien Lepiller wrote on 13 Oct 2020 22:46
(name . 43871@debbugs.gnu.org)(address . 43871@debbugs.gnu.org)
F7EADE52-F34A-4A43-9B34-27997F2CA0C3@lepiller.eu
Sounds reasonnable, but I won't be able to work on it before next week.

Le 13 octobre 2020 16:06:51 GMT-04:00, "Ludovic Courtès" <ludo@gnu.org> a écrit :
Toggle quote (24 lines)
>Hi,
>
>Luis Felipe <luis.felipe.la@protonmail.com> skribis:
>
>> Well, my idea was to have these kinds of resources grouped according
>to their types
>(https://lists.gnu.org/archive/html/guix-devel/2017-12/msg00356.html).
>So, instead of a Community resources entry in the Media menu, there
>would be separate entries like Talks, Papers, etc.
>>
>> So the Media part of the website could work like the Blog in that you
>could explore all kinds of media (/lang/media/) or media of some type
>(e.g. /lang/media/talks/).
>
>Interesting, that makes sense to me, thanks for the reminder!
>
>And yes, there’s already “Videos” and “Screenshots” (without /media in
>the URL though), so I guess we could add “Talks” and “Papers”
>similarly.
>
>Julien, does that look like a reasonable change to make? WDYT?
>
>Thanks,
>Ludo’.
Attachment: file
Z
Z
zimoun wrote on 4 Nov 2020 11:38
(name . Julien Lepiller)(address . julien@lepiller.eu)
86y2jhflum.fsf@gmail.com
Hi,

On Fri, 09 Oct 2020 at 00:38, Julien Lepiller <julien@lepiller.eu> wrote:

Toggle quote (4 lines)
> This patch aims at adding a new page on the website that lists external
> resources that talk about guix (conference talks, blog posts and even
> academic papers).

Well, what is the status of this patch?

To put more on the table, we recently discussed on #guix-hpc [1] to list
channels (of package FSDG compliant). It helps for discoverability.

For example,



“Community” section makes sense for this purpose. To be clear, the
subsection “Talks” of “Media” makes sense, as it is discussed; and
another section “Community” listing these channels (and maybe more) make
also sense. WDYT?



All the best,
simon
L
L
Luis Felipe wrote on 4 Nov 2020 17:12
(name . zimoun)(address . zimon.toutoune@gmail.com)
373YkYHCW3Nyxj8_fDQDiWvZ8oBLPx2scPrJ0x9AoavwqwnQk76IuGg6l3kHZpWIxtrp_GnQ_dJpViB3MYNUzO529PKVgOxmCvtOB-RzX40=@protonmail.com
??????? Original Message ???????
On Wednesday, November 4, 2020 10:38 AM, zimoun <zimon.toutoune@gmail.com> wrote:

Toggle quote (24 lines)
> Hi,
>
> On Fri, 09 Oct 2020 at 00:38, Julien Lepiller julien@lepiller.eu wrote:
>
> > This patch aims at adding a new page on the website that lists external
> > resources that talk about guix (conference talks, blog posts and even
> > academic papers).
>
> Well, what is the status of this patch?
>
> To put more on the table, we recently discussed on #guix-hpc [1] to list
> channels (of package FSDG compliant). It helps for discoverability.
>
> For example,
>
> https://github.com/BIMSBbioinfo/guix-bimsb
> https://github.com/guix-science/guix-science
>
> “Community” section makes sense for this purpose. To be clear, the
> subsection “Talks” of “Media” makes sense, as it is discussed; and
> another section “Community” listing these channels (and maybe more) make
> also sense. WDYT?


Or maybe add it to the Packages menu item? For example:

Packages (/LANG/packages/)
Channels (/LANG/packages/channels/ or /LANG/channels/)

Also, the Packages page could also mention that that list of packages comes from the Guix channel, but more packages are available from other channels (and link to the new list of channels).

I don't know about the "Community" part because I think the Guix community [is | will be] split into "Libre Only Community" and "Open Source with Proprietary Comunity", so maybe each community should build their own websites that better reflect their own goals? I don't know...
Z
Z
zimoun wrote on 4 Nov 2020 19:31
(name . Luis Felipe)(address . luis.felipe.la@protonmail.com)
CAJ3okZ3nrNT9qEF2kT9R9MJhqaX2CsfNoV83zz3vDb54KmF4aA@mail.gmail.com
Dear,

On Wed, 4 Nov 2020 at 17:12, Luis Felipe <luis.felipe.la@protonmail.com> wrote:

Toggle quote (5 lines)
> Or maybe add it to the Packages menu item? For example:
>
> Packages (/LANG/packages/)
> Channels (/LANG/packages/channels/ or /LANG/channels/)

Ok. Maybe it is better.


Toggle quote (2 lines)
> Also, the Packages page could also mention that that list of packages comes from the Guix channel, but more packages are available from other channels (and link to the new list of channels).

You mean add one sentence in the header of:


right?


Toggle quote (2 lines)
> I don't know about the "Community" part because I think the Guix community [is | will be] split into "Libre Only Community" and "Open Source with Proprietary Comunity", so maybe each community should build their own websites that better reflect their own goals? I don't know...

I do not understand this last statement. The website guix.gnu.org is
"Libre Only"; because it is GNU. Therefore, the channels will be
FSDG-compliant packages only (often variants) and other channels
(often named 'nonfree') will be not listed here. For example, even on
hpc.guix.info which is more permissive, nonfree channels contributed
by Ludo and/or Ricardo) about specific HPC tools are not listed
overthere. What do you have in mind about "Open Source with
non-free"?

All the best,
simon
L
L
Luis Felipe wrote on 5 Nov 2020 01:36
(name . zimoun)(address . zimon.toutoune@gmail.com)
qsZoE8aBNX_OnIKFcj3O8mu8CKAElOarZcYD0pI6l7PfBIVfHJe4W9YeGgTIWKpf2Sqy-oE8cLuDHUd_L7pfSn7wxiZCsf4kIPFrYrzexm8=@protonmail.com
??????? Original Message ???????
On Wednesday, November 4, 2020 6:31 PM, zimoun <zimon.toutoune@gmail.com> wrote:

Toggle quote (18 lines)
> Dear,
>
> On Wed, 4 Nov 2020 at 17:12, Luis Felipe luis.felipe.la@protonmail.com wrote:
>
> > Or maybe add it to the Packages menu item? For example:
> > Packages (/LANG/packages/)
> > Channels (/LANG/packages/channels/ or /LANG/channels/)
>
> Ok. Maybe it is better.
>
> > Also, the Packages page could also mention that that list of packages comes from the Guix channel, but more packages are available from other channels (and link to the new list of channels).
>
> You mean add one sentence in the header of:
>
> http://guix.gnu.org/en/packages/
>
> right?

I mean, modify the introductory paragraph. For example:

···
GNU Guix provides 15,183 packages transparently available as pre-built binaries. These pages provide a complete list of the packages IN GUIX CHANNELS. Our continuous integration system shows their current build status (updated November 4, 2020). CHECK THE CHANNELS PAGE TO LEARN ABOUT OTHER CHANNELS THAT PROVIDE ADDITIONAL FREE SOFTWARE NOT INCLUDED IN THE GUIX CHANNEL.
···

Or something like that. And maybe the first use of the term "channel" in that paragraph should be linked to the definition of a channel in the manual.



Toggle quote (11 lines)
> > I don't know about the "Community" part because I think the Guix community [is | will be] split into "Libre Only Community" and "Open Source with Proprietary Comunity", so maybe each community should build their own websites that better reflect their own goals? I don't know...
>
> I do not understand this last statement. The websiteguix.gnu.org is
> "Libre Only"; because it is GNU. Therefore, the channels will be
> FSDG-compliant packages only (often variants) and other channels
> (often named 'nonfree') will be not listed here. For example, even on
> hpc.guix.info which is more permissive, nonfree channels contributed
> by Ludo and/or Ricardo) about specific HPC tools are not listed
> overthere. What do you have in mind about "Open Source with
> non-free"?

Well, the thing is, when I read the word "Community" I think of the whole group of GNU Guix users, contributors, and enthusiasts (including people who use Guix with non-free software or who promote channels with non-free packages). So I don't like the word "community" because it would not include the whole Guix community (the group of people who use/promote non-free stuff would be excluded from the list).
L
L
Luis Felipe wrote on 25 May 2021 16:55
[PATCH website] Add community page
FRWdtJ3G7W417NDVC6CBkb_734kkCBhS3nMyyZ70f5NyRWCxIKIdMDxpqNFMa8CFjBlpGdtGfVVSIuDcAzmUMYYWDHfz6k29SdcxddWuoe0=@protonmail.com
Hi,

Just to let you know that I sent a patch that adds a new "Publications" page to the website (https://issues.guix.gnu.org/48637),which lists external written publications about Guix. It includes the written resources from Julien's community page.

In a different patch, I'll submit some changes to the videos part of the website and include videos from Julien's community page.

After that, I plan to submit another patch addressing zimoun's proposal about channels (a Channels page).


---
Luis Felipe López Acevedo
J
J
Julien Lepiller wrote on 25 May 2021 17:07
B175FBBB-E919-46D9-88FC-3AE0A638F4E3@lepiller.eu
That's great news! Thanks for working on that!

Le 25 mai 2021 10:55:59 GMT-04:00, Luis Felipe <luis.felipe.la@protonmail.com> a écrit :
Toggle quote (17 lines)
>Hi,
>
>Just to let you know that I sent a patch that adds a new "Publications"
>page to the website (https://issues.guix.gnu.org/48637), which lists
>external written publications about Guix. It includes the written
>resources from Julien's community page.
>
>In a different patch, I'll submit some changes to the videos part of
>the website and include videos from Julien's community page.
>
>After that, I plan to submit another patch addressing zimoun's proposal
>about channels (a Channels page).
>
>
>---
>Luis Felipe López Acevedo
>https://luis-felipe.gitlab.io/
Attachment: file
L
L
Luis Felipe wrote on 1 Jul 2021 15:31
muIRfMJCaBdMxKR0C81Yw7j1x320HGbBXl6sDf0EooPcfXCMB-HQ9AXKtUmyLBvmURzjRp9QvwMzodyJdY3nlfRbPheHJjZJfAEPRYgI7Rc=@protonmail.com
Hello again,

On Tuesday, May 25th, 2021 at 2:55 PM, Luis Felipe <luis.felipe.la@protonmail.com> wrote:

Toggle quote (2 lines)
> In a different patch, I'll submit some changes to the videos part of the website and include videos from Julien's community page.

Just to let you know that I submitted the videos patch: https://issues.guix.gnu.org/49310.
J
J
Julien Lepiller wrote on 19 Nov 2021 15:36
Add community page
(address . 43871-close@debbugs.gnu.org)
8BF9616B-7ADB-42EF-BCFE-D69ED18AA202@lepiller.eu
Closing since we now have equivalent pages :)
Attachment: file
?