(address . guix-patches@gnu.org)
* gnu/packages/web.scm (esbuild): New variable.
---
gnu/packages/web.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
Toggle diff (41 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b798e0abca..1e2f2e7e10 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1345,6 +1345,34 @@ used to validate and fix HTML data.")
(home-page "http://tidy.sourceforge.net/")
(license (license:x11-style "file:///include/tidy.h"))))
+(define-public esbuild
+ (package
+ (name "esbuild")
+ (version "0.7.11")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/evanw/esbuild")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08lx1i0s1q3my6x4csz746rc3c2fl4p0hyrwx4rpx80gwwjj1i11"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/evanw/esbuild/cmd/esbuild"
+ #:unpack-path "github.com/evanw/esbuild"))
+ (inputs
+ `(("go-golang-org-x-sys" ,go-golang-org-x-sys)))
+ (home-page "https://github.com/evanw/esbuild")
+ (synopsis "Bundler and minifier tool for JavaScript and TypeScript")
+ (description
+ "The esbuild tool provides a unified bundler, transpiler and
+minifier. It packages up JavaScript and TypeScript code, along with JSON
+and other data, for distribution on the web.")
+ (license license:expat)))
+
(define-public tinyproxy
(package
(name "tinyproxy")
--
2.17.1