ripgrep and fd create .crates.toml which reference to build dir.

  • Done
  • quality assurance status badge
Details
2 participants
  • Zhu Zihao
  • Efraim Flashner
Owner
unassigned
Submitted by
Zhu Zihao
Severity
normal
Z
Z
Zhu Zihao wrote on 5 Oct 2020 09:45
(address . bug-guix@gnu.org)
1a426c2b.160d.174f7b9389f.Coremail.all_but_last@163.com
In Guix commit 7cb4440951fa3a91d48c63ac5be123636abfcf82. I found that ripgrep and fd will emit a `.crates.toml` file outside of FHS structure(at the root of profile).


For example, the .crates.toml file from fd looks like.



```

[v1]
"fd-find 8.1.1 (path+file:///tmp/guix-build-fd-8.1.1.drv-0/fd-find-8.1.1)" = ["fd"]
```


This file records the build directory, I think we'd better to exclude this to improve the determinisitc(If this file doesn't affect the functionality).


If we can't exclude it, it's better to place it in a proper place, if we leave it in the root of profile, .crates.toml from different rust apps will override each other.
Attachment: file
E
E
Efraim Flashner wrote on 6 Oct 2020 09:12
(name . Zhu Zihao)(address . all_but_last@163.com)(address . 43810@debbugs.gnu.org)
20201006071258.GC21174@E5400
On Mon, Oct 05, 2020 at 03:45:45PM +0800, Zhu Zihao wrote:
Toggle quote (19 lines)
> In Guix commit 7cb4440951fa3a91d48c63ac5be123636abfcf82. I found that ripgrep and fd will emit a `.crates.toml` file outside of FHS structure(at the root of profile).
>
>
> For example, the .crates.toml file from fd looks like.
>
>
>
> ```
>
> [v1]
> "fd-find 8.1.1 (path+file:///tmp/guix-build-fd-8.1.1.drv-0/fd-find-8.1.1)" = ["fd"]
> ```
>
>
> This file records the build directory, I think we'd better to exclude this to improve the determinisitc(If this file doesn't affect the functionality).
>
>
> If we can't exclude it, it's better to place it in a proper place, if we leave it in the root of profile, .crates.toml from different rust apps will override each other.

It turns out this file seems to exist in other crate packages too. I
just checked rust-cbindgen. Luckily the rust bootstrap process doesn't
use the cargo-build-system so it's something we can fix on master and
not staging.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl98GPYACgkQQarn3Mo9
g1Ev5BAAkhKfhuN2deOVcJ0nYhgyaTn02mTQNafFhlrVcsNldOWUBiydQJM/tEIF
qHSEnvNspJAwdhkTE19Vh20T1X0XOln3NwyAaFIMDdvttVYT5332LY/3cZXcsaNG
NKJHnxb28ElzHqWcHB1tH2jMK62S2cz7ZU0t7R/Wu2R8xYucfZtCNLuCIKhQRAtP
ue6vmPACTl7LwG10Pt2OUUbJA2b7DfnZ/PEP97MuIKLNFqHKwwJy8A+TW5ZrHMN5
ytBktlDaXd44Rr1clgyWXdTx2GMwvmgo3u8pqxKBJHYapxA29Cvmxg0XUYk/uyvg
4bJggw/fC42MOoqJAvSd7KKyqn2hFVdGUy5r2WOd56Wqg2cxXaHfA+RnjdIyQFWX
4JapE4lgooM5R1/Tl9qFcDPdlteBayw5yaDgGRxoVtsQ6Rhk1OIG6y4rrIuWlGZW
8DzuhQUqA1jR7mZpk7SUSDt2M5/9cxWv3pxo4i69aHluvFts35ZiZM20VIFytmhj
4G2Z6Lu+WsnCSXfUE+edwqOcwLPEiCvzOESnkSXSGrPmKCD7aiMth1TetgB+Mv1H
ZawHsFKQCcYNgrbDDXpL2Ei0rX1hjUE/kXkhQnBXBBGd8O3Pu1Kf2eHwzqvDCR5S
PPLxn3y75XMFSrYikiys5EqM8mT7fONwwbl8KeHTr1CXKGVOvJI=
=F0YD
-----END PGP SIGNATURE-----


E
E
Efraim Flashner wrote on 6 Oct 2020 09:40
(name . Zhu Zihao)(address . all_but_last@163.com)(address . 43810-done@debbugs.gnu.org)
20201006074023.GE21174@E5400
I've pushed a patch to remove this file during the install phase when
building crates & rust apps.


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl98H2YACgkQQarn3Mo9
g1ET6g/+PBSVNfJu9qp5qvMjldHQaNPFYXQ5rtk3lgpVb1WnK7b3mUGIYF3i7qMJ
iRZWCVA7wpUzkZvSMAk6cW6rPLPVvdIyIPPvsZG4xh5WwPxUE1nvOa8MSQKm5Qk/
2Fx5MHY9+n1gbukiybVok9yhv8aLk3scLVkZ4aANLftxh94x00y22qNbhd/6P39h
fLTG4O3urUSWA9EJk8omxHI+OdrCoqeAlP3VxH3iSvA7gLsNi0IRN6B1xxtqTMKE
TGQWrhuG9orx4IxeSFsKhnlxY/0t7M1ETWMegu9ejVeHWHsXZFjtFDwKaxdU6oCA
1pBt7B3u3g19i8QvBDPhSqU+lIIJY9P5sxDAXc0qhYzUgU+CZGxvVezlCfPntyo9
MwI8sse+Pl2uIsb5CHZFvqfsurRhysxkhC/fzkkcJsktTAumLz6A0vt5od5AMe2C
kYIvpbVNkjP5c5xGiFP49UZCAANU4wd5vTWF7faNsYVQZahdnEU33fIzaXur58Qf
mIZQ1ZN6x5HLdkT8aTK8Lch/eL38/A6g6fOQTKF1XGOpIEWAumiZ+sE+dInX5TNs
Ok0QZatvxYgg3U5co+PhY0qudaqhRTW2uSahI/Wtmkc9sY1RXDhGT+DUhFP1xRJV
Fx/7OYQ3AMxYBpHMsNz4wl7eGYn1GW0WdiQFRSu6krSh6XWVlPg=
=ODDp
-----END PGP SIGNATURE-----


Closed
?