[PATCH] gnu: stockfish: Update to 12.

  • Done
  • quality assurance status badge
Details
2 participants
  • Michael Rohleder
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal
M
M
Michael Rohleder wrote on 4 Oct 2020 17:33
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20201004153359.31979-1-mike@rohleder.de
* gnu/packages/games.scm (stockfish): Update to 12.
---
gnu/packages/games.scm | 17 ++++++++++++++---
1 file changed, 14 insertions(+), 3 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 28c1492b26..30aa7b9a25 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -11407,7 +11407,7 @@ etc. You can also play games on FICS or against an engine.")
(define-public stockfish
(package
(name "stockfish")
- (version "11")
+ (version "12")
(source
(origin
(method git-fetch)
@@ -11416,8 +11416,15 @@ etc. You can also play games on FICS or against an engine.")
(commit (string-append "sf_" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "12mppipinymj8s1ipq9a7is453vncly49c32ym9wvyklsgyxfzlk"))))
+ (base32 "0vcymbwp5nf114pp3ax40s21ki5dckda15vmhr77d1mnq3fn0l32"))))
(build-system gnu-build-system)
+ (inputs
+ `(("net"
+ ,(origin
+ (method url-fetch)
+ (uri "https://tests.stockfishchess.org/api/nn/nn-82215d0fd0df.nnue")
+ (sha256
+ (base32 "1r4yqrh4di05syyhl84hqcz84djpbd605b27zhbxwg6zs07ms8c2"))))))
(arguments
`(#:tests? #f
#:make-flags (list "-C" "src"
@@ -11433,7 +11440,11 @@ etc. You can also play games on FICS or against an engine.")
("mips64el-linux" "general-64")
(_ "general-32"))))
#:phases (modify-phases %standard-phases
- (delete 'configure))))
+ (delete 'configure)
+ (add-after 'unpack 'copy-net
+ (lambda* (#:key inputs #:allow-other-keys)
+ (copy-file (assoc-ref inputs "net") "src/nn-82215d0fd0df.nnue")
+ #t)))))
(synopsis "Strong chess engine")
(description
"Stockfish is a very strong chess engines. It is much stronger than the
--
2.28.0
M
M
Mathieu Othacehe wrote on 6 Oct 2020 10:02
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 43795@debbugs.gnu.org)
87ft6r4wa5.fsf@gnu.org
Hello,

Toggle quote (2 lines)
> + (copy-file (assoc-ref inputs "net") "src/nn-82215d0fd0df.nnue")

You could wrap this line and also add a comment explaining why this
extra input is necessary.

Thanks,

Mathieu
M
M
Michael Rohleder wrote on 6 Oct 2020 12:32
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 43795@debbugs.gnu.org)
87tuv77ig6.fsf@rohleder.de
Thank you for reviewing!

Mathieu Othacehe <othacehe@gnu.org> writes:
Toggle quote (5 lines)
>> + (copy-file (assoc-ref inputs "net") "src/nn-82215d0fd0df.nnue")
>
> You could wrap this line and also add a comment explaining why this
> extra input is necessary.

Ok, did this and renamed the input to "neural-network".
Toggle quote (1 lines)
>From b128348ff8ea51b957f5bb811f88850ed541186c Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Tue, 6 Oct 2020 12:22:33 +0200
Subject: [PATCH] gnu: stockfish: Update to 12.

* gnu/packages/games.scm (stockfish): Update to 12.
[inputs]: Add fetching of the official neural network file.
[arguments]: Add phase 'copy-net to copy this file and embedd it.
---
gnu/packages/games.scm | 20 +++++++++++++++++---
1 file changed, 17 insertions(+), 3 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 00fc63aedf..d473baa335 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -11409,7 +11409,7 @@ etc. You can also play games on FICS or against an engine.")
(define-public stockfish
(package
(name "stockfish")
- (version "11")
+ (version "12")
(source
(origin
(method git-fetch)
@@ -11418,8 +11418,15 @@ etc. You can also play games on FICS or against an engine.")
(commit (string-append "sf_" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "12mppipinymj8s1ipq9a7is453vncly49c32ym9wvyklsgyxfzlk"))))
+ (base32 "0vcymbwp5nf114pp3ax40s21ki5dckda15vmhr77d1mnq3fn0l32"))))
(build-system gnu-build-system)
+ (inputs
+ `(("neural-network"
+ ,(origin
+ (method url-fetch)
+ (uri "https://tests.stockfishchess.org/api/nn/nn-82215d0fd0df.nnue")
+ (sha256
+ (base32 "1r4yqrh4di05syyhl84hqcz84djpbd605b27zhbxwg6zs07ms8c2"))))))
(arguments
`(#:tests? #f
#:make-flags (list "-C" "src"
@@ -11435,7 +11442,14 @@ etc. You can also play games on FICS or against an engine.")
("mips64el-linux" "general-64")
(_ "general-32"))))
#:phases (modify-phases %standard-phases
- (delete 'configure))))
+ (delete 'configure)
+ ;; The official neural network file is needed for building
+ ;; and is embedded in the resulting binary.
+ (add-after 'unpack 'copy-net
+ (lambda* (#:key inputs #:allow-other-keys)
+ (copy-file (assoc-ref inputs "neural-network")
+ "src/nn-82215d0fd0df.nnue")
+ #t)))))
(synopsis "Strong chess engine")
(description
"Stockfish is a very strong chess engine. It is much stronger than the
--
2.28.0
--
Happiness does not depend on what you have or who your are.
It solely relies on what you think. - Buddha
-----BEGIN PGP SIGNATURE-----

iQFFBAEBCAAvFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl98R9oRHG1pa2VAcm9o
bGVkZXIuZGUACgkQfHr/vv7yyyVf2ggAgvVYoArhXhNbMYnf17hE8oFySFaCmaDc
IC8szdMiJ4MfNxJDnBKT8hlu0xkWAfQ7RSlinHDpDENHfuunvSG6L6OAbEq5SsHr
2ZIIyrMC8ykwDVIZQq4SKhrIbr0wUWfZlICwFeZ4WXsAQUb7EReueG1Y6NqaQVMd
uN+BSEDN5d8MVxKaThBX+8gmObBnJHgrM0UQcEvMv18Wx+aFfBqyZjiVpjdvJerg
c7aXUdWpeE2mGGVq4jHENCjQNt9Ey/64/sxMyEu11QCKAjvbcA4LjlvayD+pD35F
f+4hFQ4ITBmHnZgV1TltSPHqPunyiJkqJfgIWFvtGo4igJhYquL5YA==
=l8eA
-----END PGP SIGNATURE-----

M
M
Mathieu Othacehe wrote on 6 Oct 2020 13:52
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 43795-done@debbugs.gnu.org)
87o8lf3721.fsf@gnu.org
Toggle quote (2 lines)
> Ok, did this and renamed the input to "neural-network".

Nice, pushed as b343f5d8fdea44ebcf2e8459f4a3b1ce7da07df2.

Thanks,

Mathieu
Closed
?