[PATCH 0/3] Add AWS Go SDK

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Ryan Prior
Owner
unassigned
Submitted by
Ryan Prior
Severity
normal
R
R
Ryan Prior wrote on 4 Oct 2020 07:20
(address . guix-patches@gnu.org)
20201004051959.29166-1-rprior@protonmail.com
The AWS Go SDK is one of the many dependencies of Hugo
(https://issues.guix.gnu.org/43784),and useful for others as well. This patch
series contains packages for the SDK and its dependencies.

Ryan Prior (3):
gnu: Add go-github-com-go-sql-driver-mysql.
gnu: Add go-github-com-jmespath-go-jmespath.
gnu: Add go-github-com-aws-sdk.

gnu/packages/golang.scm | 82 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 82 insertions(+)

--
2.17.1
R
R
Ryan Prior wrote on 4 Oct 2020 07:22
[PATCH 1/3] gnu: Add go-github-com-go-sql-driver-mysql.
(address . 43785@debbugs.gnu.org)
20201004052218.29371-1-rprior@protonmail.com
* gnu/packages/golang.scm (go-github-com-go-sql-driver-mysql): New variable.
---
gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 001c864505..dfaaba47c3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3341,6 +3341,31 @@ without requiring a real database connection.")
(home-page "https://github.com/DATA-DOG/go-sqlmock")
(license license:expat))))
+(define-public go-github-com-go-sql-driver-mysql
+ (package
+ (name "go-github-com-go-sql-driver-mysql")
+ (version "1.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-sql-driver/mysql")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11x0m9yf3kdnf6981182r824psgxwfaqhn3x3in4yiidp0w0hk3v"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:tests? #f ;; tests require a network connection
+ #:import-path "github.com/go-sql-driver/mysql"))
+ (home-page "https://github.com/go-sql-driver/mysql")
+ (synopsis "MySQL driver for golang")
+ (description
+ "This is a pure Go implementaton of the MySQL API, compatible with
+golang's database/sql package.")
+ (license license:mpl2.0)))
+
(define-public go-golang-org-colorful
(package
(name "go-golang-org-colorful")
--
2.17.1
R
R
Ryan Prior wrote on 4 Oct 2020 07:22
[PATCH 2/3] gnu: Add go-github-com-jmespath-go-jmespath.
(address . 43785@debbugs.gnu.org)
20201004052218.29371-2-rprior@protonmail.com
* gnu/packages/golang.scm (go-github-com-jmespath-go-jmespath): New variable.
---
gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index dfaaba47c3..ed822c53a0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4886,6 +4886,34 @@ the parse trees produced by the html package.")
to jQuery to the Go language.")
(license license:bsd-3)))
+(define-public go-github-com-jmespath-go-jmespath
+ (package
+ (name "go-github-com-jmespath-go-jmespath")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jmespath/go-jmespath")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18zyr9nlywmwp3wpzcjxrgq9s9d2mmc6zg6xhsna00m663nkyc3n"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/jmespath/go-jmespath"))
+ (native-inputs
+ `(("go-github-com-davecgh-go-spew" ,go-github-com-davecgh-go-spew)
+ ("go-github-com-pmezard-go-difflib" ,go-github-com-pmezard-go-difflib)
+ ("go-gopkg-in-yaml-v2" ,go-gopkg-in-yaml-v2)))
+ (home-page "https://github.com/jmespath/go-jmespath")
+ (synopsis "Golang implementation of JMESPath")
+ (description
+ "This package implements JMESPath, a query language for JSON. It
+transforms one JSON document into another through a JMESPath expression.")
+ (license license:asl2.0)))
+
(define-public go-github-com-aymerick-douceur
(package
(name "go-github-com-aymerick-douceur")
--
2.17.1
R
R
Ryan Prior wrote on 4 Oct 2020 07:22
[PATCH 3/3] gnu: Add go-github-com-aws-sdk.
(address . 43785@debbugs.gnu.org)
20201004052218.29371-3-rprior@protonmail.com
* gnu/packages/golang.scm (go-github-com-aws-sdk): New variable.
---
gnu/packages/golang.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ed822c53a0..7282b5710b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -502,6 +502,35 @@ way of specifying command line options.")
(home-page "https://github.com/jessevdk/go-flags")
(license license:bsd-3)))
+(define-public go-github-com-aws-sdk
+ (package
+ (name "go-github-com-aws-sdk")
+ (version "1.35.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aws/aws-sdk-go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ky5lw2s2zpslnnqcs6hgsrwvwbxwgflb5jwf16dd4aga3vrg10c"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/aws/aws-sdk-go/aws"
+ #:unpack-path "github.com/aws/aws-sdk-go"))
+ (propagated-inputs
+ `(("go-github-com-go-sql-driver-mysql" ,go-github-com-go-sql-driver-mysql)
+ ("go-github-com-jmespath-go-jmespath" ,go-github-com-jmespath-go-jmespath)
+ ("go-github-com-pkg-errors" ,go-github-com-pkg-errors)
+ ("go-golang-org-x-net" ,go-golang-org-x-net)))
+ (home-page "https://github.com/aws/aws-sdk-go")
+ (synopsis "Library to access Amazon Web Services (AWS)")
+ (description
+ "This is the official AWS SDK for the Go programming language.")
+ (license license:asl2.0)))
+
(define-public go-gopkg.in-tomb.v2
(let ((commit "d5d1b5820637886def9eef33e03a27a9f166942c")
(revision "0"))
--
2.17.1
E
E
Efraim Flashner wrote on 9 Dec 2020 08:47
Re: [bug#43785] [PATCH 0/3] Add AWS Go SDK
(name . Ryan Prior)(address . rprior@protonmail.com)(address . 43785-done@debbugs.gnu.org)
X9CBDFu4FiOmevvV@E5400
On Sun, Oct 04, 2020 at 05:20:04AM +0000, Ryan Prior via Guix-patches via wrote:
Toggle quote (16 lines)
> The AWS Go SDK is one of the many dependencies of Hugo
> (https://issues.guix.gnu.org/43784), and useful for others as well. This patch
> series contains packages for the SDK and its dependencies.
>
> Ryan Prior (3):
> gnu: Add go-github-com-go-sql-driver-mysql.
> gnu: Add go-github-com-jmespath-go-jmespath.
> gnu: Add go-github-com-aws-sdk.
>
> gnu/packages/golang.scm | 82 +++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 82 insertions(+)
>
> --
> 2.17.1
>

This patch set apparently got forgotten. Patches pushed!

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl/QgQwACgkQQarn3Mo9
g1EsQQ//aWbTvB6+8f1wRaHul3ylzOQMXsQdte1qWGpNrcUAGgtFZj3FhQSeyg9K
udN0LJZ29ZybZ5u9KYmW7dhQ44GB8bjDdnSzuTr+LhHzQnkTtwAcTP8mTLjddR4r
Bh9qwrc+OCk8eonr0djwXB3Yz5kR1jdNM3jDWaUhBCUJc/DWgJBc617EL2cwKqrP
5WEy1i9JPlKoiqK8k3MV20CY4jOmMnjSgGEXKtZeaVNLHUvzD0CEc/6hvZF/hxlu
r2DjmSGmbjZ5ekx7uhwrJqJAuq1pgtSgpo4t584hmqfo+rYF4SchFWyaYvLG1SHw
i6srb/kl+79j0Nih6jGmfn9xOo+Qo4nhQSN/bFcg3dklyTflP9Oh3WuUkkqzAbY1
Dga/kk3q7o2hYMPn0x8/1/ACUpaeP670zPf68nBkmulCVqEsWj939vHo7xxFw6m1
7JzCrWN30EXyHzVBE/wYyOdrQarQUrY/yGVM29lMVRvfLd3yah+crlWkObJ/sE95
avUYVWVC9Mh81jkJwXZJcG6ZYifO4HnR0Ie2H+QKjHqFr39SB9XdBlD13PJ0EDmY
24G6T6sweLRhg25fJ5S6J7kNOcCv9Kcy8kv6YnQKTwn4x90bul8c26Gcb3Ff329/
Z3U6sZ27vutMN1AxjrfLUL0IBbtzUVOEWp5o02V05t2kshcWhmI=
=1rOt
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43785@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43785
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch