(address . bug-guix@gnu.org)
Hello Guix!
When someone’s working on a channel, it’s typical to have that channel
already in your ‘guix’ and to use ‘guix build -L /path/to/checkout PKG’
to test a package from a working copy of the channel. Here’s what it
looks like:
Toggle snippet (52 lines)
$ cat ~/.config/guix/past-channels.scm
(cons (channel
(name 'guix-past)
(url "https://gitlab.inria.fr/guix-hpc/guix-past")
(introduction
(make-channel-introduction
"0c119db2ea86a389769f4d2b9c6f5c41c027e336"
(openpgp-fingerprint
"3CE4 6455 8A84 FDC6 9DB4 0CFB 090B 1199 3D9A EBB5"))))
%default-channels)
$ guix pull -p /tmp/test -C ~/.config/guix/past-channels.scm
[...]
$ /tmp/test/bin/guix build -L ~/src/guix-past/modules autoconf@2.59 -n
;;; note: source file /home/ludo/src/guix-past/modules/past/packages/assembly.scm
;;; newer than compiled /gnu/store/6b0ww9dxvfig7wdxqcyjs0hlw331la4z-guix-past/lib/guile/3.0/site-ccache/past/packages/assembly.go
;;; note: source file /home/ludo/src/guix-past/modules/past/packages/autotools.scm
;;; newer than compiled /gnu/store/6b0ww9dxvfig7wdxqcyjs0hlw331la4z-guix-past/lib/guile/3.0/site-ccache/past/packages/autotools.go
;;; found fresh local cache at /home/ludo/.cache/guile/ccache/3.0-LE-8-4.3/home/ludo/src/guix-past/modules/past/packages/autotools.scm.go
;;; note: source file /home/ludo/src/guix-past/modules/past/packages/backup.scm
;;; newer than compiled /gnu/store/6b0ww9dxvfig7wdxqcyjs0hlw331la4z-guix-past/lib/guile/3.0/site-ccache/past/packages/backup.go
;;; found fresh local cache at /home/ludo/.cache/guile/ccache/3.0-LE-8-4.3/home/ludo/src/guix-past/modules/past/packages/backup.scm.go
;;; note: source file /home/ludo/src/guix-past/modules/past/packages/guile-xyz.scm
;;; newer than compiled /gnu/store/6b0ww9dxvfig7wdxqcyjs0hlw331la4z-guix-past/lib/guile/3.0/site-ccache/past/packages/guile-xyz.go
;;; found fresh local cache at /home/ludo/.cache/guile/ccache/3.0-LE-8-4.3/home/ludo/src/guix-past/modules/past/packages/guile-xyz.scm.go
;;; note: source file /home/ludo/src/guix-past/modules/past/packages/boost.scm
;;; newer than compiled /gnu/store/6b0ww9dxvfig7wdxqcyjs0hlw331la4z-guix-past/lib/guile/3.0/site-ccache/past/packages/boost.go
;;; found fresh local cache at /home/ludo/.cache/guile/ccache/3.0-LE-8-4.3/home/ludo/src/guix-past/modules/past/packages/boost.scm.go
;;; note: source file /home/ludo/src/guix-past/modules/past/packages/graphviz.scm
;;; newer than compiled /gnu/store/6b0ww9dxvfig7wdxqcyjs0hlw331la4z-guix-past/lib/guile/3.0/site-ccache/past/packages/graphviz.go
;;; note: source file /home/ludo/src/guix-past/modules/past/packages/maths.scm
;;; newer than compiled /gnu/store/6b0ww9dxvfig7wdxqcyjs0hlw331la4z-guix-past/lib/guile/3.0/site-ccache/past/packages/maths.go
;;; note: source file /home/ludo/src/guix-past/modules/past/packages/maths.scm
;;; newer than compiled /home/ludo/.cache/guile/ccache/3.0-LE-8-4.3/home/ludo/src/guix-past/modules/past/packages/maths.scm.go
;;; note: source file /home/ludo/src/guix-past/modules/past/packages/perl.scm
;;; newer than compiled /gnu/store/6b0ww9dxvfig7wdxqcyjs0hlw331la4z-guix-past/lib/guile/3.0/site-ccache/past/packages/perl.go
;;; found fresh local cache at /home/ludo/.cache/guile/ccache/3.0-LE-8-4.3/home/ludo/src/guix-past/modules/past/packages/perl.scm.go
;;; note: source file /home/ludo/src/guix-past/modules/past/packages/python.scm
;;; newer than compiled /gnu/store/6b0ww9dxvfig7wdxqcyjs0hlw331la4z-guix-past/lib/guile/3.0/site-ccache/past/packages/python.go
;;; note: source file /home/ludo/src/guix-past/modules/past/packages/python.scm
;;; newer than compiled /home/ludo/.cache/guile/ccache/3.0-LE-8-4.3/home/ludo/src/guix-past/modules/past/packages/python.scm.go
;;; note: source file /home/ludo/src/guix-past/modules/past/packages/statistics.scm
;;; newer than compiled /gnu/store/6b0ww9dxvfig7wdxqcyjs0hlw331la4z-guix-past/lib/guile/3.0/site-ccache/past/packages/statistics.go
;;; note: source file /home/ludo/src/guix-past/modules/past/packages/simgrid.scm
;;; newer than compiled /gnu/store/6b0ww9dxvfig7wdxqcyjs0hlw331la4z-guix-past/lib/guile/3.0/site-ccache/past/packages/simgrid.go
;;; found fresh local cache at /home/ludo/.cache/guile/ccache/3.0-LE-8-4.3/home/ludo/src/guix-past/modules/past/packages/simgrid.scm.go
;;; note: source file /home/ludo/src/guix-past/modules/past/packages/web.scm
;;; newer than compiled /gnu/store/6b0ww9dxvfig7wdxqcyjs0hlw331la4z-guix-past/lib/guile/3.0/site-ccache/past/packages/web.go
/gnu/store/nah91czddjcb72ghx9kh2z6jwad0kh4d-autoconf-2.59
The problem as can be seen above is that all these Guile warnings are
confusing at best and useless: there’s nothing the user can do about
them.
Ludo’.