tests/guix-environment.sh is broken when SHELL=fish

  • Open
  • quality assurance status badge
Details
One participant
  • Mikhail Tsykalov
Owner
unassigned
Submitted by
Mikhail Tsykalov
Severity
normal
M
M
Mikhail Tsykalov wrote on 30 Sep 2020 19:39
(address . bug-guix@gnu.org)
00f52b84-e8dc-d77a-07f4-026677edb911@gmail.com
Hi,

I'm on commit db194f714a8beb155c508c06e346c7c2322e7053. Running tests
with fish as shell always results in failure at test
tests/guix-environment.sh. Seems like problem is with difference in
`set` output format.

`set` command in fish outputs environmental variables in format:
VAR1 VAL1
VAR2 VAL2

tests/guix-environment.sh expects format:
VAR1=VAL1
VAR2=VAL2

Thanks,
Mikhail
+ set -e
+ guix environment --version
guix environment (GNU Guix) 1.0.1.22248-4dd77
Copyright (C) 2020 the Guix authors
License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
+ tmpdir=t-guix-environment-13081
+ gcroot=t-guix-environment-gc-root-13081
+ trap 'rm -r "$tmpdir"; rm -f "$gcroot"' EXIT
+ mkdir t-guix-environment-13081
+ export SHELL
+ guix environment --bootstrap --ad-hoc guile-bootstrap --pure --search-paths
accepted connection from pid 13097, user tsmish
+ guix environment --bootstrap --ad-hoc guile-bootstrap:out --pure --search-paths
accepted connection from pid 13108, user tsmish
+ grep -E '^export PATH=.*profile/bin' t-guix-environment-13081/a
export PATH="/home/tsmish/src/guix/test-tmp/store/32inxhc578la6zzjna1ic0x5156lyrfx-profile/bin"
++ wc -l
+ test 1 = 1
++ sed -r 's/^export PATH="(.*)"/\1/' t-guix-environment-13081/a
+ test -x /home/tsmish/src/guix/test-tmp/store/32inxhc578la6zzjna1ic0x5156lyrfx-profile/bin/guile
+ cmp t-guix-environment-13081/a t-guix-environment-13081/b
+ GUIX_TEST_ABC=1
+ GUIX_TEST_DEF=2
+ GUIX_TEST_XYZ=3
+ export GUIX_TEST_ABC GUIX_TEST_DEF GUIX_TEST_XYZ
+ guix environment --bootstrap --ad-hoc guile-bootstrap --pure '--preserve=^GUIX_TEST_A' '--preserve=^GUIX_TEST_D' -- /gnu/store/k6rqxabw4v4nr3k8g820hxnx2sg2sryj-fish-3.1.2/bin/fish -c set
accepted connection from pid 13124, user tsmish
+ grep '^PATH=' t-guix-environment-13081/a
+ rm -r t-guix-environment-13081
+ rm -f t-guix-environment-gc-root-13081
FAIL tests/guix-environment.sh (exit status: 1)
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 43727@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43727
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch