[PATCH 2/2] gnu: ppsspp: Update to 1.10.3.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Leo Prikler
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 4 years ago
(address . guix-patches@gnu.org)
20200927123723.3232-2-leo.prikler@student.tugraz.at
* gnu/packages/emulators.scm (ppsspp): Update to 1.10.3.
[snippet]: Update the snippet, that strips glslang from build.
[inputs]: Update lang.
---
gnu/packages/emulators.scm | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index d0d581c4db..067d63e4bd 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1902,7 +1902,7 @@ framework based on QEMU.")
(define-public ppsspp
(package
(name "ppsspp")
- (version "1.10")
+ (version "1.10.3")
(source
(origin
(method git-fetch)
@@ -1910,7 +1910,7 @@ framework based on QEMU.")
(url "https://github.com/hrydgard/ppsspp")
(commit (string-append "v" version))))
(sha256
- (base32 "02yx1w0ygclnmdl0imsvgj24lkzi55wvxkf47q617j0jgrqhy8yl"))
+ (base32 "0znxlbj6cfw7gn0naay0mzhc0k5saw8nrwpspcn7gap1023p06w2"))
(file-name (git-file-name name version))
(patches
(search-patches "ppsspp-disable-upgrade-and-gold.patch"))
@@ -1961,7 +1961,7 @@ framework based on QEMU.")
" spirv-cross-reflect spirv-cross-util")))
(substitute* "ext/CMakeLists.txt"
(("add_subdirectory\\(glew\\)") "")
- (("add_subdirectory\\(glslang\\)") "")
+ (("add_subdirectory\\(glslang( [A-Z_]*)*\\)") "")
(("add_subdirectory\\(snappy\\)") "")
(("add_subdirectory\\(SPIRV-Cross-build\\)") ""))
;; Finally, we can delete the bundled sources.
@@ -2004,14 +2004,14 @@ framework based on QEMU.")
;; TODO: unbundle armips.
("armips-source" ,(package-source armips))
("lang"
- ,(let ((commit "d184ba2b607a03435be579406b816c90add334e6"))
+ ,(let ((commit "1c64b8fbd3cb6bd87935eb53f302f7de6f86e209"))
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/hrydgard/ppsspp-lang")
(commit commit)))
(sha256
- (base32 "0s003x6247nx09qd6a1jz1l2hsk5d6k1zmh8mg3m6hjjhvbvd9j9"))
+ (base32 "0rprn3yd8xfrvi0fm62sgpqa8n73jk7zmlscp8cp0h2fawqpiamd"))
(file-name (git-file-name "ppsspp-lang" commit)))))
("tests"
,(let ((commit "328b839c7243e7f733f9eae88d059485e3d808e7"))
--
2.28.0
Efraim Flashner wrote 4 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 43649-done@debbugs.gnu.org)
20200929054036.GG1386@E5400
Looks good. I wasn't sure about the source snippet but it turns out it
was right. Patch pushed!


--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl9yyNQACgkQQarn3Mo9
g1EVgA/+KgcaZFw/y78nNyNM684StX8Tv0rReetHkRxuZxpnVoueFFbQiUOCNIsO
+y5NXo06yyeVxt99s8OJ7KadSmtSG/dBBRKlUiOkGkW/KBwevFEBm585PKEvGZgb
uKzvQk4+ypsHlS+S6QFxaeOKzThtsaNsdp3V/ri1cYaXM6Enso338pzJvXBTrWR8
iT0BylxLPUD11+UHkYPo9LhW81g1fasEBfe3OiMM3mB14r4zEQFgkU1jhSjE55TP
vu4hCsXGllTuVlkONzTYo/OHu5khI4kx+Cb0oMiklvIKn3qH0m//imT6kFNMZE4m
LJl01Pqnu35IP+zpYrnvyuS1mQJxSG51OUmAJ2SoTFR9yP9y1u1flc+pCJxzIYI1
OOa95+kSek5zwUSzHNRpv5BbO8VPIdSPNGqXReYu9cQm6IaU2vC1NppdfxQi9GQz
JhKAhg967DkxZQ8U+5J+9LXrsO9wq/W0TyFnDPET68Qgt0BRneNHOKqbh235wwj9
WjGJaTOZHsC8prc4MKQm4T95xiDK1bMJcE2z6gjLgplBSkXJ0XmPq4W6+/i9Y78g
x0mFURzDpKlMKu3X0QsO+xAwDTA/pnZpa83PkXcOg7kJVB4A/fv3toma2piHUz82
GXCnQJcvCCznFY7uTXFzcxnLEjxduhIEZzDsU3rm9PboNELqWhA=
=lR89
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43649@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43649
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help