[PATCH] gnu: nng: Update to build as shared library

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Hamzeh Nasajpour
Owner
unassigned
Submitted by
Hamzeh Nasajpour
Severity
normal

Debbugs page

Hamzeh Nasajpour wrote 4 years ago
(address . guix-patches@gnu.org)
818a21e5-1299-464e-862d-f45a01d3141d@www.fastmail.com
Toggle diff (15 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 89e47a6726..a5aac7b878 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -419,7 +419,9 @@ at the link-layer level.")
(arguments
`(#:configure-flags
(list "-DNNG_ENABLE_COVERAGE=ON"
- "-DNNG_ENABLE_TLS=ON")
+ "-DNNG_ENABLE_TLS=ON"
+ ;; To building as shared library
+ "-DBUILD_SHARED_LIBS=ON")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'disable-failing-tests
Efraim Flashner wrote 4 years ago
(name . Hamzeh Nasajpour)(address . h.nasajpour@pantherx.org)(address . 43576-done@debbugs.gnu.org)
20200923091412.GI896@E5400
On Wed, Sep 23, 2020 at 11:41:25AM +0330, Hamzeh Nasajpour wrote:
Toggle quote (12 lines)
> diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
> index 89e47a6726..a5aac7b878 100644
> --- a/gnu/packages/networking.scm
> +++ b/gnu/packages/networking.scm
> @@ -419,7 +419,9 @@ at the link-layer level.")
> (arguments
> `(#:configure-flags
> (list "-DNNG_ENABLE_COVERAGE=ON"
> - "-DNNG_ENABLE_TLS=ON")
> + "-DNNG_ENABLE_TLS=ON"
> + ;; To building as shared library

This comment isn't really necessary

Toggle quote (6 lines)
> + "-DBUILD_SHARED_LIBS=ON")
> #:phases
> (modify-phases %standard-phases
> (add-after 'unpack 'disable-failing-tests
>

I created a whole commit message, added a copyright line for you
and pushed the patch. Thanks!

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl9rEeMACgkQQarn3Mo9
g1GB2Q/8DNEhuaYydGAMQ86Ed7UpO2yCDMFyDmvMVayk5cEFw1mC7+c6cUvrYL3I
2OdjZxF0twplXaQqQSZ9cQpaM5OI/WUo83s2QlB2icLDM16lUHsAuxg4Zx0YdRBR
DebyhXVZFItPTNjjm+/ANj941V7SVz6hA7NB52hpkrJv/tw5ZQZPT3nT/DYNbp60
JztyqNBdoXdhmETyP/ejp/9DVQZqpxRZyn9hBsKegwEcZTk1gVby8JT2dxIgTSeH
rgYNmvdljDH7kUoDeYYtj71nUJciQ3kyutC82Kx+jk6p7801WEsgRRMeTteZfQ/W
HncAUpHr3Pji+K9mZZ3H+CUUZdxFrdQ3SbIyTSHVwycoCTf8jZCxTbmcX76buMig
4eVWRBU/DE/nr4HxuPZ3FtSKs6r//UnPIJwYbpdDMFNmgxjkPb+i1hzGBMnN6pYJ
nfaDPZdzPJut/Gp7z7hIOVdR3PvAmllSERQyZkBnyObIJSLoFJMfF0l4DLCB2nZO
3z8D+X7VuPrrJWZBdSAECdJZRCUIlEhf/ZtA/DT5riigkiI8oBzOrfhwCDKCA/Wr
+5W1ILc/7IW9bnmeLQ1ajFPLYzn0P9udrimzrbXcDW5QOZLI57F2GAwnlXY37VQS
Ke5T00LNfK8TzdlH/qh94Ip+kSrsTcteWxvczN4sR/xJwKaPP9Y=
=zuZ8
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43576@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43576
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help