Guix Interactive Installer Broken

DoneSubmitted by Yasuaki Kudo.
Details
5 participants
  • Julien Lepiller
  • Ludovic Courtès
  • Tobias Geerinckx-Rice
  • Yasuaki Kudo
  • zimoun
Owner
unassigned
Severity
normal
Y
Y
Yasuaki Kudo wrote on 20 Sep 2020 09:51
(address . bug-guix@gnu.org)
EFA5059D-71B7-41BE-AFE0-C7C9F5C33576@yasuaki.com
Hi,
It seems Guix installer


is broken - I reported in June 2020 and saw another person report this bug again on the same help-guix mailing list. The graphical installer somehow appears to go into an infinite loop of repeating the same questions.
In addition , I watched this issue mentioned at https://youtu.be/jx3YF-ihjUg
Is there a bug tracker ID already assigned for this?
-Yasu
Attachment: file
Attachment: images.png
J
J
Julien Lepiller wrote on 20 Sep 2020 13:18
2086CD70-B1F0-4BD5-9388-7BCEA4E7C26C@lepiller.eu
Is this the installer for 1.1.0 or the "latest"? If you haven't tried yet, can you test https://ci.guix.gnu.org/search/latest/ISO-9660?query=spec:guix-master+status:success+system:x86_64-linux+image.iso
This should be the latest image with the most recent bug fixes. Maybe your issue was already fixed?
You can always use the manual installation instructions of course, but we should fix the issue if it's still present :)
Le 20 septembre 2020 03:51:19 GMT-04:00, Yasuaki Kudo <yasu@yasuaki.com> a écrit :
Toggle quote (17 lines)>Hi,>>It seems Guix installer >>>>is broken - I reported in June 2020 and saw another person report this>bug again on the same help-guix mailing list. The graphical installer>somehow appears to go into an infinite loop of repeating the same>questions.>>In addition , I watched this issue mentioned at >https://youtu.be/jx3YF-ihjUg>>Is there a bug tracker ID already assigned for this?>>-Yasu
Attachment: file
Y
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 43529@debbugs.gnu.org)
7a00b29ef0dd0eab20277ec904845e94@yasuaki.com
I think i tried 1.1.0. The link below leads to:
get 504 Gateway Time-out
is the server running?

On 20.09.2020 20:18, Julien Lepiller wrote:
Toggle quote (28 lines)> Is this the installer for 1.1.0 or the "latest"? If you haven't tried> yet, can you test> https://ci.guix.gnu.org/search/latest/ISO-9660?query=spec:guix-master+status:success+system:x86_64-linux+image.iso> > This should be the latest image with the most recent bug fixes. Maybe> your issue was already fixed?> > You can always use the manual installation instructions of course, but> we should fix the issue if it's still present :)> > Le 20 septembre 2020 03:51:19 GMT-04:00, Yasuaki Kudo> <yasu@yasuaki.com> a écrit :> >> Hi,>> >> It seems Guix installer>> >> is broken - I reported in June 2020 and saw another person report>> this bug again on the same help-guix mailing list. The graphical>> installer somehow appears to go into an infinite loop of repeating>> the same questions.>> >> In addition , I watched this issue mentioned at>> https://youtu.be/jx3YF-ihjUg>> >> Is there a bug tracker ID already assigned for this?>> >> -Yasu
T
T
Tobias Geerinckx-Rice wrote on 21 Sep 2020 12:31
(address . yasu@yasuaki.com)
3ceb62f399daf8c3ff1deb8ccfd95d87@tobias.gr
On 2020-09-21 2:50, yasu@yasuaki.com wrote:
Toggle quote (4 lines)> I think i tried 1.1.0. The link[0] below leads to:> > get 504 Gateway Time-out
The ISO images were very recently renamed from *iso9660-image to *image.iso, although that would not generate a 504.
Toggle quote (2 lines)> is the server running?
Yes. Have you tried again? It works fine here.
Kind regards,
T G-R
Sent from a Web browser. Excuse or enjoy my brevity.
[0]: https://ci.guix.gnu.org/search/latest/ISO-9660?query=spec:guix-master+status:success+system:x86_64-linux+image.iso
Z
Z
zimoun wrote on 29 Sep 2020 19:17
86wo0csds2.fsf@gmail.com
Dear,
Thank you for the feedback.
On Sun, 20 Sep 2020 at 16:51, Yasuaki Kudo <yasu@yasuaki.com> wrote:
Toggle quote (2 lines)> Is there a bug tracker ID already assigned for this?
Y
Y
Yasuaki Kudo wrote on 1 Oct 2020 00:32
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 43529@debbugs.gnu.org)
4BEE971F-21D2-478C-96E5-85CC9F6D78A7@yasuaki.com
let me try over the weekend 😄
Toggle quote (17 lines)> On Sep 30, 2020, at 02:17, zimoun <zimon.toutoune@gmail.com> wrote:> > Dear,> > Thank you for the feedback.> >> On Sun, 20 Sep 2020 at 16:51, Yasuaki Kudo <yasu@yasuaki.com> wrote:>> >> Is there a bug tracker ID already assigned for this?> > Do you hit the bug using the last image [1]?> > [1] <https://ci.guix.gnu.org/search/latest/ISO-9660?query=spec:guix-master+status:success+system:x86_64-linux+image.iso>> > > All the best,> simon
Y
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 43529@debbugs.gnu.org)
5e8d282cf1f1055df4f4bd9033daa460@yasuaki.com
Sorry I haven't tried this yet (the download seems to take a long time!)
But I created an image according to: https://guix.gnu.org/manual/devel/en/html_node/Building-the-Installation-Image.html
as of commit:
commit 23dc21f05b54ef63daaea9eb301cfddbc4c82ddb (HEAD -> master, origin/master, origin/HEAD) Author: Julien Lepiller <julien@lepiller.eu> Date: Fri Oct 2 00:28:30 2020 +0200

The installer failed to launch... I am attaching my screen copy
I can try again next weekend :-)
-Yasu



On 30.09.2020 02:17, zimoun wrote:
Toggle quote (16 lines)> Dear,> > Thank you for the feedback.> > On Sun, 20 Sep 2020 at 16:51, Yasuaki Kudo <yasu@yasuaki.com> wrote:> >> Is there a bug tracker ID already assigned for this?> > Do you hit the bug using the last image [1]?> > [1]> <https://ci.guix.gnu.org/search/latest/ISO-9660?query=spec:guix-master+status:success+system:x86_64-linux+image.iso>> > > All the best,> simon
Attachment: IMG_4975.jpg (1.17 MiB)
Z
Z
zimoun wrote on 5 Oct 2020 12:55
(name . Yasuaki Kudo)(address . yasu@yasuaki.com)(address . 43529@debbugs.gnu.org)
CAJ3okZ06ApSRL-kssjQreqF5WeUe25BG4oLGfkMdXVJ0RWCRrg@mail.gmail.com
Dear,
On Sun, 4 Oct 2020 at 13:58, <yasu@yasuaki.com> wrote:
Toggle quote (2 lines)> Sorry I haven't tried this yet (the download seems to take a long time!)
It depends on where you are based. :-)

Toggle quote (4 lines)> But I created an image according to:>> https://guix.gnu.org/manual/devel/en/html_node/Building-the-Installation-Image.html
[...]
Toggle quote (2 lines)> The installer failed to launch... I am attaching my screen copy
That's another issue than the one you initially reported. The firstone (infinite loop when asking about partition&co.) is fixed, I guess.So recent enough images should not have this bug.

All the best,simon
L
L
Ludovic Courtès wrote on 25 Apr 22:10 +0200
control message for bug #43529
(address . control@debbugs.gnu.org)
87sg3ef7lh.fsf@gnu.org
tags 43529 fixedclose 43529 quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send email to 43529@debbugs.gnu.org