[PATCH 1/2] gnu: Add python-liblarch.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 15 Sep 2020 23:06
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200915210630.54271-1-monego@posteo.net
* gnu/packages/gnome.scm (python-liblarch): New variable.
---
gnu/packages/gnome.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9b72e6a7ab..81ac0cfabf 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2501,6 +2501,47 @@ on the GNOME Desktop with a single simple application.")
for settings shared by various components of the GNOME desktop.")
(license license:lgpl2.1+)))
+(define-public python-liblarch
+ (package
+ (name "python-liblarch")
+ (version "3.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/getting-things-gnome/liblarch")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xv2mfvyzipbny3iz8vll77wsqxfwh28xj6bj1ff0l452waph45m"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'start-xserver
+ (lambda* (#:key inputs #:allow-other-keys)
+ (system (format #f "~a/bin/Xvfb :1 &"
+ (assoc-ref inputs "xorg-server")))
+ (setenv "DISPLAY" ":1")
+ #t)))))
+ (native-inputs
+ `(("xorg-server" ,xorg-server-for-tests)))
+ (inputs
+ `(("gtk+" ,gtk+)))
+ (propagated-inputs
+ `(("python-pygobject" ,python-pygobject)))
+ (home-page "https://wiki.gnome.org/Projects/liblarch")
+ (synopsis "Library to easily handle complex data structures")
+ (description
+ "Liblarch is a Python library built to easily handle data structures such
+as lists, trees and acyclic graphs. There's also a GTK binding that will
+allow you to use your data structure in a @code{Gtk.Treeview}.
+
+Liblarch support multiple views of one data structure and complex filtering.
+That way, you have a clear separation between your data themselves (Model)
+and how they are displayed (View).")
+ (license license:lgpl3+)))
+
(define-public icon-naming-utils
(package
(name "icon-naming-utils")
--
2.20.1
V
V
Vinicius Monego wrote on 15 Sep 2020 23:07
[PATCH 2/2] gnu: Add gtg.
(address . 43434@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200915210753.54440-1-monego@posteo.net
* gnu/packages/gnome.scm (gtg): New variable.
---
gnu/packages/gnome.scm | 57 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

Toggle diff (70 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 81ac0cfabf..1785a2f8e1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2542,6 +2542,63 @@ That way, you have a clear separation between your data themselves (Model)
and how they are displayed (View).")
(license license:lgpl3+)))
+(define-public gtg
+ (package
+ (name "gtg")
+ (version "0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/getting-things-gnome/gtg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0r28vyr88rj3kd3cg4gj7sd29wadjchi92wzmbx67d4hlg25h8kk"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/gtg"))
+ (pylib (string-append (assoc-ref outputs "out")
+ "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages")))
+ (wrap-program prog
+ `("PYTHONPATH" = (,(getenv "PYTHONPATH") ,pylib))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
+ #t))))))
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk+:bin" ,gtk+ "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gtk+" ,gtk+)
+ ("python-dbus" ,python-dbus)
+ ("python-liblarch" ,python-liblarch)
+ ("python-pycairo" ,python-pycairo)
+ ("python-pygobject" ,python-pygobject)
+ ("python-pyxdg" ,python-pyxdg)))
+ (home-page "https://wiki.gnome.org/Apps/GTG")
+ (synopsis "Personal organizer for the GNOME desktop")
+ (description
+ "Getting Things GNOME! (GTG) is a personal tasks and TODO list items
+organizer for the GNOME desktop environment inspired by the Getting Things
+Done (GTD) methodology. GTG is designed with flexibility, adaptability,
+and ease of use in mind so it can be used as more than just GTD software.
+GTG is intended to help you track everything you need to do and need to
+know, from small tasks to large projects.")
+ (license license:gpl3+)))
+
(define-public icon-naming-utils
(package
(name "icon-naming-utils")
--
2.20.1
L
L
Ludovic Courtès wrote on 24 Sep 2020 17:31
Re: [bug#43434] [PATCH 1/2] gnu: Add python-liblarch.
(name . Vinicius Monego)(address . monego@posteo.net)(address . 43434-done@debbugs.gnu.org)
87lfgz6vka.fsf@gnu.org
Hi,

Vinicius Monego <monego@posteo.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/gnome.scm (python-liblarch): New variable.

[...]

Toggle quote (2 lines)
> * gnu/packages/gnome.scm (gtg): New variable.

Applied both, thanks!

Ludo’.
Closed
?