[PATCH] gnu: Add libsoundio.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal

Debbugs page

Alexandros Theodotou wrote 4 years ago
(address . guix-patches@gnu.org)
ba8632337e6f8676da41b37d34a86a81ce407985.camel@zrythm.org
Hi,

This patch adds libsoundio.

Thanks,
Alex
From bca9b2fb17e63a60b70f6659272b1bba884aa9e7 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Tue, 15 Sep 2020 10:17:15 +0100
Subject: [PATCH] gnu: Add libsoundio.

* gnu/packages/audio.scm (libsoundio): New variable.
---
gnu/packages/audio.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 38ee4f8bcc..0b71901ff5 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4464,6 +4464,36 @@ supports both of ID3v1/v2 and APEv2 tags.")
(home-page "http://tausoft.org/")
(license license:gpl2+)))
+(define-public libsoundio
+ (package
+ (name "libsoundio")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/andrewrk/libsoundio")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12l4rvaypv87vigdrmjz48d4d6sq4gfxf5asvnc4adyabxb73i4x"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests included
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("jack" ,jack-1)
+ ("pulseaudio" ,pulseaudio)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://libsound.io")
+ (synopsis "C library for real-time audio input and output")
+ (description "libsoundio is a C library providing audio input and output.
+The API is suitable for real-time software such as digital audio workstations
+as well as consumer software such as music players.")
+ (license license:expat)))
+
(define-public redkite
(package
(name "redkite")
--
2.27.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl9gh78ACgkQAi6uQjE9
cPPpnQf+N8R0aZrJKXXARFL1loUATkWWMTvyt6vESWhO2Jnyk2Bs4gM4UOChnCwW
Q2LMQC7HTWhNpve4UAFTohbxadCYRi+jlfkuZ8poJs+Bf+QoPQWhOMyywM0SHgXW
qMkHBTdV8vpioWIws4CXPLsbRdzveHT0EQiu7slcxiSAR5jKSaGEPKunDpAMDihF
Lx5N0U6UfAvkyU+LyU9F8BIK7GfJonBa1Ga7lxaU+J//cdkuUcJm+rYS7l9Epvzz
jhE3/Aodt67k4BbWgtgl8xBXTzhZphc0ouTRnSde06ZjCQB/GiB+f+9j4AbqiLKv
e318dRf9eapjiHR/vs33jVBOOBtrRw==
=fvcv
-----END PGP SIGNATURE-----


Mathieu Othacehe wrote 4 years ago
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 43417-done@debbugs.gnu.org)
87eemzz19r.fsf@gnu.org
Hello,

Toggle quote (2 lines)
> * gnu/packages/audio.scm (libsoundio): New variable.

I fixed the indentation and pushed.

Thanks,

Mathieu
--
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43417@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43417
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help