[PATCH 0/1] New package quickjs

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • rprior
Owner
unassigned
Submitted by
rprior
Severity
normal
R
R
rprior wrote on 14 Sep 2020 03:11
(address . guix-patches@gnu.org)(name . Ryan Prior)(address . rprior@protonmail.com)
20200914011130.20880-1-rprior@protonmail.com
From: Ryan Prior <rprior@protonmail.com>

This patch adds Fabrice Bellard and Charlie Gordon's quickjs, a complete Javscript ES2020 implementation that fits inside a megabyte.

Ryan Prior (1):
gnu: Add quickjs.

gnu/packages/javascript.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

--
2.17.1
R
R
rprior wrote on 14 Sep 2020 03:13
[PATCH 1/1] gnu: Add quickjs.
(address . 43391@debbugs.gnu.org)(name . Ryan Prior)(address . rprior@protonmail.com)
20200914011325.21015-1-rprior@protonmail.com
From: Ryan Prior <rprior@protonmail.com>

* gnu/packages/javascript.scm (quickjs): New variable.
---
gnu/packages/javascript.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/javascript.scm b/gnu/packages/javascript.scm
index fbc7388f3d..9c6c95bd70 100644
--- a/gnu/packages/javascript.scm
+++ b/gnu/packages/javascript.scm
@@ -447,3 +447,33 @@ to use, and is very similar to Lua. There is no need to interact with byzantine
C++ template mechanisms, or worry about marking and unmarking garbage collection
roots, or wrestle with obscure build systems.")
(license license:isc)))
+
+(define-public quickjs
+ (package
+ (name "quickjs")
+ (version "2020-09-06")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://bellard.org/quickjs/quickjs-"
+ version ".tar.xz"))
+ (sha256
+ (base32 "05vpnnzmws7plnwsnk2brwf7whyj84l5xl0iahi1xdn6rpla6880"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list "prefix="
+ (string-append "DESTDIR=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'check
+ (lambda _
+ (invoke "make" "microbench"))))))
+ (home-page "https://bellard.org/quickjs/")
+ (synopsis "Small embeddable Javascript engine")
+ (description "QuickJS supports the ES2020 specification including modules,
+asynchronous generators, proxies, BigInt and BigDecimal. It can compile
+Javascript sources to executables with no external dependency. It includes a
+command line interpreter with contextual colorization implemented in
+Javascript and a small built-in standard library with C library wrappers.")
+ (license license:expat)))
--
2.17.1
M
M
Mathieu Othacehe wrote on 14 Sep 2020 16:15
(address . rprior@protonmail.com)(address . 43391-done@debbugs.gnu.org)
87r1r45tsg.fsf@gnu.org
Hello,

Toggle quote (2 lines)
> + (base32 "05vpnnzmws7plnwsnk2brwf7whyj84l5xl0iahi1xdn6rpla6880"))))

I wrapped this line and pushed.

Thanks,

Mathieu
Closed
?