[PATCH] gnu: josm: Fix formatting and install more files.

  • Done
  • quality assurance status badge
Details
2 participants
  • Julien Lepiller
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 4 years ago
(address . guix-patches@gnu.org)
20200913084323.32740-1-mail@cbaines.net
This means that JOSM appears in the GNOME Shell menu.

* gnu/packages/geo.scm (josm)[source]: Replace tab character.
[arguments]: Reduce line length, and add install-share-directories phase.
---
gnu/packages/geo.scm | 18 ++++++++++++++++--
1 file changed, 16 insertions(+), 2 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index ab1d691c6c..a896364c35 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1290,7 +1290,7 @@ to the OSM opening hours specification.")
(modules '((guix build utils)))
(snippet
'(begin
- (for-each delete-file (find-files "." ".*.jar$"))
+ (for-each delete-file (find-files "." ".*.jar$"))
#t))))
(build-system ant-build-system)
(native-inputs
@@ -1339,7 +1339,8 @@ to the OSM opening hours specification.")
(filter
(lambda (s)
(let ((source (assoc-ref inputs "source")))
- (not (equal? (substring s 0 (string-length source)) source))))
+ (not (equal? (substring s 0 (string-length source))
+ source))))
(string-split (getenv "CLASSPATH") #\:))
":"))
#t))
@@ -1386,6 +1387,19 @@ to the OSM opening hours specification.")
"Is-Local-Build: true\n"
"Build-Date: 1970-01-01 00:00:00 +0000\n"))))
#t))
+ (add-after 'install 'install-share-directories
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (share-directories '("applications" "icons" "man" "menu"
+ "metainfo" "mime" "pixmaps")))
+ (for-each (lambda (directory)
+ (copy-recursively (string-append
+ "native/linux/tested/usr/share/"
+ directory)
+ (string-append
+ out "/share/" directory)))
+ share-directories))
+ #t))
(add-after 'install 'install-bin
(lambda* (#:key outputs inputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
--
2.28.0
Julien Lepiller wrote 4 years ago
42CF4931-2004-40A2-9EA2-9411F9185CF2@lepiller.eu
LGTM! Do you already have a copyright line?

Le 13 septembre 2020 04:43:23 GMT-04:00, Christopher Baines <mail@cbaines.net> a écrit :
Toggle quote (59 lines)
>This means that JOSM appears in the GNOME Shell menu.
>
>* gnu/packages/geo.scm (josm)[source]: Replace tab character.
>[arguments]: Reduce line length, and add install-share-directories
>phase.
>---
> gnu/packages/geo.scm | 18 ++++++++++++++++--
> 1 file changed, 16 insertions(+), 2 deletions(-)
>
>diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
>index ab1d691c6c..a896364c35 100644
>--- a/gnu/packages/geo.scm
>+++ b/gnu/packages/geo.scm
>@@ -1290,7 +1290,7 @@ to the OSM opening hours specification.")
> (modules '((guix build utils)))
> (snippet
> '(begin
>- (for-each delete-file (find-files "." ".*.jar$"))
>+ (for-each delete-file (find-files "." ".*.jar$"))
> #t))))
> (build-system ant-build-system)
> (native-inputs
>@@ -1339,7 +1339,8 @@ to the OSM opening hours specification.")
> (filter
> (lambda (s)
> (let ((source (assoc-ref inputs "source")))
>- (not (equal? (substring s 0
>(string-length source)) source))))
>+ (not (equal? (substring s 0
>(string-length source))
>+ source))))
> (string-split (getenv "CLASSPATH") #\:))
> ":"))
> #t))
>@@ -1386,6 +1387,19 @@ to the OSM opening hours specification.")
> "Is-Local-Build: true\n"
> "Build-Date: 1970-01-01 00:00:00 +0000\n"))))
> #t))
>+ (add-after 'install 'install-share-directories
>+ (lambda* (#:key outputs #:allow-other-keys)
>+ (let ((out (assoc-ref outputs "out"))
>+ (share-directories '("applications" "icons" "man"
>"menu"
>+ "metainfo" "mime" "pixmaps")))
>+ (for-each (lambda (directory)
>+ (copy-recursively (string-append
>+
>"native/linux/tested/usr/share/"
>+ directory)
>+ (string-append
>+ out "/share/"
>directory)))
>+ share-directories))
>+ #t))
> (add-after 'install 'install-bin
> (lambda* (#:key outputs inputs #:allow-other-keys)
> (let* ((out (assoc-ref outputs "out"))
>--
>2.28.0
Attachment: file
Christopher Baines wrote 4 years ago
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 43368-done@debbugs.gnu.org)
87v9ghhniw.fsf@cbaines.net
Julien Lepiller <julien@lepiller.eu> writes:

Toggle quote (2 lines)
> LGTM! Do you already have a copyright line?

Great, I didn't have a copyright line in this file, so I've added on and
pushed as 1192ae940434808560b3170107e4ce44855816c3.

Thanks for taking a look,

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl9eD6dfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xd5mQ/8Czj4ZmM24G12F091c2Qn7fLhKvKOyuuA5g/2S80+4x8oALfVqxf6OneU
P9QgZKNPYYSMUtaINcuf1NHNaHFF6D6kw5uWWu5+cup5+ioeled9ZY/sK39PIuBa
tCKdbIVo/gCwofZhYxGUeyse1ARcflP/8J1mAHm+FkiXxxNTYLWaaHe3FCHQ9qkX
wcah/bwBpj2J0ZWfmIVB93eqQPHObX9GItp/puxvqnB2OWEu2uHw4EWw6KlRL3Ji
H3S33XR84tBbDl9VKabpeb8hnnK00Smp7U/7LBiuUL+aZuebmzuShsJc68n11E88
ia4KZa4e09vKgdqm2yd2JYQCtCesA4eBVj0fDHpSCVb8Slmc0S7ucTeUvN0RdLqH
J7QAy5LZPYVwPQxRUL1mZinEnTL07PvZ9W+BYc6tNIvTcYZYBRNOcUC0PIjmRc2F
cbVrkQvheSzYqrIpu6lb+8eM3CUzv2FT9kRlh3/ragb+XHSFlIOPBamfH9mzJMcl
0aED2yxsHw/nVy1vJbM/xtdgZD8GVOmNHBY6QKQrF91G+b5/E2jlK66L66fqt6dz
7KqwForDXufn/X21uC88DnVeNSgFPoveyK3Ee0BIgup4l1M6c1O6c1ounyygpmAl
8S3bkIb1zNP28zjDRIz5Oo+ZiYD9Q+NfHNMEAe5OCAGV7tXRKA8=
=CrEU
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43368@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43368
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help