[PATCH 0/3] Fix #43303 GCC package name

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 11 Sep 2020 18:06
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20200911160612.21850-1-zimon.toutoune@gmail.com
Dear,

As described in #43303 [1], the package gcc-toolchain providing the complete
GCC compilation toolchain is not easy to reach; even the manual has a
dedicated section [2].

Commit f17e1802ec325e5cc86d4908f05ac69aafdf39da fixes:

guix install gcc

which will install instead gcc-toolchain, the expected compilation package.


However, there are still discoverability issues, e.g.,

guix search gcc | recsel -C -P name | head

reports first the package libgccjit and second gccgo, which have both too
general synopsis and description. The 2 first patches try to improve the
situation.

Then, because the file gnu/packages/gcc.scm exists and the relevance scoring
function weights the filename too, the query "guix search gcc" artificially
ranks first libgccjit and gccgo. Therefore the third patch fixes this
corner-case.


All the best,
simon

zimoun (3):
gnu: libgccjit: Reword synopsis and description.
gnu: gccgo: Reword synopsis and description.
gnu: gcc-toolchain: Reword description.

gnu/packages/commencement.scm | 3 ++-
gnu/packages/gcc.scm | 20 ++++++++++++++++++--
2 files changed, 20 insertions(+), 3 deletions(-)


base-commit: 1c87536287837c19b6a7d0b5df43fdcab7e5a26e
--
2.28.0
Z
Z
zimoun wrote on 11 Sep 2020 18:07
[PATCH 1/3] gnu: libgccjit: Reword synopsis and description.
(address . 43342@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20200911160800.22518-1-zimon.toutoune@gmail.com
Reported by Jeffrey Walton <noloader@gmail.com>.

* gnu/packages/gcc.scm: (libgccjit)[synopsis,description]: Reword.
---
gnu/packages/gcc.scm | 12 +++++++++++-
1 file changed, 11 insertions(+), 1 deletion(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index a39ac3b84c..c74477aed9 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2018, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
+;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -759,7 +760,16 @@ as the 'native-search-paths' field."
(for-each delete-file
(find-files (string-append (assoc-ref outputs "out") "/bin")
".*(c\\+\\+|cpp|g\\+\\+|gcov|gcc|gcc-.*)"))
- #t))))))))
+ #t))))))
+ (synopsis "GCC library generating machine code on-the-fly at runtime")
+ (description
+ "This package is part of the GNU Compiler Collection and provides an
+embeddable library for generating machine code on-the-fly at runtime. This
+shared library can then be dynamically-linked into bytecode interpreters and
+other such programs that want to generate machine code on-the-fly at run-time.
+It can also be used for ahead-of-time code generation for building standalone
+compilers. The just-in-time (jit) part of the name is now something of a
+misnomer.")))
(define-public gccgo-4.9
--
2.28.0
Z
Z
zimoun wrote on 11 Sep 2020 18:07
[PATCH 2/3] gnu: gccgo: Reword synopsis and description.
(address . 43342@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20200911160800.22518-2-zimon.toutoune@gmail.com
Reported by Jeffrey Walton <noloader@gmail.com>.

* gnu/packages/gcc.scm: (gccgo-4.9): Add synopsis and description
---
gnu/packages/gcc.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index c74477aed9..4d5aaa7070 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -773,7 +773,13 @@ misnomer.")))
(define-public gccgo-4.9
- (custom-gcc gcc-4.9 "gccgo" '("go")
+ (custom-gcc (package
+ (inherit gcc-4.9)
+ (synopsis "Go frontend to GCC")
+ (description
+ "This package is part of the GNU Compiler Collection and
+provides the GNU compiler for the Go programming language."))
+ "gccgo" '("go")
%generic-search-paths
;; Suppress the separate "lib" output, because otherwise the
;; "lib" and "out" outputs would refer to each other, creating
--
2.28.0
Z
Z
zimoun wrote on 11 Sep 2020 18:08
[PATCH 3/3] gnu: gcc-toolchain: Reword description.
(address . 43342@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20200911160800.22518-3-zimon.toutoune@gmail.com
* gnu/packages/commencement.scm (make-gcc-toolchain)[description]: Reword.
---
gnu/packages/commencement.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index cc86d06c65..565799c611 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3861,7 +3861,8 @@ COREUTILS-FINAL vs. COREUTILS, etc."
(description
"This package provides a complete GCC tool chain for C/C++ development to
be installed in user profiles. This includes GCC, as well as libc (headers and
-binaries, plus debugging symbols in the @code{debug} output), and Binutils.")
+binaries, plus debugging symbols in the @code{debug} output), and Binutils. GCC
+is the GNU Compiler Collection.")
(home-page "https://gcc.gnu.org/")
(outputs '("out" "debug" "static"))
--
2.28.0
L
L
Ludovic Courtès wrote on 13 Sep 2020 23:12
Re: [bug#43342] [PATCH 0/3] Fix #43303 GCC package name
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 43342-done@debbugs.gnu.org)
87pn6p9y9l.fsf@gnu.org
Hi zimoun,

zimoun <zimon.toutoune@gmail.com> skribis:

Toggle quote (4 lines)
> gnu: libgccjit: Reword synopsis and description.
> gnu: gccgo: Reword synopsis and description.
> gnu: gcc-toolchain: Reword description.

Applied all 3 patches. We’re doing SEO! :-)

Thanks,
Ludo’.
Closed
Z
Z
zimoun wrote on 14 Sep 2020 12:40
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 43342-done@debbugs.gnu.org)
CAJ3okZ3B9aNTzvjbdqRck0QTdA0Utgn5hPULc07hGCghNBf8Ng@mail.gmail.com
Hi,

Thank you for the quick review. :-)

On Sun, 13 Sep 2020 at 23:12, Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (2 lines)
> Applied all 3 patches. We’re doing SEO! :-)

Yeah! :-)
Waiting for improvement of 'relevance'... my long overdue.

Cheers,
simon
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43342@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43342
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch