[PATCH] gnu: Add lsp-dsp-lib.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Efraim Flashner
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal

Debbugs page

Alexandros Theodotou wrote 5 years ago
(address . guix-patches@gnu.org)
9160c83dd3e513eb0f73b6a8b22ee78323fd2555.camel@zrythm.org
Hi,

This patch adds lsp-dsp-lib.

Thanks,
Alex
From 8708b830c3be565c6ada9cb1b6042acc5174f86f Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Thu, 10 Sep 2020 16:17:22 +0100
Subject: [PATCH] gnu: Add lsp-dsp-lib.

* gnu/packages/audio.scm (lsp-dsp-lib): New variable.
---
gnu/packages/audio.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index eecbf5260b..1d49482ee3 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4790,6 +4790,37 @@ edited, converted, compressed and saved.")
,@(package-inputs ztoolkit)))
(synopsis "ZToolkit with SVG support")))
+(define-public lsp-dsp-lib
+ (package
+ (name "lsp-dsp-lib")
+ (version "0.5.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/sadko4u/lsp-dsp-lib/"
+ "releases/download/lsp-dsp-lib-" version
+ "/lsp-dsp-lib-" version "-src.tar.gz"))
+ (sha256
+ (base32
+ "07w3d2i0z0xmvi1ngcgs7lc5a0da8jvf7rv4dnjk01md43b7fkh1"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (invoke "make" "config" (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #t)))))
+ (home-page "https://github.com/sadko4u/lsp-dsp-lib")
+ (synopsis "Digital signal processing library")
+ (description "The LSP DSP library provides a set of functions that perform
+SIMD-optimized computing on several hardware architectures. All functions
+currently operate on IEEE-754 single-precision floating-point numbers.")
+ (license license:lgpl3+)))
+
(define-public codec2
(package
(name "codec2")
--
2.27.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl9aRAsACgkQAi6uQjE9
cPMoQwf+LzIhmVH1Ge6Bn0j2RjVMEeSrBnXbVBTKN9SENhwY5YjgZL/ZnVNlWXXS
GQ3CWYGy7OrVZTWDuyP6nHIAz5eBJWk5dnD0UxffYNF5YaLflqeV/DCo2nGjRhRv
Jz5YyDrlKsv3Pp5LHdezzaYLTFF8wGakXHSGRYyCepobaqnZOZJhwx5WF9oUKBij
d7uGl1mWDX/h2+Tk78A7uyOQRkQnZgluKH1d9lyz8Kdjv9evBBCEjO2Q/dqCs3JN
qjTPRgJ7r3WTn22fDXzDTL5LThRXGRla4vGJ+H1bKUsVNyrJrc0IBrfslgnvPy2U
F4DAzD/bnHMZZEsvvvmNfZQr8EMVcw==
=ojpk
-----END PGP SIGNATURE-----


Efraim Flashner wrote 4 years ago
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 43310@debbugs.gnu.org)
20200914140203.GB17272@E5400
On Thu, Sep 10, 2020 at 04:19:39PM +0100, Alexandros Theodotou wrote:
Toggle quote (7 lines)
> Hi,
>
> This patch adds lsp-dsp-lib.
>
> Thanks,
> Alex

It looks like everything in the modules directory is vendored. Can we
build it separately and link it in? Also, I saw that there were a few
test directories. Are there tests to be built?

Toggle quote (37 lines)
> From 8708b830c3be565c6ada9cb1b6042acc5174f86f Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Thu, 10 Sep 2020 16:17:22 +0100
> Subject: [PATCH] gnu: Add lsp-dsp-lib.
>
> * gnu/packages/audio.scm (lsp-dsp-lib): New variable.
> ---
> gnu/packages/audio.scm | 31 +++++++++++++++++++++++++++++++
> 1 file changed, 31 insertions(+)
>
> diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
> index eecbf5260b..1d49482ee3 100644
> --- a/gnu/packages/audio.scm
> +++ b/gnu/packages/audio.scm
> @@ -4790,6 +4790,37 @@ edited, converted, compressed and saved.")
> ,@(package-inputs ztoolkit)))
> (synopsis "ZToolkit with SVG support")))
>
> +(define-public lsp-dsp-lib
> + (package
> + (name "lsp-dsp-lib")
> + (version "0.5.8")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/sadko4u/lsp-dsp-lib/"
> + "releases/download/lsp-dsp-lib-" version
> + "/lsp-dsp-lib-" version "-src.tar.gz"))
> + (sha256
> + (base32
> + "07w3d2i0z0xmvi1ngcgs7lc5a0da8jvf7rv4dnjk01md43b7fkh1"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:tests? #f ; no tests
> + #:make-flags
> + (list "CC=gcc")

This can be cc-for-target
(list (string-append "CC=" ,(cc-for-target)))

Toggle quote (7 lines)
> + #:phases
> + (modify-phases %standard-phases
> + (replace 'configure
> + (lambda _
> + (invoke "make" "config" (string-append "PREFIX=" (assoc-ref %outputs "out")))
> + #t)))))

We'd rather not use %outputs if possible, but to add it to the lambda.
Also invoke already returns #t

(lambda* (#:key outputs #:allow-other-keys)
(invoke "make" "config"
(string-append "PREFIX=" (assoc-ref outputs "out"))))))))

Toggle quote (17 lines)
> + (synopsis "Digital signal processing library")
> + (description "The LSP DSP library provides a set of functions that perform
> +SIMD-optimized computing on several hardware architectures. All functions
> +currently operate on IEEE-754 single-precision floating-point numbers.")
> + (license license:lgpl3+)))
> +
> (define-public codec2
> (package
> (name "codec2")
> --
> 2.27.0
>




--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl9fd9gACgkQQarn3Mo9
g1H3dhAAuzRJPYEhaHcfUnJvnUzOnfLXs8Md8t1BD+QIb3XTwadUw6my9ADmsNah
wf90LCHuNp9btHKdTuPApKmazxXT5q8FMc7CDd2qL4N0KOH+VOsQzJUlL4zBq+3u
9zz/2ABQOt6vBg1t/fPL12851g7fRGV1rA2RwkRIlb7ZL8CB+pXXBSDH/050TfwH
TJ+bsSTQdfJtAReCyogA6KfPGZp2pAMui7fDhWCPI4INtMe6figZHrS7L7zI8+iw
hPIsEkbo1e8b7SAQcetNlILoyBfV0vPQ/YFKs9qVp3QgjXddIEBtruQp2et/jhqp
hAutIB0er24XnIwS4cs1fktIrQY9rnacWhKw3JkZXkfwLZJn3FKgEVEoSV8rHPwp
+tuu63GBv3ZEViRICuuQvTPOBjVWl6KRLm0Cri2+NKWkGXcKfLkdwG8NFN7p/vHC
tKitlSIlxlsNR/PJwv18rlTRudeiMCOsTNsETBX0b0wqyL90KDtIhfI/fHRfKCda
n3vAxpOUYxnlKo5pew5YbpF1RO2U2eVJ/3aGWO/VjDnv2GEaalHLjpWbXYCO166O
iJhTqXUjeGKQTLAjrJy3idbT4dNFrmb0JsydGAC5jTdrMlyefjxb6GgX3ydEICiJ
PcEYoG9VILKUEqnhGt21ETLasR2rkMu2E3qzRYD3z72bY/0Peuw=
=/opJ
-----END PGP SIGNATURE-----


Alexandros Theodotou wrote 4 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 43310@debbugs.gnu.org)
3128d450cf954008cadc7c24d9817c5e88a6b4ea.camel@zrythm.org
Hi Efraim,

Thanks for the review.

On Mon, 2020-09-14 at 17:02 +0300, Efraim Flashner wrote:
Toggle quote (3 lines)
> It looks like everything in the modules directory is vendored. Can we
> build it separately and link it in?

I asked the author something similar a while back
I think the build system just expects those modules to be there as
sources - not sure if they even build anything to link to. BTW, this is
my initial patch, before the author started to provide an all-inclusive
tarball in the github releases page:

```scheme
(define-public lsp-dsp-lib
(package
(name "lsp-dsp-lib")
(version "0.5.6")
(source
(origin
(method git-fetch)
(uri (git-reference
(commit (string-append "lsp-dsp-lib-" version))))
(file-name (git-file-name name version))
(sha256
(base32
"1n5qp9bjsgg1ziy9mqnx034qlzbsp7yl473vk9aigzkyj883dfpj"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests
#:make-flags
(list "CC=gcc")
#:phases
(modify-phases %standard-phases
(add-before 'build 'copy-modules
(lambda* (#:key inputs #:allow-other-keys)
(copy-recursively (assoc-ref inputs "lsp-common-lib")
"modules/lsp-common-lib")
(copy-recursively (assoc-ref inputs "lsp-test-fw")
"modules/lsp-test-fw")
#t))
(replace 'configure
(lambda _
(invoke "make" "config" (string-append "PREFIX=" (assoc-
ref %outputs "out")))
#t)))))
(inputs
`(("lsp-common-lib" ,(origin
(method git-fetch)
(uri (git-reference
(commit "lsp-common-lib-1.0.7")))
(file-name (git-file-name name version))
(sha256
(base32
"1alxv2ryivbj122gryxrrvyicw6zgbdk15wp010lrq6r1nj7mjxh"))))
("lsp-test-fw" ,(origin
(method git-fetch)
(uri (git-reference
(commit "lsp-test-fw-1.0.5")))
(file-name (git-file-name name version))
(sha256
(base32
"0n4ircp9bgzwfaa6023bvfsb90qvl2iawbihnwivr5id1js5jq3p"))))
))
(synopsis "Digital signal processing library")
(description "The LSP DSP library provides a set of functions that
perform
SIMD-optimized computing on several hardware architectures. All
functions
currently operate on IEEE-754 single-precision floating-point
numbers.")
(license license:lgpl3+)))
```

Toggle quote (3 lines)
> Also, I saw that there were a few
> test directories. Are there tests to be built?

Not sure - I don't see a check/test make target (see `make help`)


Toggle quote (8 lines)
> > + (arguments
> > + `(#:tests? #f ; no tests
> > + #:make-flags
> > + (list "CC=gcc")
>
> This can be cc-for-target
> (list (string-append "CC=" ,(cc-for-target)))

ACK

Toggle quote (16 lines)
> > + (modify-phases %standard-phases
> > + (replace 'configure
> > + (lambda _
> > + (invoke "make" "config" (string-append "PREFIX="
> > (assoc-ref %outputs "out")))
> > + #t)))))
>
> We'd rather not use %outputs if possible, but to add it to the
> lambda.
> Also invoke already returns #t
>
> (lambda* (#:key outputs #:allow-other-keys)
> (invoke "make" "config"
> (string-append "PREFIX=" (assoc-ref outputs
> "out"))))))))

ACK

Please find the updated patch attached.

Thanks,
Alex
From 2efb2e2dfbfe4cd82b90fef44f6d6919a5cac865 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Mon, 14 Sep 2020 15:16:30 +0100
Subject: [PATCH] gnu: Add lsp-dsp-lib.

* gnu/packages/audio.scm (lsp-dsp-lib): New variable.
---
gnu/packages/audio.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 5e6008f31e..38ee4f8bcc 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4778,6 +4778,37 @@ edited, converted, compressed and saved.")
,@(package-inputs ztoolkit)))
(synopsis "ZToolkit with SVG support")))
+(define-public lsp-dsp-lib
+ (package
+ (name "lsp-dsp-lib")
+ (version "0.5.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/sadko4u/lsp-dsp-lib/"
+ "releases/download/lsp-dsp-lib-" version
+ "/lsp-dsp-lib-" version "-src.tar.gz"))
+ (sha256
+ (base32
+ "07w3d2i0z0xmvi1ngcgs7lc5a0da8jvf7rv4dnjk01md43b7fkh1"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target)))
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "make" "config"
+ (string-append "PREFIX=" (assoc-ref outputs "out"))))))))
+ (home-page "https://github.com/sadko4u/lsp-dsp-lib")
+ (synopsis "Digital signal processing library")
+ (description "The LSP DSP library provides a set of functions that perform
+SIMD-optimized computing on several hardware architectures. All functions
+currently operate on IEEE-754 single-precision floating-point numbers.")
+ (license license:lgpl3+)))
+
(define-public codec2
(package
(name "codec2")
--
2.27.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl9fe4wACgkQAi6uQjE9
cPP6HAf/ZmSqLmk7idKwAKdkHRuweEzUEqX2S29UU4l4gBGrzpaibyCymkGfdxic
yTbIu6ZyUGVS+d1pu9G79e/t4MG5cojnGkycobQK9n550Za8zG3qQ+oqo5Hv/PdS
GM2RvYqGFfJuiySw8wVMaBIH+ousToftr8R0dF6V5JrvAGRfm22yfbYMHG0oq+Y+
G8VVRRzSqkiGx1Pt3ponrMQDfNKI+E29zAIZYAikfOs2qw+jc4Svpf5+XxUKVUvD
GGMapvXOkwYBhQU21NPTZQvK+X5XAEUFpeaYV0ycI/p6QgxTf+efFzSXDkbK8FVU
8vZPH7dH24ukRoKy8WDfmBTH4rUI1w==
=WKL2
-----END PGP SIGNATURE-----


Efraim Flashner wrote 4 years ago
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 43310-done@debbugs.gnu.org)
20200914143541.GC17272@E5400
On Mon, Sep 14, 2020 at 03:17:48PM +0100, Alexandros Theodotou wrote:
Toggle quote (80 lines)
> Hi Efraim,
>
> Thanks for the review.
>
> On Mon, 2020-09-14 at 17:02 +0300, Efraim Flashner wrote:
> > It looks like everything in the modules directory is vendored. Can we
> > build it separately and link it in?
>
> I asked the author something similar a while back
> https://github.com/sadko4u/lsp-dsp-lib/issues/1#issuecomment-676517050
> I think the build system just expects those modules to be there as
> sources - not sure if they even build anything to link to. BTW, this is
> my initial patch, before the author started to provide an all-inclusive
> tarball in the github releases page:
>
> ```scheme
> (define-public lsp-dsp-lib
> (package
> (name "lsp-dsp-lib")
> (version "0.5.6")
> (source
> (origin
> (method git-fetch)
> (uri (git-reference
> (url "https://github.com/sadko4u/lsp-dsp-lib")
> (commit (string-append "lsp-dsp-lib-" version))))
> (file-name (git-file-name name version))
> (sha256
> (base32
> "1n5qp9bjsgg1ziy9mqnx034qlzbsp7yl473vk9aigzkyj883dfpj"))))
> (build-system gnu-build-system)
> (arguments
> `(#:tests? #f ; no tests
> #:make-flags
> (list "CC=gcc")
> #:phases
> (modify-phases %standard-phases
> (add-before 'build 'copy-modules
> (lambda* (#:key inputs #:allow-other-keys)
> (copy-recursively (assoc-ref inputs "lsp-common-lib")
> "modules/lsp-common-lib")
> (copy-recursively (assoc-ref inputs "lsp-test-fw")
> "modules/lsp-test-fw")
> #t))
> (replace 'configure
> (lambda _
> (invoke "make" "config" (string-append "PREFIX=" (assoc-
> ref %outputs "out")))
> #t)))))
> (inputs
> `(("lsp-common-lib" ,(origin
> (method git-fetch)
> (uri (git-reference
> (url "https://github.com/sadko4u/lsp-common-lib")
> (commit "lsp-common-lib-1.0.7")))
> (file-name (git-file-name name version))
> (sha256
> (base32
> "1alxv2ryivbj122gryxrrvyicw6zgbdk15wp010lrq6r1nj7mjxh"))))
> ("lsp-test-fw" ,(origin
> (method git-fetch)
> (uri (git-reference
> (url "https://github.com/sadko4u/lsp-test-fw")
> (commit "lsp-test-fw-1.0.5")))
> (file-name (git-file-name name version))
> (sha256
> (base32
> "0n4ircp9bgzwfaa6023bvfsb90qvl2iawbihnwivr5id1js5jq3p"))))
> ))
> (home-page "https://github.com/sadko4u/lsp-dsp-lib")
> (synopsis "Digital signal processing library")
> (description "The LSP DSP library provides a set of functions that
> perform
> SIMD-optimized computing on several hardware architectures. All
> functions
> currently operate on IEEE-754 single-precision floating-point
> numbers.")
> (license license:lgpl3+)))
> ```

The current patch looks better. It is the same author and all.

Toggle quote (7 lines)
>
> > Also, I saw that there were a few
> > test directories. Are there tests to be built?
>
> Not sure - I don't see a check/test make target (see `make help`)
>

I didn't see anything either.

Toggle quote (34 lines)
>
> > > + (arguments
> > > + `(#:tests? #f ; no tests
> > > + #:make-flags
> > > + (list "CC=gcc")
> >
> > This can be cc-for-target
> > (list (string-append "CC=" ,(cc-for-target)))
>
> ACK
>
> > > + (modify-phases %standard-phases
> > > + (replace 'configure
> > > + (lambda _
> > > + (invoke "make" "config" (string-append "PREFIX="
> > > (assoc-ref %outputs "out")))
> > > + #t)))))
> >
> > We'd rather not use %outputs if possible, but to add it to the
> > lambda.
> > Also invoke already returns #t
> >
> > (lambda* (#:key outputs #:allow-other-keys)
> > (invoke "make" "config"
> > (string-append "PREFIX=" (assoc-ref outputs
> > "out"))))))))
>
> ACK
>
> Please find the updated patch attached.
>
> Thanks,
> Alex

Thanks! Patch pushed.


--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl9ff7oACgkQQarn3Mo9
g1FJ1g/9G0XxgIDCV3U0HG/eftQj6AuIEzU/7JbymzJbVLZ/vzoiXpE4eNNA/jbf
dvO4B85sLUL4dhWOAvIJrQZGw5aoKGPhiNAUwlJ6Kl2jNnaxOkr/zu5cKDjEMKoi
eQjT/DqbCRAKWN0VdnXGqc1Xci/wnsOI0H+DxVUQHbFNDvlIUj+A/towdEOKD6FP
wfkN9BfKDhdaC2P0+bc5oeFpEqBic8W01G+SRH9OLG9eWuz6RBiV7zl5leO9aTjo
VnEXTnztFf3cUhqwV5fifqpnXWOvzvzMXbSwAc5Eyz2i/lrlZgjtiVDawd6UtNgo
EWGaK+uKuqTLn1VDa5T4taGhqwhPziNMjeF8/uXqrfdrVjlEX9Uk2m3CJucJMqvP
KVTwyE4lFjMDHJPpf2nw70xxlmxCqXx0Xv/RHAZs9QkLi6HUsRgMLcDqi+vCQQAY
MsimM7xXlwL5IkB3KwMYr3Piu0bA12bL/hHcAu2jB7g6x5dcjvLDjHbU/PYnb9p2
QPGS118qDC/+p24X7Lls4dF4yqV2CByBl1VSWbkkCfoRYhwkbKbAYjAAxx25Ucwz
zg4DHDohJ63PBh7jFAsNaLhjjlo++iYo4PWa42cE+4lSyBEFZPTd7AR6YxfCDzpC
G0X9/CFflyXSP4WtLjg/ioQ+YGci1klCe2HEG3+YCyBK2wbkDfU=
=NSCD
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43310@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43310
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help