[PATCH] gnu: emacs-djvu: Add needed inputs

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Ludovic Courtès
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 5 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR1001MB210554702B66069A17BCF5D6C5260@DM5PR1001MB2105.namprd10.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-djvu): Add needed inputs
---
gnu/packages/emacs-xyz.scm | 24 +++++++++++++++++++++---
1 file changed, 21 insertions(+), 3 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0b1c79de79..6138ccc27a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -118,6 +118,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
#:use-module (gnu packages dictionaries)
+ #:use-module (gnu packages djvu)
#:use-module (gnu packages emacs)
#:use-module (gnu packages guile)
#:use-module (gnu packages gtk)
@@ -2456,13 +2457,30 @@ filters, new key bindings and faces. It can be enabled by
(sha256
(base32 "0njgyx09q225hliacsnjk8wallg5i6xkz6bj501pb05nwqfbvfk7"))))
(build-system emacs-build-system)
+ (inputs `(("djview" ,djview)
+ ("djvulibre" ,djvulibre)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((file "djvu.el")
+ (djview (assoc-ref inputs "djview"))
+ (djvulibre (assoc-ref inputs "djvulibre")))
+ ;; Specify the absolute executable locations.
+ (chmod file #o644)
+ (substitute* file
+ (("\"djvused\"") (string-append "\"" djvulibre "/bin/djvused\""))
+ (("\"djvm\"") (string-append "\"" djvulibre "/bin/djvm\""))
+ (("\"ddjvu\"") (string-append "\"" djvulibre "/bin/ddjvu\"")))
+ (emacs-substitute-variables file
+ ("djvu-djview-command" (string-append djview "/bin/djview"))))
+ #t)))))
(home-page "http://elpa.gnu.org/packages/djvu.html")
(synopsis "Edit and view Djvu files via djvused")
(description
"This package is a front end for the command-line program djvused from
-DjVuLibre, see @url{http://djvu.sourceforge.net/}. It assumes you have the
-programs @command{djvused}, @command{djview}, @command{ddjvu}, and
-@command{djvm} installed.")
+DjVuLibre, see @url{http://djvu.sourceforge.net/}.")
(license license:gpl3+)))
(define-public emacs-pabbrev
--
2.28.0
Ludovic Courtès wrote 4 years ago
(address . Morgan.J.Smith@outlook.com)(address . 43287-done@debbugs.gnu.org)
87v9gh8iy1.fsf@gnu.org
Hi,

Morgan.J.Smith@outlook.com skribis:

Toggle quote (4 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/emacs-xyz.scm (emacs-djvu): Add needed inputs

I tweaked the commit message to mention the new ‘inputs’ and ‘arguments’
fields.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43287@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43287
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help