[PATCH 0/3] git-annex: Enable WebDAV support and update

  • Done
  • quality assurance status badge
Details
2 participants
  • Kyle Meyer
  • Timothy Sample
Owner
unassigned
Submitted by
Kyle Meyer
Severity
normal

Debbugs page

Kyle Meyer wrote 5 years ago
(address . guix-patches@gnu.org)
20200909021257.8682-1-kyle@kyleam.com
This series updates git-annex to the latest release. Two new inputs are
needed because git-annex no longer supports disabling WebDAV support at build
time.

[1/3] gnu: Add ghc-xml-hamlet.
[2/3] gnu: Add ghc-dav.
[3/3] gnu: git-annex: Update to 8.20200908.

gnu/packages/haskell-apps.scm | 7 ++++---
gnu/packages/haskell-web.scm | 36 +++++++++++++++++++++++++++++++++++
gnu/packages/haskell-xyz.scm | 26 ++++++++++++++++++++++++-
3 files changed, 65 insertions(+), 4 deletions(-)


base-commit: ee7a7c9014f7dd238ab42d15ef3f5f1fe187d1c3
--
2.28.0.618.gf4bc123cb7
Kyle Meyer wrote 5 years ago
[PATCH 1/3] gnu: Add ghc-xml-hamlet.
(address . 43286@debbugs.gnu.org)
20200909021628.9319-1-kyle@kyleam.com
* gnu/packages/haskell-xyz.scm (ghc-xml-hamlet): New variable.
---
gnu/packages/haskell-xyz.scm | 26 +++++++++++++++++++++++++-
1 file changed, 25 insertions(+), 1 deletion(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 08d6580a32..f4af00283c 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -20,7 +20,7 @@
;;; Copyright © 2019 Robert Vollmert <rob@vllmrt.net>
;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
;;; Copyright © 2019,2020 John Soo <jsoo1@asu.edu>
-;;; Copyright © 2019 Kyle Meyer <kyle@kyleam.com>
+;;; Copyright © 2019, 2020 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 JoJo <jo@jo.zone>
@@ -14712,6 +14712,30 @@ (define-public ghc-xml-types
documents.")
(license license:expat)))
+(define-public ghc-xml-hamlet
+ (package
+ (name "ghc-xml-hamlet")
+ (version "0.5.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/xml-hamlet/"
+ "xml-hamlet-" version ".tar.gz"))
+ (sha256
+ (base32 "0jrhcjy7ww59dafg857f2g2df1fw2jmbwcs1q379ph0pc5rxj3lj"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-shakespeare" ,ghc-shakespeare)
+ ("ghc-xml-conduit" ,ghc-xml-conduit)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("ghc-hunit" ,ghc-hunit)))
+ (home-page "https://www.yesodweb.com/")
+ (synopsis "Hamlet-style quasiquoter for XML content")
+ (description "This package provides a type-safe tool for generating XML
+code via quasi-quoting built on top of @code{ghc-shakespeare}.")
+ (license license:bsd-3)))
+
(define-public ghc-yaml
(package
(name "ghc-yaml")
--
2.28.0.618.gf4bc123cb7
Kyle Meyer wrote 5 years ago
[PATCH 2/3] gnu: Add ghc-dav.
(address . 43286@debbugs.gnu.org)
20200909021628.9319-2-kyle@kyleam.com
* gnu/packages/haskell-web.scm (ghc-dav): New variable.
---

`guix lint' flags the homepage with a connection timeout. I haven't had any
luck connecting to it, but I also haven't been able to find anything else that
seems like it'd be appropriate as the homepage.

gnu/packages/haskell-web.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index b9474c973a..98d163566c 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@gmail.com>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2020 Kyle Meyer <kyle@kyleam.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1945,3 +1946,38 @@ (define-public ghc-bower-json
"This package provides a data type and ToJSON/FromJSON instances for
Bower's package manifest file, bower.json.")
(license license:expat)))
+
+(define-public ghc-dav
+ (package
+ (name "ghc-dav")
+ (version "1.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/DAV/DAV-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1isvi4fahq70lzxfz23as7qzkc01g7kba568l6flrgd0j1984fsy"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-case-insensitive" ,ghc-case-insensitive)
+ ("ghc-data-default" ,ghc-data-default)
+ ("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-http-client" ,ghc-http-client)
+ ("ghc-http-client-tls" ,ghc-http-client-tls)
+ ("ghc-http-types" ,ghc-http-types)
+ ("ghc-lens" ,ghc-lens)
+ ("ghc-transformers-base" ,ghc-transformers-base)
+ ("ghc-transformers-compat" ,ghc-transformers-compat)
+ ("ghc-utf8-string" ,ghc-utf8-string)
+ ("ghc-xml-conduit" ,ghc-xml-conduit)
+ ("ghc-xml-hamlet" ,ghc-xml-hamlet)
+ ("ghc-network" ,ghc-network)
+ ("ghc-network-uri" ,ghc-network-uri)
+ ("ghc-optparse-applicative" ,ghc-optparse-applicative)))
+ (home-page "http://floss.scru.org/hDAV")
+ (synopsis "RFC 4918 WebDAV support")
+ (description "This package provides a library for the Web Distributed
+Authoring and Versioning (WebDAV) extensions to HTTP as well an executable,
+@command{hdav}, for command-line operation.")
+ (license license:gpl3)))
--
2.28.0.618.gf4bc123cb7
Kyle Meyer wrote 5 years ago
[PATCH 3/3] gnu: git-annex: Update to 8.20200908.
(address . 43286@debbugs.gnu.org)
20200909021628.9319-3-kyle@kyleam.com
* gnu/packages/haskell-apps.scm (git-annex): Update to 8.20200908.
[arguments]: Drop flag to disable WebDAV because the latest release
unconditionally builds with WebDAV support.
[inputs]: Add ghc-dav.
---
gnu/packages/haskell-apps.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index ddcd5c65ce..32e1c50852 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -339,18 +339,18 @@ (define-public ghcid
(define-public git-annex
(package
(name "git-annex")
- (version "8.20200810")
+ (version "8.20200908")
(source
(origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
"git-annex/git-annex-" version ".tar.gz"))
(sha256
- (base32 "1wy6ckcf5f6m94gakg1504h1zryail3mmj85sglq03s45vawjcg6"))))
+ (base32 "1113inl10f4m0699ba2zglaqlfqvwhqjkqg6r6m1d5rqv5brswb1"))))
(build-system haskell-build-system)
(arguments
`(#:configure-flags
- '("--flags=-Android -Assistant -Pairing -Webapp -WebDAV")
+ '("--flags=-Android -Assistant -Pairing -Webapp")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-shell-for-tests
@@ -448,6 +448,7 @@ (define-public git-annex
("ghc-crypto-api" ,ghc-crypto-api)
("ghc-cryptonite" ,ghc-cryptonite)
("ghc-data-default" ,ghc-data-default)
+ ("ghc-dav" ,ghc-dav)
("ghc-disk-free-space" ,ghc-disk-free-space)
("ghc-dlist" ,ghc-dlist)
("ghc-edit-distance" ,ghc-edit-distance)
--
2.28.0.618.gf4bc123cb7
Timothy Sample wrote 5 years ago
Re: [bug#43286] [PATCH 0/3] git-annex: Enable WebDAV support and update
(name . Kyle Meyer)(address . kyle@kyleam.com)(address . 43286-done@debbugs.gnu.org)
875z8nbkk2.fsf@ngyro.com
Hi Kyle,

Kyle Meyer <kyle@kyleam.com> writes:

Toggle quote (8 lines)
> This series updates git-annex to the latest release. Two new inputs are
> needed because git-annex no longer supports disabling WebDAV support at build
> time.
>
> [1/3] gnu: Add ghc-xml-hamlet.
> [2/3] gnu: Add ghc-dav.
> [3/3] gnu: git-annex: Update to 8.20200908.

Pushed – thanks very much!

Oh, and about the homepage: I also had trouble connecting, and using the
Internet Archive showed that even when it worked (5 years ago) it was
only a link to Hackage and to the Git repo. It might make more sense to
point it to https://salsa.debian.org/clint/DAV, but the other address
is still the project’s Web URL according to the project itself. In the
end, I left it as-is. I sent an email to the maintainer and will adjust
it if and when I hear anything.


-- Tim
Closed
Kyle Meyer wrote 5 years ago
(name . Timothy Sample)(address . samplet@ngyro.com)(address . 43286@debbugs.gnu.org)
874ko6fpmi.fsf@kyleam.com
Timothy Sample writes:

Toggle quote (8 lines)
> Oh, and about the homepage: I also had trouble connecting, and using the
> Internet Archive showed that even when it worked (5 years ago) it was
> only a link to Hackage and to the Git repo. It might make more sense to
> point it to <https://salsa.debian.org/clint/DAV>, but the other address
> is still the project’s Web URL according to the project itself. In the
> end, I left it as-is. I sent an email to the maintainer and will adjust
> it if and when I hear anything.

All right, thank you!
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43286@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43286
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help