[PATCH] glade: Search for catalogues and modules

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 5 years ago
(address . guix-patches@gnu.org)
97c8db1a352cd9f53c9e17407656e7734ae769e5.camel@student.tugraz.at
Hi Guix,

I noticed, that libhandy still has the glade catalog disabled even if
the module builds fine (although the 0.0 version appears to be broken).
To actually get glade to load them correctly, I had to define some
search paths, which is the actual functionality added by this patch
set. I'm not sure, if other gtk+-based libraries would also add their
catalogs, so for now it's just these two patches.

Regards,
Leo
From 21671bd6a3c193be0b75a29d8edc71be25bae103 Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Tue, 8 Sep 2020 14:03:40 +0200
Subject: [PATCH 1/2] gnu: glade: Add catalog and module search paths.

* gnu/packages/gnome.scm (glade3)[native-search-paths]: Add
GLADE_CATALOG_SEARCH_PATH and GLADE_MODULE_SEARCH_PATH.
---
gnu/packages/gnome.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8f75a4e914..1092065069 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2919,7 +2919,13 @@ API add-ons to make GTK+ widgets OpenGL-capable.")
(description "Glade is a rapid application development (RAD) tool to
enable quick & easy development of user interfaces for the GTK+ toolkit and
the GNOME desktop environment.")
- (license license:lgpl2.0+)))
+ (license license:lgpl2.0+)
+ (native-search-paths (list (search-path-specification
+ (variable "GLADE_CATALOG_SEARCH_PATH")
+ (files '("share/glade/catalogs")))
+ (search-path-specification
+ (variable "GLADE_MODULE_SEARCH_PATH")
+ (files '("lib/glade/modules")))))))
(define-public libcroco
(package
--
2.28.0
From c54baafc4b97e89c241ee3fff765ee84aa2e6e54 Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Tue, 8 Sep 2020 14:08:33 +0200
Subject: [PATCH 2/2] gnu: libhandy: Enable glade_catalog.

* gnu/packages/gnome.scm (libhandy)[configure-flags]: Add glade_catalog.
[inputs]: Add glade and libxml2.
(libhandy-0.0)[configure-flags]: Keep glade_catalog disabled.
---
gnu/packages/gnome.scm | 12 +++++++++---
1 file changed, 9 insertions(+), 3 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1092065069..31c5b0319c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10508,7 +10508,7 @@ advanced image management tool")
(build-system meson-build-system)
(arguments
`(#:configure-flags
- '("-Dglade_catalog=disabled"
+ '("-Dglade_catalog=enabled"
"-Dgtk_doc=true")
#:phases
(modify-phases %standard-phases
@@ -10519,7 +10519,9 @@ advanced image management tool")
(setenv "DISPLAY" ":1")
#t)))))
(inputs
- `(("gtk+" ,gtk+)))
+ `(("gtk+" ,gtk+)
+ ("glade" ,glade3)
+ ("libxml2" ,libxml2)))
(native-inputs
`(("glib:bin" ,glib "bin")
("gobject-introspection" ,gobject-introspection) ; for g-ir-scanner
@@ -10550,7 +10552,11 @@ for usage on small and big screens.")
(commit (string-append "v" version))))
(file-name (git-file-name "libhandy" version))
(sha256
- (base32 "1y23k623sjkldfrdiwfarpchg5mg58smcy1pkgnwfwca15wm1ra5"))))))
+ (base32 "1y23k623sjkldfrdiwfarpchg5mg58smcy1pkgnwfwca15wm1ra5"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments libhandy)
+ ((#:configure-flags flags)
+ '(list "-Dglade_catalog=disabled" "-Dgtk_doc=true"))))))
(define-public libgit2-glib
(package
--
2.28.0
Ludovic Courtès wrote 4 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 43279-done@debbugs.gnu.org)
87r1r58iqg.fsf@gnu.org
Hi Leo,

Leo Prikler <leo.prikler@student.tugraz.at> skribis:

Toggle quote (8 lines)
> From 21671bd6a3c193be0b75a29d8edc71be25bae103 Mon Sep 17 00:00:00 2001
> From: Leo Prikler <leo.prikler@student.tugraz.at>
> Date: Tue, 8 Sep 2020 14:03:40 +0200
> Subject: [PATCH 1/2] gnu: glade: Add catalog and module search paths.
>
> * gnu/packages/gnome.scm (glade3)[native-search-paths]: Add
> GLADE_CATALOG_SEARCH_PATH and GLADE_MODULE_SEARCH_PATH.

[...]

Toggle quote (9 lines)
> From c54baafc4b97e89c241ee3fff765ee84aa2e6e54 Mon Sep 17 00:00:00 2001
> From: Leo Prikler <leo.prikler@student.tugraz.at>
> Date: Tue, 8 Sep 2020 14:08:33 +0200
> Subject: [PATCH 2/2] gnu: libhandy: Enable glade_catalog.
>
> * gnu/packages/gnome.scm (libhandy)[configure-flags]: Add glade_catalog.
> [inputs]: Add glade and libxml2.
> (libhandy-0.0)[configure-flags]: Keep glade_catalog disabled.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 43279@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 43279
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help